[SOLVED] Chord Mojo over USB, Win 10, not showing up in devices

Hi -

I’ve been using Roon for a long time, but after recent upgrade to Windows 10 1809, Roon does not see my Mojo when connected via USB.

Windows itself does see the Mojo - and I’ve installed the latest drivers from Chord - but nothing in Roon. I see my other 2 endpoints (DACs connected to Raspberry Pis on my network).

As background info, I have the Roon core running on my NAS. I saw some similar threads out there and tried deleting the devicedb-prod* files, but didnt help.

Any advice?




Solved by installing Roon Bridge on my laptop, and then running the main Roon app as a controller. But I am pretty sure this wasn’t required before, e.g. the Win10 Roon app (the one with control/core/output functionality) used to connect to my core running on my NAS but also detect locally-connected devices (like my Mojo over USB) - just needed the one app running on my Win10 laptop (which could then also control the networked devices on my Pi’s).

Am I wrong there?

Hello @Justin_Clark,

Make sure that the “Roon” application is not being blocked by a firewall on your computer. Roon’s endpoint discovery relies on access to the local network, even for locally attached zones. I’ve included instructions on how to access the Windows Firewall Settings below.



Awesome - fixed by modify the Defender settings for Roon.exe.

Thank you!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.