SOLVED: Do I really need a static IP to make Roon Arc work?

What else would the IP address be? (Very green behind my ears…)

Could it be that your Port forwarding rule is conflicting with the port uPnp finds? Perhaps try deleting the port forwarding rule and rebooting your router and see what uPnp does.

Maybe I didn’t word that well. The IP address in the port forward rule will need to match the IP of your Roon core server. Roon will show this in the Roon ARC settings page next to where the ARC port is entered.

Your diagnostic messages don’t contain “multiple_nat” so I think that can be crossed off the list.

I just turned off port forwarding on my router then rebooted my nucleus+. The diagnostic message I get is very similar to the first one you posted, except for connectivity shows a NetworkError code :504.

I think the configuration you have with UPnP off should be working. However, I saw in another thread that it looks like the Windows firewall was getting in the way. Also as @Andy_Jones mentions above, some users may need something like the Tailscale solution. I’m not as familiar when a solution like that is needed.

I just deleted what you proposed…rebooted the router…(my wife griped about it because she lost the connection with the TV)…
And you’re not gonna believe it, now I get the multiNAT error:

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“”},
“status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I really don’t understand how this thing works… sometimes you get this, then you get that…

You do indeed have an external IP address, otherwise you could not be on the Internet. Type “what is my IP address” in your browser and you will find out what it is, or currently is if your ISP issues Dynamic IP Addresses.

This gives me indeed the address I got in the error:

Turning off the Firewall on the PC doesn’t change anything
Turning of the Firewall of the ISP doesn’t change anything

So you know that Roon reaches your modem. Can you give us info on your network setup?
1 Which ISP?
2 Make and model of the router?
3 Do you have additional network gear?

All is connected using the following:

Internet (ISP: Telenet Belgium)


  • Firewall active
  • UPnP active
  • No port forwarding
  • DMZ address exists but is not used in Asus Router)

To Asus RT-AC68U router (FW:
Setup as Wireless router mode / AiMesh Router mode (Default)
Other possibilities:

  • Access Point(AP) mode / AiMesh Router in AP mode
  • Repeater mode
  • Media Bridge
  • AiMesh Node

To Switch Netgear GS724T

To Computers

It appears you have two routers which both do NAT. Do you use both to connect devices? Wifi or ethernet?

Nope, ISP modem has only one link to another device, the Asus Router. And Wifi is not used (at least not on purpose)

Diagnostic when UPnP is deactivated in Asus Router:

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: ConnectFailure”}

Diagnostic when UPnP is activated in Asus Router:

“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“”},
“status”: MultipleNatFound
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}


As mentioned no expert on this topic, but i think your ISP modem has UPnP enabled by default and when you turn on UPnP on the Asus router you get the MultipleNatFound error.

I don’t know the DOCSIS 3.1 WIRELESS modem, as far as i could found on Google i don’t see any option to disable UPnP on that device. Maybe @Joost_Hoogland knows more about this or you could contact your ISP.

I can’t help you any further, sorry.

Kind regards,



I’ll explain later…


The solution to my problem can be found in this document:

Open it up and at the bottom you will find this:

I found out that when you activate UPnP, I don’t have to do a Port Forwarding, but when you do, you have to deactivate UPnP… strange, but that’s how it now works here/

So, in my ISP Modem, I made port forwarding from the external ISP address to my ISP Modem IP address, AND I disabled UPnP in the ISP Modem (Enabling UPnP without the Port Forwarding didn’t work)

Then I simply activated UPnP in my own Asus Modem, without Port Forwarding. If I do a port forwarding to the Roon Core, it’s not working, so only activation of UPnP did the job.

Maybe others can benefit from what I found…:slight_smile: , it’s worth trying…


I’m glad you were able to resolve your issue.

I noticed in an earlier post that you also had “Enable Port Trigger” = “Yes” on the Asus router. It didn’t look like you had any port trigger rules defined, so you may want to consider disabling this if you haven’t already.

(If you are interested in seeing the manual port forwarding setup I have on my Asus router, please let me know. I already have it typed up, but it’s very similar to what you already tried. I also don’t have a cable modem that was causing troubles, so the environment is a bit different.)

@Nepherte - what are you talking about? All these IP addresses are private NAT’ted IPs, not public IPs.

13 posts were split to a new topic: Help Needed on Port Forwarding

Wow, I just noticed a reply to one of my other threads…also from an Italian…
His ISP modem doesn’t let him do Port Forwarding with ports higher than 16000. Maybe you can try using another port than 55000, so rather something between 10000 en 16000…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.