SOLVED: Going crazy: Crackling sound with Roon Bridge on RPI3+ to Cambridge 851N with USB2 enabled

Hello Everybody,

I am new to this community, currently testing Roon to see if it’s a fit for me.

I ran into a very strange situation:

I use a Roon Bridge on RPI 3b+ on Dietpi attached to two different audio devices: Cambridge 851N and Dragonfly Red. I am testing the core on different devices. Please note that I have tested with also B&W MM1 but the behavior is the same as the dragonfly in all cases.

At the moment I have installed on my MacBook Pro 15 (i7 top specs) and on my QNAP Nas ts-453 pro with 8GB.

Here is the situation, I get pops and crackles when I play from QNAP core to 851N but I don’t when I play from QNAP core to Dragonfly. The crazy part is that if I switch core to my MacBook Pro the crackles go away. The Bridge remains the same.

Crackles happen with all kind of files, from FLAC 44k/16 to dsd. When upsampling or downsampling, when not touched. Also happens on TIDAL music but a little less.
No crackles when playing local on any roon remote.

My thoughts:

  1. If it was processing power from QNAP core I would have troubles with Dragonfly as well. I monitored the cpu usage with htop and I never get above 30% per core.
  2. If it was incompatibility of drivers / cables or else between Dietpi/bridge and Cambridge 851n I would keep having the problem with macbook pro as CORE.

Both macbook pro and qnap are running on the same auto updated version of roon (latest). Settings of devices are exact replica on the two cores.

I really can’t figure out what the problem could be, honestly it doesn’t make much sense to me. Hopefully you guys can help me figure it out, I started loving roon but I can’t keep my MBPRO on all time when listening to music.

Any advice is very welcome.

Are you using any DSP options in the QNAP core…that might be where things are breaking… failing that flagging @crieke and @support for you

Anything on wifi anywhere in the chain?

I seem to recall people having issues with the 851n and linux which is what will be running on the Qnap. A search of the forum might help you.

Yes I think Tony is on to something…I do recall some issues with that Linux connectivity

Thanks Wizard, tried with both DSP on and off. Same issue. No wifi in the chain , router is professional grade netgear.

Hey Tony, thanks. I read numerous posts and spent hours on this but all that I found was related to the Linux USB Drivers of the RaspberryPi which isn’t really the case here for two reasons. 1. It functions properly with a different CORE, 2. I am using the latest DietPi which works for others.
@support at this stage I believe some more debugging might be needed but I couldn’t find in the wiki what kind info I should be looking for? I am good with Linux up to compiling my own kernels if advanced debugging is needed. I am a techie.

Can you update the ffmpeg package that your Qnap server uses and see if that makes a difference?

That’s for direct attached to the dac not as a networked device. @Marco_Borza are you connecting the pi direct via usb to the Cambridge audio. The pis usb is known to be a bit iffy and if using the LAN port it shares the same bus as the usb so they can interfere and some have had issue with the new GB ethernet in the new models… Try using using wireless with a b+ to see if it helps or 100MB usb adaptor instead.

1 Like

Hello @Marco_Borza,

Could you report what version of QTS you are running on your QNAP device? Do you get the crackles if you use the Cambridge 851N Airplay input with your QNAP as the core? You could also try setting the Cambridge 851N to “USB Class 1” audio in the settings on the device.


1 Like

I’d guess that the buffering in the two devices is different. The 851N perhaps requires more just-in-time delivery of packets, and the reduced processing power of the QNAP means that fails sometimes, compared to the MBP. Assuming USB connection from Pi to each device.

1 Like

Hello @john

No cracklings with airplay and surprisingly no cracklings with USB mode 1 but of course 96khz max so no DSD fun for me. Big step forward however!!! At least I can enjoy Tidal and up to 96khz.

My Qnap details:

uname -a
Linux QNAPHOME 4.2.8 #1 SMP Thu Aug 30 01:19:06 CST 2018 x86_64 GNU/Linux
FW Version Build 20100830

would it make sense to try wifi instead of ETH considering with MBP core works well?


It sounds reasonable. but htop shows clearly that I get on peaks to max 30% CPU.

Found a QNAP package for 4.x I am now running 3.3.6 .
Installation is taking forever. Trying this . Will let you know tomorrow morning.


  1. FFMPEG makes no difference.
  2. Problem is now present also with MBP as CORE , maybe It was always there but I didn’t notice
  3. Using QNAP as core and attaching dac in USB2 mode to MBP works perfectly
  4. Tried high quality USB cable, same issue (esoteric attempt)

At this stage I believe is goes down to the USB drivers of the RPI for my DAC? I investigated more on the cambridge side and indeed they support my device only for Win and Mac.

At this stage my options are limited, either stay with usb1 96khz max or use airplay (which is terrible to my ears).

@support in this changed scenario, is there anything you can do to help me? I only have a few days of trial license and I fell in love with Roon, but can’t really justify spending 2000+ on a different DAC/Streamer just for this.


Sounds like you just need to replace the RPI3, right? You need something else to replace the Roon Bridge. For under $200, you can get a USBridge from for that.

Well, no, apparently not. See SMS 200....Is it a good upgrade?.

But perhaps this:

Im using the sms 200 to the CA 851N via USB set at Class2,…Rock on a nuc 7i5, im getting full hi res output, obviously no artwork.Also i have a Sbooster on its way for the SMSbut will try it on the Nuc aswell.

Did you try using the inbuilt wireless on the pi to see if it helps? The gige adaptor for LAN is crappy on the latest versions.?

Simon… 100% right! On wifi I am able to use USB2!!! Thank you a million.

Thanks @CrystalGipsy, @Bill_Janssen, @Henry_McLeod, @Tony_Reimann, @wizardofoz for all the support. This community is really great.

In the process I learned a lot about Roon and I will most likely buy an Allo DigiOne board for my RPI 3 B+ and go SPDIF. I heard it makes everything sound much better thanks to reduced Jitter and isolation.
At this stage indeed I have to say that my 851N plays nicer with it’s internal player which is most likely optimized for clock/jitter which I hope I can solve with SPDIF. In the future I will surely consider Roon Ready devices first.

And now, time for a nice listening session!


Update: Just ordered Allo Digione board upgrade for my transport. Should be able to test this weekend and let you my impressions with my hw.