(Solved) Nevermind - No Sound with Resampler on Power of 2 mode or MAX Bitrate Mode (Custom mode does works for 44.1->96khz)

I’ve recently updated the Raspberry Pi 3 ( HIFIBERRY DIGI+ PRO H.A.T installed.) running the latest update of DIETPI (this morning) & the RoonBridge was restarted and shows it’s up-to-date.

The file shows it’s playing in the remote and the GUI, but there’s no sound with the resampler turned on while in ‘Power of 2’ mode or ‘Max Bitrate Mode’.

Custom mode does works at least for 44.1khz -->96khz which I have successfully tested.

Not a biggy, I’m just mentioning it.

(ROON SUPPORT - This issue can be closed. I did some research on my DAC in a secondary listening room and found it it doesn’t support Power of 2 sampling rates or sampling rates above 96k. I incorrectly assumed it could handle 24/192 DAC.)

No help to you, I’m afraid – just adding a data point: my Pi2/Digi+ Pro is working fine with all options (Max PCM, Power of 2, custom). Running DietPi B143 as well.

None of the DSP functions are working for me… Other threads on the matter exist. No update from Roon.

Thanks for your post, RBM, it motivated me to verify compatibility of my DAC with power of 2 and max 24/192 sampling rates. I finally verified that zone’s DAC is limited to 24/96 and doesn’t support power of 2 sampling rates at all. I’ve reconfigured Roon to down sample dsd to pcm, power of 2 sampling rates, and restrict sampling rates to 96khz or below.

Thanks for the sanity check! =)

1 Like