SOLVED: Roon Ready endpoints lose connection. Others do not

Here’s the setup: Roon server running on purpose-built PC with Linux OS. Endpoints: Sonore Ultrarendu, Elac Discovery (using only as an endpoint), Apple TV. two PCs running Squeezesoft. Controlling this using Roon app on iPad or on one of the connected PCs.

Network: Server hard wired to wireless router, Dlink wireless hub in next room connected via WPS and all endpoints connected to this hub.

This setup was working rock solid until just recently.

The Sonore and the Elac are Roon Ready endpoints. It is only with these that I see a problem. ALL the other devices are rock solid with no issues whatever.

The problem is the Roon Ready endpoints keep losing connection to the server. Roon sees the endpoint, music starts playing, then the endpoint disappears from Roon for a few seconds (the music stops) and then it (usually) returns. This behavior is repeatable and seems connected to recent software updates. Sometimes the Roon Ready endpoints do not appear at all and I have to start and stop the Roon control app several times to “find them.” Then the behavior described returns.

I tried bypassing the wireless section of the network by running a temporary Ethernet cable across the house connected directly from the main router to a separate temporary hub with just the Roon Ready devices connected to it. The behavior was the same, so it has nothing to do with the wireless connection.

I do not accept that there is something wrong with my network. If this was the case, why do the Squeeze and iOS devices play back with no issues from the same network connection? I might also add that this same wireless hub setup is used to stream HD Video to my ROKU, and it is rock solid.

Is Roon aware of this issue with the Roon Ready software? What can I do to fix this as it is unacceptable.

Thanks for reaching out, @David_Yohn!

So I can get some additional insight into what may be occurring, may I ask that you please verify the following:

  • Can you confirm that you are on the latest version of Roon and that the firmware is up to date for the Sonore and Elac endpoints?
  • While it may seem elementary, can you confirm for me that you’ve power cycled your Core machine, endpoints, and networking hardware since you’ve noticed this?
  • What router are you using?
  • Where is your library stored? How large is your library?

Have you noticed any patterns in when you notice this behavior occur? Does it happen during certain times of day, or when you’re playing specific types of content?

In order to narrow down where this behavior may be stemming from, I’d like to propose a test. If you use a different machine as the Core temporarily (one of the PCs you mentioned above) do you experience the same behavior?


Dylan, Replies to your questions:

  1. Endpoints are updated to the latest (RAAT SDK 1.1.19 reported on the Elac, Roon Ready 1.1.30 on the Sonore). Roon core is Version 1.5 build 334 (full lifetime license). Roon Core is on a server with a 4-core AMD processor, 16Gb RAM, SSD for the Linux OS, 2Tb WD red hard drives for the media.
  2. I have power cycled the endpoint devices, but NOT the Core machine. I will do that now.
    OK, completely powered down, waited for a few seconds, then back up. The same behavior returned. By the way, Roon tells me the Elac is Roon Ready but there is an “Uncertified” comment in the Audio settings screen. Also, while looking at the Roon Audio Settings screen, I can watch the Roon Ready devices come and go, like they are there then they disappear for a second then they are back. Also, sometimes I see an error message in the Roon control app about files being slow to load, but not every time.
  3. Routers: DSL modem/router is a Technicolor C2100T from Century Link. Access point is a D-Link DAP 1650. Both have been rebooted. Connection between the two is WPS.
  4. Library is on hard drive in main core machine. Library is 1.3 Tb in size.

Behavior is any time, all the time, while playing any track.
I have not tried using another PC as a core, but will try that and report back.

Ar there any diagnostics or logs I can get from Roon that might helop troubleshoot?

Thank you for the support

Just a thought, but what happens if you shut down the Elac Discovery? Does the remaining Roon Ready Endpoint continue to come and go?

Geoff: yes. The Rendu was doing this before I added the Elac. Indeed, the Elac was intended to replace the Rendu as I thought it had a hardware issue.

Dylan, I installed Roon Server on one of my PCs, a Win 10 box. The endpoints exhibited the same behavior.

Thank you

Thanks for the info, as well as for giving that a try, @David_Yohn.

Since this is happening for both Core machines it seems that there may be some networking difficulties at play here. The best way to verify this is to simplify the networking setup and see if the issue persists. I’d like to propose a test that should give us some greater insight into what is occurring.

Temporarily disconnect the D-Link access point, as well as the Sonore endpoint. Then connect the Elac Discover directly to the router (bypassing the other hub you mentioned). Try to play to the Elac endpoint once you’ve done this.

If the Elac does not exhibit the same behavior then we can start adding in additional components piece by piece until we see when the Elac starts showing the same behavior. This way we should have a clear idea of where the behavior is rooting from.

Alternatively, if the Elac continues to exhibit this behavior even with the simplified setup, I’d like you to make a note of the time in which this behavior occurs. Send the timestamp to me and I’ll enable diagnostics on your account. Once we have the diagnostics report I will send it to our tech team for analysis.

Kind regards,

Ok thank you, I will try that.

1 Like


I moved the Elac into the same room as the server and connected via Ethernet to the same hub as the server. the Elac endpoint is doing the same thing, turning on and off in the Roon control app (running on a PC also hard wired to the same hub.)

This just happened At 11:27 AM local time and repeated at 11:29 AM.

Thanks for giving that a try, @David_Yohn.

Just to confirm, the hub you’re referring to is the router you mentioned above, correct?

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


Update — The diagnostics report has been received.

Yes, the router mentioned above, sorry. I see the report was sent. Please let me know my next steps. Thank you for your support!

1 Like

Dylan, I look forward to any updates

Thank you for your time!

Hey @David_Yohn,

Thanks for your patience here while we’ve been investigating, it’s truly been appreciated! I had a long discussion with the team today and we have some next steps for you.

First, can you confirm whether or not you have used Roon Essentials with the Elac Discovery? Have you logged in at all? If not, can you try logging in using Roon Essentials and see if there are any updates available?

Next, we noticed that the Technicolor router you’re using has previously been the cause of some networking troubles similar to what you’ve described. If you have another router you could temporarily test with that would help to confirm whether or not the router is contributing to this behavior. Alternatively, if you have a switch available, can you try connecting the Core machine and your Sonore Ultra Rendu device to the switch and see if the behavior occurs when playing to the Ultra Rendu?

Additionally, by using the Ultra Rendu web interface, can you share a screenshot of your Apps tab settings?


@dylan Hmm. I do not know if I have a switch that will do that. Let me look. Also, the Ultrarendu is still back with Sonore being tested as I at first thought it was having a hardware issue. It is fine and they are returning it to me.

  1. What about the Technicolor DSL modem/router is interfering? Is it something I can change? I tried disabling QOS and no effect.
  2. Why did everything work before? The Technicolor has had no firmware nor software updates. The only software change was the last Roon update.
  3. I can connect to the Elac using Roon Essentials and have made sure it has all the latest updates.

Thank you

Hey @David_Yohn,

I would look into advanced settings on the router and see if there are any firewall or multicast settings. Share a screenshot of what these settings are so we can take a look.

When did you first notice this behavior with the Ultra Rendu? Was it right after the latest update? It never happened prior to that?

Thank you for confirming this.

On the Core machine I’d like to try with a fresh database and see if there is any change in behavior. Please see the following steps:

  • Make a backup of your Roon database
  • Stop Roon
  • Locate your Roon database according to these instructions
  • Rename the entire RoonServer folder to roon_old
  • Relaunch Roon, sign in, and configure a new install

Try playing to your Elac, preferably with the Core and Elac directly connected to the router via Ethernet (fresh database with a simplified network). Let me know if you still experience the issue with this setup.

Note that you can switch back to your old database when you’re ready by stopping Roon, and changing the roon_old folder that contains your old database back to RoonServer.

Thank you,

@dylan, that was very useful information. I went into the Technicolor modem advanced controls and disabled the IPv6 firewall, and it SEEMS the problem has stopped. I will monitor this today, and it is just with the Elac at this point, but something in the IPv6 firewall seems to have been interfering. The IPv4 firewall remains enabled as before.

Please leave this open for now as I want to do more testing, and also see what happens when I get my Ultrarendu back from Sonore.

Question: does Roon use IPv6 and if so what ports need to be open?

Thanks for the update, @David_Yohn!

Roon uses IPv4, so you shouldn’t need to worry about those ports. It is interesting that changing that setting has changed the behavior. Definitely keep me update! If the issue comes back or you have any other questions just let me know!


Interesting indeed. There must be something in the IPv6 firewall that interfered, but who knows what that might be? In any case it might be an easy solution for anyone with similar issues.

Also, I moved the Elac back into the music room, connected to the wireless access point, and it’s been playing flawlessly for the past hour. I will keep you updated.

Update. I now have my Ultrarendu back from Small Green Computer, and it too works fine now. So here is the upshot:

If a user has a Technicolor C2100T DSL modem/router, disabling the IPv6 firewall may be required for Roon to work properly on the network.

Thank you to @dylan for the support and patience. I am very appreciative. Also a shout out to Andrew and Jesus at Sonore and Small Green Computer, as well as to Chris at Elac, all of whom assisted in troubleshooting this issue.

1 Like