SOLVED - Roon stopped identifying Sotm network device

My system has stopped working, and I can’t figure out why. I’m not a network or computer audio expert, but I’ve tried everything I can think of, and read the Roon “FAQs.”

My setup: Roon Rock on Intel NUC. OS Version 1.0 (build 158) stable, server Version 1.5 (build 354) stable, 64 bit. Control is running on an iPad, most recent model. NUC connected to my Netgear AC1750 router. Router firmware up to date.

Router connected to SMS-200ultra network player by a TP-link powerline network adapter (AV2000, model TL-PA9020P). The SMS-200ultra connects to a tx-usbultra, which connects to the Kii control of my Kii active speakers.

This all worked fine for several months. Then, without any change in the setup that I was aware of, Roon stopped locating the sotm sms200ultra on the network. cannot figure out why.

– Roon continues to recognize my other devices (the ipad itself, and an airplay device, a Muzo cobblestone, that I use to stream background music in my kitchen).

– The TP-links seems to be working, and the sms200ultra is visible on my network. I can access the sms200 using its IP address in my browser. I upgraded the sms200 software to the most recent version. Roon endpoint is set to active in the sms200 software.

– I updated both Roon core and controller to most recent software versions.

– I’ve power cycled everything many times.

– The Kii components are working fine. I know this because I can play music by plugging my laptop directly into the Kii control.

– I can also play music through the ipad by making it the active zone in the Roon control software.

But Roon has stopped recognizing my sms200ultra endpoint, and I can’t figure out why. If I go into settings, the only Networked device it shows is my airplay device ( It used to show the sms200 too, but not anymore. I can still see the sms200 on my network in the Mac Finder.

Screenshots attached. Can you help with this?

Thank you,


Roons discovery relies on multicast protocol which powerlines can have issues with. As a first step if you have not already would be to power cycle the powerlines at both ends and all your network gear. Then power the on in order.

If this does not work check via web interface to the SMS what the IP address being assigned by your router to the SMS is. It should be in the same IP range as the core and other endpoints. Take note of the 3rd number and make sure this is the same as the rest. If not then something on your network is creating a different subnet for them and Roon does not work over subnets.

Something else may be going on here. Your advice is spot on, but this is the second (maybe more) report that devices are suddenly not discovered on the network after having worked for a long time. A Devialet user has just said that Roon (on Linux) no longer sees his amp after months of working fine. Different protocols AIR vs RAAT for sure, but I think discovery is the same. @support should be alerted here too.

simon_arnold and ogs:

Thank you both for your responses.

Ogs: I tried power cycling again. (I’ve done this many times already–actually left the system unplugged for a week or so because I was busy and tired of trying to get it to work.) I unplugged both powerline adapters, the sotm equipment, router, and even my cable modem. Plugged it all back in. Didn’t fix problem.

Then checked IP addresses as you recommended. To me, they look okay. (Screenshot attached.)

simon_arnold: It’s true, my setup worked for months, and then stopped working for no reason that I can figure out.

How can I alert support? I thought this was the support forum.

Thank you again.

I’ve alerted support in my response. I guess Roon support monitors this area, but ‘@’ in front of the username gives a direct alert. Like @Charles_Wells does :smile:

Thanks ogs

Another data point: the SMS-200ultra does seem to be recognizing the Kii control.

From :

**** List of PLAYBACK Hardware Devices ****
card 0: Control [Kii Control], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 004: ID 20b1:0401 XMOS Ltd
Bus 002 Device 003: ID 20b1:30a2 XMOS Ltd
Bus 002 Device 002: ID 0424:2512 Standard Microsystems Corp. USB 2.0 Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
0 [Control ]: USB-Audio - Kii Control
Kii Audio Kii Control at usb-1c1c000.usb-1.1, high speed
Kii Audio Kii Control at usb-1c1c000.usb-1.1, high speed : USB Audio

Status: Stop
Interface 1
Altset 1
Format: S32_LE
Channels: 2
Endpoint: 1 OUT (ASYNC)
Rates: 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000, 705600, 768000
Data packet interval: 125 us
Interface 1
Altset 2
Format: S16_LE
Channels: 2
Endpoint: 1 OUT (ASYNC)
Rates: 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000, 705600, 768000
Data packet interval: 125 us

Another data point: I reinstalled the ROCK OS (same build, 158). No change.

Hello @Charles_Wells,

Thanks for contacting support, I’d be happy to take a look over this issue with you.

We have previously seen issues in the past with using Powerline adapters and I believe that the best course of action here will be simplifying the network as the first troubleshooting step.

Can I please ask you to connect your ROCK, the sms200ultra directly into your Router via Ethernet and connect the Roon Remote to the Router and verify if you are still experiencing the same issue afterwards?

Do you have another DAC around the house that you can connect to the sms200ultra to verify if this issue affects all DACs connected to the sms200?

Please let me know your findings when possible.


Thank you for your reply. Taking the powerline adapters out of the system did not help.

However, the problem is now solved. After making no headway for awhile, I messaged sotm. They recommended several troubleshooting steps, which didn’t help. Then they asked me to download an as-yet unreleased alpha version of their Roon Ready software, and that solved the problem.

My best guess is that maybe some recent Roon software update is incompatible with the current sotm software. The new version they’re working on apparently fixes the problem.

Sincere thanks to everyone who contributed to the troubleshooting process.