SOLVED: Trouble with adding radio stations


(Chris ) #5

This is what I use

http://a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/hls/uk/sbr_high/ak/bbc_radio_three.m3u8


(Martin Webster) #6

Looping in @support for some help. @Mesmo please provide some details of your setup as described in the following KB article. Thanks.


(Noris) #8

Hello @Mesmo,

I have tried the various radio links posted here, the only one that I was able to sucessfully use was the tunein one (https://tunein.com/radio/BBC-Radio-3-913-s24941/) but this may be because the other links are geo-blocked for my location (US).

Can you please let me know if the behavior is the same when trying to output to all of your zones or even “System Output” and provide more information regarding your setup using the link Martin posted?

Thanks,
Noris


(Martin Webster) #9

@noris Yes, the BBC use geo-blocking.


(Chris ) #10

In the UK we pay a license fee for BBC services. The TV Licence. It cover TV Radio and all,other BBC offerings. I am surprised they haven’t thought to offer an international licence to raise funds as I expect the demand would be strong.


(Dave) #11

Hi Noris,

I am UK based, to the geo sensitive station should work for me (and does in a web browser) - I’ve also tried the global ones and have the same error setting up the stations.

With the TuneIn station, the target zone makes no difference and I still get the Transport: Failed to load media problem.

As per Martin’s earlier post, my setup is (shown here):

  • Core 1.5 (build 363) running on IBM Lenovo T61p with Ubuntu Server 18.04 LTS
  • Storage OpenMediaVault on a Raspberry Pi and 2x Western Digital Passport 1Tb drives
  • Both of the above hard wired into a Netgear GS105 switch which in turn is wired to the primary Google WiFi point
  • Meridian 218 and MS200 wired into a secondary Google WiFi point for main two systems
  • 2x B&W Zeppelin
  • Remote (that I’m trying to use to set up radio): macOS 10.14.1

All working flawlessly for music from OpenMediaVault


(Noris) #12

Hello @Mesmo,

Thanks for confirming the setup details. Do other Radio stations work as expected or is other online content such as TIDAL working fine? If other radio stations do not work as expected, I an wondering if there might be something amiss with your DNS settings and Roon not being able to resolve the station’s streaming URL. Can you please try updating your DNS servers to Goolge’s DNS or Cloudflare and let me know if that helps?

Thanks,
Noris


(Dave) #13

Thanks for the suggestion - I’ve tried configuring both Google and Cloudflare DNS on Google WiFi (which acts as a DCHP server for all devices so assuming it passes those DNS settings on to its clients) and no change. I’m unable to change the DNS settings on my router (Sky hub).


(Dave) #14

Further to this, I’ve not managed to get any other radio stations working, though historically I have had internet radio working.


(Larry Post) #15

Be sure to renew each devices DHCP lease or they won’t pick up the new DNS server info until 1/2 through the lease expiration. Restart is likely the easiest option.


(Dave) #16

Sadly no joy after a reboot either…


(Noris) #17

Hello @Mesmo,

Since other radio stations are not working as expected, I am wondering if there is something wrong with the Ethernet cable from your Core or with the network switch. Can you please try using a different Ethernet cable or connecting your Core directly to your router to verify if the same behavior occurs?

Thanks,
Noris


(stan pennock) #18

My experience is/was that adding a URL from the actual radio station itself does not take. Rather, the URL must be from an internet radio provider, like Internet-radio.com.


(Dave) #19

So, I’ve made a little modest progress in my trouble-shooting… when I move the core onto a different machine (running macOS Mojave), Internet Radio works as expected.

When I return to my core on Ubuntu on the Lenovo the issue returns.

So what immediately springs to mind is my installation of the linux dependencies (ffmpeg et al) - any advice on how to verify that they’re all present and correct?


(Noris) #20

Hello @Mesmo,

I want to try something different. Can you please try pasting the stream URL in Roon Radio on your Ubuntu Core? For example (http://icy1.abacast.com/kplu-newsjazzmp3-32)? Does this link work as expected?

If so you may be experiencing the same issue as this thread which QA is investigating now:

Please let me know if that link works and if it does you may be able to get the BBC stream working by posting the stream link instead of the tunein link (http://opml.radiotime.com/Tune.ashx?id=s24941&formats=mp3,aac)

Thanks,
Noris


(Dave) #21

Nope - that gives me the message “Roon could not find a radio station at this URL”.


(Noris) #22

Hello @Mesmo,

Thanks for trying those links and verifying that it is not the same issue. I think you may have been right regarding the dependencies for your radio station, can you please check to make sure you have the proper dependencies installed for your linux Roon build? You can use the commands listed here to make sure that they’re installed properly:

For  ffmpeg :

$ sudo apt-get install ffmpeg

For  avconv :

$ sudo apt-get install libav-tools

These commands are from our Linux Setup Guide

Thanks,
Noris


(Dave) #23

Thanks Noris,

I really struggled to install ffmpeg originally as I was unable to find it using apt-get, but did manage in the end using:

$ sudo snap install ffmpeg

I’m running version 4.0.2 of it currently.

If I try using apt-get I get an error:

Package ffmpeg is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package ‘ffmpeg’ has no installation candidate

I get a similar error when trying to install libav-tools:

E: Unable to locate package libav-tools

So I installed libsound2 via apt-get.

If I run /opt/RoonServer/check.sh I get this response:

Checking to see if RoonServer can run on this machine
Checking for Binary Compatibility [ OK ]
Checking for ALSA Libraries [ OK ]
Checking for ffmpeg or avconv [ OK ]
Checking for the mount.cifs command [ OK ]
Testing ulimit -n 8192 [ OK ]
STATUS: SUCCESS


(Noris) #24

Hello @Mesmo,

Thanks for letting me know. I have passed your feedback to the QA team who will take a look at the log snippet you posted and I will be sure to let you know once I hear back from them regarding next steps.

Thanks,
Noris


(Noris) #25

Hello @Mesmo,

I spoke to the technical team today and they have confirmed that the issue you’re seeing here is because you don’t have ffmpeg installed on your Ubuntu Core. I would take a look at these instructions to see if they help with the installation of ffmpeg:

Please let me know if this helps.

Thanks,
Noris