SOLVED! Two problems with nucleus setup (usb storage + directstream)

[Mysteriously but not surprisingly, four hours after I posted this, after all the wire shifting and rebooting of the DAC, the Nucleus rebooted itself, and now it works. Go figure.]

Just got my Nucleus. It’s beautifully finished, solid and elegant. Bravo.

Here’s what I had:

  • Macbook pro, connected by thunderbolt/ethernet adapter to a dumb 5 port switch. On that switch was the NAS 520 and an ethernet cable to my PSAudio DirectStream DSD.

  • Also on that Mac was a 2 tb USB solid state drive, connected via USB.

  • I used wifi to control the mac from my other mac running Roon as a remote, and also used the wifi to connect to Tidal.

Everything worked, all the time.

Switching to the Nucleus required me to get the internet to the new box, so I bought an inexpensive WIFI N adapter/extender, which, amazingly, worked the first time via WPS to my router.


Okay, so now, into the dumb switch goes:
Ethernet for PSAudio DAC
Ethernet for NAS
Ethernet for Wifi

And a cable to the Nucleus.

I sit down at my remote Mac, and boom, it works! I can see the Nucleus. First time.

I was able to find the internet and set up Tidal via the remote. First time.

I was able to set up audio to my Sonos in the kitchen. First time.

I was able to find the path to my NAS and set it up. I’ll say First Time for symmetry, but it took two tries. Still. Amazing.

Now, the two problems (thanks for bearing with me)

  1. The USB 2 tb drive doesn’t appear when I try to add a folder. I’ve put it in the top and the bottom port. Nothing shows.

  2. More important, I can’t see the PSAudio on my list of devices. I can see the Sonos in the kitchen and play music there, but the DirectStream doesn’t show. I’ve restarted the DirectStream but that didn’t help.

Audio settings dashboard, below.

Thank you support for all the support and magic.

Doesn’t the Nucleus have a gigabit Ethernet port?

Right, the ethernet port is plugged into the switch, so I can network the NAS, the DirectStream and the wifi extender.

Am I missing something from your question?

I can’t plug the wifi router in directly because wifi comes into the other side of the house and I’m unable to string a long cable.

here’s a pic of the dumb switch:

and here’s the switch:

Ok, sorry I misunderstood.

I suppose the first question I’d ask is what file system is the USB SSD using and is it compatible with Nucleus? I dont know what the Nucleus supports, so it could be a stupid question!

Do you have any other USB storage devices you could try to see if its a problem with the Nucleus or the USB device?

great question, @Tim_Rhodes

I grabbed a usb memory stick, plugged it in, it worked

for kicks, I put the unplugged Transcend drive back on my Mac, it didn’t appear.

Switched to the other USB port, ran disk utilities, mounted it, ejected it, put it back on the Nucleus

and it worked

4 points for gryfindor. Thanks for that.

Now, if I could only get the music to play on my dac…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.