Some tracks from album in watched folder not importing [Fixed - Pending 1.3]

Hi,

@support I have recently purchased the digital download version of Whelm by Douglas Dare from Erased Tapes. When I add the files to my Roon Watched Folder only track 10 is imported. I have tried re-scanning to no avail. I have also tried deleting the album, re-downloading from Erased Tapes and importing again with no change.

Any clues as to what may be causing this? The fact that it picks up one track only is odd.

I have been using Roon for nearly 2 years with the same setup with no issues. If required I can provide a Dropbox link to the files in question.

See the attached screenshot for reference.

Thanks in advance.

Hey @mikedowsettgive this a read, and if you’re still stuck, let us know.

It would be helpful to know what platform your Core is on, and what storage device you’re using. Thanks!

Yep. That was the first thing I did. Still unable to resolve unfortunately.

Core is sitting on a MacMini and the files are on network drive. As mentioned earlier it seems odd as track 10 is picked up fine. I bought and added 5 other albums to same network drive at the same time and they all imported just fine. Thanks.

Are you sure there isn’t another album with some or all of the other tracks.

Sometimes albums get split, but if you can find them, they can be merged.

Cheers, Greg

Ordering the album browser by date added can sometimes help spotting misidentified tracks.

I also thought this might be the case so I exported all tracks to Excel and sorted by file path. See the below screenshot. It seems as though Roon is definitely only seeing track 10 when there are another 9 tracks in the same file location.

Hey @mikedowsett – do you want to zip up the album and PM @support a dropbox link or similar? I can also give you a way to upload the media to our server.

1 Like

Hi @mike - I have sent PM with a Dropbox link to the files in question. Let me know what you discover. I appreciate your help with this.

in the filenames I see a lot off Special Characters. Do not use them.
Change the tags!. Many servers do not like them.

@Roony - None of the ‘Special Characters’ used in the folder names are in the below list of characters to avoid:

Avoid using:
< (less than), > (greater than), : (colon - sometimes works, but best avoided), " (double quote), / (forward slash), \ (backslash), | (vertical bar or pipe), ? (question mark), * (asterisk), $ (dollar sign), ` (backtick), and ~ (tilde)

I removed and renamed the folder names anyway to be on the safe side but no change. If the naming of the folders was an issue this doesn’t explain why track 10 is seen and imported whilst tracks 1-9 are not seen and are not imported. There are no special characters of any sort in the actual filenames.

Thanks for the suggestion though!

Huh? None of those characters are event remotely a problem for a modern file system. Of everything in that directory the only one that could cause an issue for poorly written code is the ’ and that file got successfully imported!

Now if he had a lot of ?$!^% then I’d be a little more skeptical :slight_smile:

I see a pdf with the name Nine…
Track 10 is ok.
Maby you must remove the pdf, ha ha.

Did you check if a folder or filename ends with a space? Hard to spot, but may evade detection by Roon.

Yep. Done that and no spaces anywhere [sigh].

OK. So I just downloaded the MP3 44.1kHz 16bit 2ch, 320kbps version from Erased Tapes. Same file structure and file naming as the 24-Bit Master. Roon imported the Mp3 version fine with no problems.

So must be something to do with the files themselves. @support have a copy of the original 24-Bit files so hopefully they can shed some light on the problem.

Excellent album though… when I can get to listen to it!!

Convert the files to flac.
Did it for me with another CD.

@Roony - A gold star for you. It worked! Thank you for the suggestion.

1 Like

Hi @support, was this issue ever resolved? Converting problematic files is just a fix and not a solution. I seem to be having the same issue suddenly (on both FLAC and mp3 that were working before). My entire “A Tribe Called quest” discography just vanished from the library.

Hi @Joost_de_Bonth ---- Thank you for the feedback. I wanted to touch base with you as a fix has been made and is set into place pending the release of 1.3.

Moving forward, it sounds like you may be experiencing a different issue here. This thread had to do with tracks not importing and from your report it seems like content was at one point available in Roon and now it is not. Is this correct?

-Eric

Yes that is correct. I have had all kinds of content missing for about a week, and it all seems to be back now. I have not touched anything in the meantime. Will keep an eye out for this and let you know if it happens again.

1 Like