Some Tracks Now Have 2 Parts

Okay, To save space on my iMac’s SSD, I moved my entire iTunes Library to an external HDD. Now, some but not all of my tracks have 2 parts and the song will play twice before moving on to the next track. You can see this in the bottom right corner of this screen capture:

Here is the file info:

There is only 1 music file with that name in that location. If you get info on the track when the second part is playing, it has the same path.

Anyone have ideas on how to fix this?

Thank you!

First, try restarting Roon.

If that doesn’t fix it, make a backup, then head to Settings > Storage, here are some things to try

Try them in this order one-by-one, and only keep going if you’re still having an issue :slight_smile:

  • Confirm this storage location/folder is only added to Roon once

  • Force a rescan

  • Remove the folder, restart Roon, and re-add it

I did all of those things and none of them solved the problem. FYI:

“Roon” music contains albums not in my iTunes Library.

Okay, I fixed it…or it fixed itself. I listed all the track in my Library and did a “Command-A”. Then I told Roon to “Re-Identify” all the tracks. Once I did that, any new songs that came up in “Radio” were fine. Maybe it was the radio that was screwed up and not the library.

Thanks for the suggestions!

1 Like

@mike ,

By the way, I really appreciate the fast and helpful support you folks at Roon provide. I’ve had a couple of issues and each time the response has been quick and on target. When one considers the quality of the product, the features, and the support provided, the price I paid for a lifetime subscription was a bargain!



Thanks Scott! We really appreciate that!

Have a good weekend!

1 Like

This topic was automatically closed after 27 hours. New replies are no longer allowed.