Something strange with number of tracks imported (bug?)

Since a few weeks the number of classical tracks imported is a negative number.
If I add a new album, this number decrease, as in the example below. And this happens only for the classical folder. Note that I had already observed this with the previous version of Roon. I suppose this is a bug…

Hello @Thierry_M,

It does look like a bug, though I’m not sure how you ended up in this state. Let’s start from a brief but accurate description of your current setup using this link as guide.

In regard to the behavior you observed:

  • Have you tried to reboot Roon Core ?
  • When did you notice the state for the first time ?


Hi @Vova

I have rebooted Roon… and now the number of classical tracks is ok.
But I’ve noticed this problem since about two months, I would say (I didn’t report it sooner because it is not really annoying). And I know that I rebooted Roon some times since then.
Well, now it is ok… I’ll get back to you if it occurs again.


Hi @Vova

Same problem again. Strangely, it occurs always for the same folder (the “Classique” folder).

And once again, after rebooting Roon, it came back to normal.

Roon core is installed on a QNAP NAS (TVS-471).
Roon version is 1.4 (build 294) stable (64bit).
Collection size: about 22000 tracks.

Thank you,

Hi @Thierry_M ---- Thank you for the follow up and update on this observation you have made. both are appreciated.

To provide you with an update, I have a meeting setup for early next week with the tech team and a members of the Dev team to discuss this behavior you are reporting to see if we can get some feedback as to what may be causing it to occur. Once I have a clear sense as to what the next “troubleshooting steps” should be in addressing this issue I will be sure to follow up with you asap.


I’m getting a similar error: number of files imported is definitely corrupted. If I click edit against the storage (and i have one watched folder only on a local hard drive), change nothing, click save, the system starts to recheck the folder, but starting with a negative number, so the final result continually reduces.
However when i click the tracks number in the overview, the number listed is i suspect the true number; the display right now says 18610 of 18364. So i dont think i’m losing songs, it’s just not counting up properly.
Latest build of linux server. On lubuntu latest version.

I’ve just stopped and restarted roonserver.
The “number of tracks imported” under watching folder in real time is back to 18622, and the display by tracks shows 18650 of 18610.
Another media player/manager tells me it has 18662 tracks, so the numbers are in the same ballpark. I’ve been checking over and over trying to work out why roon is ignoring files, and noticed this anomaly. (And number of skipped files = 0, and all 3 numbers in the “clean library” option are also 0)
I’m assuming the alleged missing 12 tracks (18650 vs 18662) equals 1 album (though it might not) so have been going through my library trying to determine whats missing by comparing roon back to a file list extracted into a text file - very laborious. I went though nearly 1500 folders comparing to the albums in roon and havent yet spotted the missing one!

I’m still having the same issue. And the symptoms are still the same: this only occurs for one folder (I have 5 different folders on my NAS, and it occurs only for the “Classique” folder).
And I’m pretty sure that no file is ignored by Roon - so the problem is not really annoying.

Managed to sort out the file discrepancies.
Took out “hitchhiker’s guide to the galaxy” which was 292 mp3’s and actually didnt want in my roon library, simply moved the files elsewhere out of the watched folder.
Exported roon to Excel and Jriver to m3u file, compared the 2 in Excel, found the original 12 tracks missing - Fleet Foxes “Helplessness Blues” in m4a format; converted to flac and the album showed up in roon.
So now roon = my music library, no files missing or skipped.

So here are the screenshots of the files imported / tracks etc.

18165 according to the overview

18165 according to the watched folder

18165 according to the number on the right
18330 according to the number on the left, and this number is confirmed now as correct.

so that’s now the only number displayed that I can trust.
@support have you seen other instances of these discrepancies? many thanks

@support still struggling with this one.
My library is now 18181 tracks and I have confirmed a 100% match by extracting to Excel and comparing to a file extract from the directories. I have also removed all non alpha characters from the filenames and paths (changing Björk to Bjork, removing symbols etc just in case roon was skipping over something it didnt like, and this did help to get the number of tracks up to 100% inclusion in roon).

What I dont get is why roon tells me it has imported 18124 tracks when there are 18181 in the library. Why 57 short?



zero skipped on import, zero to clean from the library
I thought maybe it’s 1 file = multiple tracks, but I dont have any m3u / cue files, or e.g. single flac files split in the library to make many individual tracks.

Hi, @Robert_Holloway, @Thierry_M, sorry for a late reply here. May I ask you to sent us your logs? I will send more detailed instructions via PM.



Just updating as “solved” but dont 100% know the cause; rigorous file renaming seems to have fixed it, taking out ò and é and & and ‘ and any other character that might impact importing.
The other possible cause was “various artists” albums, where i fixed artist assignment to give the individual tracks the correct artist, but left “album artist” as various.