sonicTransporter: how to watch folders on another computer

Core Machine (Operating system/System info/Roon build number)

sonicTransporter i9

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Orbi modem/router and satellite with WiFi backhaul between Core machine and other A/V gear

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

ultraRendu via USB to integrated amp

Description Of Issue

Trouble setting up “watched” folder.
When my Core was on a Mac Mini, I had Roon set up to “watch” the Music folder (with iTunes music, etc.)
After moving the Core to a sonicTransporter i9, I wanted Roon to continue watching the Mac Mini’s Music folder (using the Mini now for Music file management).
However, when I try to add a network share, specifying the Mini’s Music folder as the “new folder”, and hit the “Add Network Share” button, the “Add Folder” message just stalls. The watched folder never gets created/linked.

Is it necessary to do something first on the sonicTransporter side, to mount the Music folder on the Core machine? Isn’t it possible to just add the network share directly from Roon using the smb protocol

Have you already seen, read and followed the instructions from the document below?

FAQ: How do I create a shared folder on Mac and add it as a watched folder in Roon?

Yes. I’m familiar with those procedures and have set up folder-watching successfully in the past. My question pertained specifically to the Small Green Computer sonicTransporter line of music servers. As far as I can tell, the procedures I followed in the past (similar to what you linked) don’t quite work on the sT i9.

However, a little while ago I did get it to work by going into the sT i9’s browser-based controls and mounting the Mac Mini disk I want to share, then going into Roon and adding the share with the familiar procedure. Apparently, you cannot complete the set-up solely through Roon and the Mac (or other target computer).

Try using smb://MusicManager.local/Music. Other users reported success with this method.

I already had tried using the .local suffix.
Didn’t seem to work for me. Maybe one needs to do something with Bonjour settings, or some such.

I’m ok with having to mount the drive through the sT i9 browser control … just wish the need had been more obvious up front.

Your question seems to be more targeted to SGC support than Roon support. You may be at the wrong place here.

Hi @Tom_K,

Can you share a screenshot of your Mac’s Sharing tab and a screenshot of the values you input into the Add Network Share tab? Screenshots look like this for reference:

As @BlackJack suggested, I would also consider reaching out to SGC in case they are aware of any SMB limitations for connection to MacOS.

For adding the network share, I’ve tried several variations on the settings below (with/without the .local suffix, with the IP instead of host name, etc.):

The “Adding…” box keeps going and going.
When this procedure worked for me, it finished quickly.

Is the share still mounted there? Is there a change in behaviour in Roon when you unmount the share in the sT i9’s browser-based controls before you try to add it to Roon?

I wasn’t entirely sure how to unmount/eject the disk.
So I just deleted the settings in the sT i9 browser controls, hit save, and also removed the shared folder from Roon. That seems to be un-doing the share.

And yes, the behavior in Roon still seems to be the same now.

According to SGC, it is possible to share directly from Roon, but requires some set-up procedure that apparently is harder than just copying the files directly to the sT i9 disk. I don’t know, it seems to me that the procedure I used earlier to day does work, and is more desirable than copying everything over manually.

One way or another, it would be nice to have clear documentation for the preferred procedure (if there is one).

I’ve re-mounted the shared disk.
Apparently, with the sT music servers as Core, you don’t add a network share the “Roon” way. You mount the disk you want to share onto your music server (using the SGC browser-based software). Then you “add folder” in Roon.

At least, that’s the method I’ve stumbled on.

Hi @Tom_K,

It sounds like you’re up and running with this mounting in place, correct? I’m not aware of the method you used, but for others who are facing this issue, would you be able to provide some more information as to how you set this up? Possibly with a few screenshots?

Open the browser control for your sonicTransporter.
Go to “Settings”.
Then open “Drive Mounter”.
Select “SMB” (not “USB”) and fill in the form, then save it.
On my system, the form looks like this:

Once you’ve used that procedure to mount your shared drive to the sonicTransporter, then:
Go into Roon;
open Settings/Storage;
click the “Add Folder” button;
navigate to the “Music Storage Folder”;
click the “Select This Folder” button.
At this point you should be in a screen that looks something like this:

What I’m doing here is mirroring my Apple “Music” folder to the sonicTransporter. I can buy albums on the Qobuz Music Store site (for example), download them to my Mac, and they’ll be exposed to the sonicTransporter (and to Roon).

Hope this is clear! If there is a simpler/better way, I’d love to know.

Hi @Tom_K,

Thanks for sharing those instructions, it will be useful for others who can’t mount via SMB. I noticed in the other thread you mentioned SMB via Roon started working properly by itself as well?

Certainly strange that it started working all of the sudden, and nothing was changed on the Mac Mini or Network?

I’m saying I did not do anything deliberately to fix the network share problem. But something must have changed to make the difference.
For instance, I had changed one or two iTunes sync settings, then turned on the “NoTunes” application to get iTunes to stop popping on randomly. I wonder if those steps might have triggered some other change in how devices alert other devices to their presence across the network.

Hi @Tom_K,

It’s possible that this was due to a setting, although I don’t think it would be a setting within iTunes, maybe a system change you made. If the behavior re-occurs do keep a close eye to any changes you make.

Below is a screen shot of my current sharing preference settings:

These settings appear to be exactly the same as the ones shown in my post #6 above (Jan 15).

I’m now using smb and the host name to refer to my Mac Mini music server (“Jukebox.local”). But before I got that working I was using its IP address. I notice that over the past few days, it seems to have changed from to then back again to

This seems like the DHCP lease expired and you got a new address in the meantime. I wonder if the lease reset impacted the issue here and allowed the smb share to start working again.

It’s hard to say what exactly it triggered since everything is now working, do let me know if you have any further issues.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.