sonicTransporter i7 - 1st track on most Tidal albums is being skipped - ISP connection ~47Mbps


(Sean) #1

I just did a TeamViewer session with the old man (dad).

His connection is ~47Mbps and the 1st track on most albums is being skipped after a couple of seconds.

So the internet speed wasn’t the issue.

He’s running RoonServer and HQP Embedded on the same sonicTransporter i7.

I’ll get him to use Roon only (disable HQP for a week) and see if he’s still having issues.

Might need to spin me off to a separate topic perhaps.

This has actually been happening for a long time (months) but I never reported it because we thought it was the ~5Mbps ADSL2 internet connection. Now on a ~47 Mbps fiber connection (which just went live today) we’re seeing the same issue.


Roon is skipping MQA tracks
(Sean) #2

By-passing HQ Player completely and just doing Roon Server --> microRendu (RoonReady mode), I can still see the 1st track of Tidal albums skipping. So it’s an issue independant of HQP Embedded.

It’s skipping to an Allo DigiOne endpoint (another room) too.

Tagging @agillis .

It’s Cat 6 ethernet all the way between the sonicT i7 and microRendu, with 2 x Negtear GS108’s (unmanaged) switches in between.

Hi @Carl could you move my last couple of posts to the Small Green Computer section?


#3

Done, trust the title is ok with you.


(Sean) #4

Thanks Carl! All good.


(Sean) #5

@agillis @Jesus_Rodriguez , I’m not able to change the router DNS settings - it’s been locked by the ISP for the VoIP service to work.

Can I change the sonicT i7’s DNS settings, to use Google’s public settings?

As a first thing to try.


(Sean) #6

@agillis @Jesus_Rodriguez we’ve sacrificed VoIP calls to test a good router which allows DNS config. We’ve configured an Asus RT-AC86U with Google DNS settings and still have the 1st track skipping issue.


#7

#8

(Sean) #9

Thanks @R1200CL but that’s completely different.

These 1st album tracks that skip will play, after hitting the album play button again.

The Tidal app on Mac and iPhone on the same home network doesn’t have any of these issues with same Tidal albums…


(Robin Carmack) #10

I have had this issue for a long time. I just hit play twice as you mentioned.


(Sean) #11

Likewise.

I’m not alone, there’s another guy on CA Forum that says he’s had the same issue for a long time too, with a sonictransporter.

An iMac running Roon Server on the same network doesn’t have this issue… so it’s the sonictransporter


(Jesus Rodriguez) #12

The best thing is to submit a log to Roon support. I’m going to notify Roon support of this thread.


(Sean) #13

Will do.

As per this thread, I wasn’t sure at first if it was Roon but today I’ve isolated it to Roon on the sonicT i7… since today I saw that Roon on an iMac can play to HQP on the sonicT i7 without issues.

I removed Roon Server from the sonicT i7 today so he can have trouble free Roon + HQP listening - but I will TeamViewer with the old man this weekend to put Roon Server back on the sonicT i7 and then contact Roon @support about logs.


(Jesus Rodriguez) #14

The logs should help regardless of where the issue lies.


(Sean) #15

Noted… The Roon logs probably wouldn’t help if it was a microRendu HQP NAA issue… but just today I was able to isolate it to Roon Server on the sonicT i7, as mentioned.


(Dylan Caudill) #17

Hey @Sean2016,

Thanks for sharing your report with us, and sorry for the difficulties here. In order to better understand what’s happening, I’d like to get a little more information about exactly what you’re experiencing here:

  • Is this always happening for the same albums? For the albums where this doesn’t occur, is there anything different about them that you notice?
  • Just to confirm: After the track stops and you hit play, everything works okay from there? The track plays as expected and later tracks in the album don’t exhibit this behavior?
  • Is there any difference in the way that the iMac is connected to the network compared to the SonicTransporter?

  • Was the iMac playing to the same endpoints as the SonicTransporter?

  • Just to confirm, is local content playing without issue?

  • What device is connected to the microRendu? If you instead connect it directly to the Core machine do you notice any change in behavior here?

Thanks!
Dylan


(Sean) #18

Hey dylan

Absolutely no problem at all. These things happen. Appreciate the support. This is happening on dad’s account, so I’ll PM you his Roon details.

But replies to your queries are below:

No, it’s random. Note also my earlier observation that when we first boot the sonicTransporter and wait for Roon to load, we get a Tidal login error and there’s two options - ‘retry’ and ‘edit’. This is 100% reproducible, on each boot up. After a few seconds, we can hit retry and his Tidal library then appears. I don’t know if it’s related to the Tidal skipping issue or not. The iMac never has this issue… I did 20 boots of Roon Server on the iMac yesterday and never saw this issue.

The track doesn’t stop - it skips and starts playing the next one. I’ve seen it mostly myself on the 1st track when I TeamViewer with dad. But he says it also happens mid-album. Sometimes 2 or 3 tracks can skip. When I’ve seen it skip the 1st track, it jumps to the next track and starts playing. So to play the 1st track of that same album, I re-hit the play album button again. Robin_Carmack mentioned above that he does the same and another sonicTransporter own on the CA Forum also mentioned he does the same. We all thought this was ‘normal’ for a long time. As mentioned I thought it was dad’s ~5-6Mbps connection that was the issue but just this week his ~45Mbps fiber connection went live and to my surprise, we are still getting the issue.

Setting up Roon Server on the iMac (with the sonicT i7 still in the chain for HQPe) tells me it’s not an internal networking issue and not a general Tidal services issue, otherwise that chain would have issues too but it’s flawless.

Correct, local content has never been an issue. Only Tidal with Roon on the sonicTransporter i7. Tidal with Roon on the iMac is no issues.

No, both connect to the same NetGear GS108 unmanaged switch (switch #1) - which connects direct to the new Asus RT-86U I just got him, all in the home office.

From switch #1 in the home office, there are Cat 6 UTP cables going to the two listening rooms - where there is another NetGear GS108 unmanaged switch in each room.

In one room there is a microRunning NAA and in the other there is an Allo DigiOne running NAA.

As previously mentioned, I took HQP out of the equation and just used RoonServer on the sonicTransporter, feeding the Rendu and DigiOne via RoonReady and RoonBridge respectively - and we still get the same issues with both zones.

A Pro-Ject S2 DAC connects to the Rendu. With the iMac test (which keeps the sonicTransporter still in the loop) I thought we could by-pass having to connect via USB to the sonicTransporter… it’s on the other side of the house to the two listening rooms, in the home office (with the iMac and router). If we absolutely need to do this test let me know but I thought the iMac (Roon Server) --> sonciT i7 (HQPe) --> microRendu (NAA) chain working without a hiccup eliminated general internet connectivity, internal networking issues and general Tidal services issues. Do let me know though.

Happy to provide more info and let me know if I missed anything.

I will have to re-install Roon Server on his sonicT i7 tonight/tomorrow and reproduce the issues. I’ll let you know the times I get the issues. Can you get the Roon Server logs automatically with the sonicTransporter or do I do that manually?

If luck is on my side then re-installing Roon Server on the sonicT will fix things but I’ll find out tonight/tomorrow when I TeamViewer with the old man.


#19

2 posts were split to a new topic: This track is not currently available - when playing a Tidal track


(Sean) #20

Just an update because I know a couple other sonicTransporter i7 owners here have mentioned having the same issue and saying they thought this Tidal track skipping was normal all this time - like I did.

There’s been a lot of offline back and forth with Roon Support and Andrew of SGC has been fantastic too, trying and suggesting different things to help resolve this.

Roon have been looking at the Roon account’s diagnostics and their dev team say from their end it appears to be a DNS issue… but as they will see in the latest diagnostics this weekend:

our iMac running Roon Server doesn’t have any skipping issues… both the iMac and the sonicTransporter connect to the same NetGear GS108 switch, which connects to the Asus RT-AC86U router… so if it was DNS issues, the iMac should experience the same issues?

i.e. the network chains are identical playing to the same endpoints

We’ve tried Google DNS settings, CloudFare DNS settings etc and no matter what we try, it’s only Roon running on the sonicTransporter that has issues - and Roon running on the iMac no issues.

Roon and Andrew continue to look into it and as they know, I’m happy to keep trying different things they suggest.

The idea of both Roon Server and HQP Embedded on the same machine sounds fantastic but it really needs to work reliably.

The Mac+Roon and sonicT+HQPe (i.e. two box solution) is rock solid reliable - the Roon experience you want.

I haven’t seen any sonicT i5 owners mention this problem - only sonicT i7 owners here and one on CA Forum.

Anyway we’re not giving up. I have a very positive attitude and as long as @agillis and Roon Support continue to look into it, I’ll continue to support them with trying what they ask.

Just an update for now. The support from @agillis, @Jesus_Rodriguez and Roon has been great. I’m still positive this will be solved.