SonicTransporter not detecting ultraRendu[solved-broken usb port]

Hi. Thanks in advance for any help. Problem: Roon on my iPad or MacBook Pro, the Audio ‘tab’ does not list my Sonore ultraRendu as a networked device. In Roon, I have tried clicking on ‘configure’ on the ‘Setup’ tab / Configure Roon OS Device…just spins ‘searching for devices’. Never finds any Roon devices. I have tried restarting both the sonic transporter (runs Roon Core) and the ultraRendu 2-3 times. I turned my firewall off and restarted my MacBook Pro.

The SonicOrbiter IP address shows the ultraRendu on my network and Roon Ready is shown as "Active’ with green badge. System is: Sonic Transporter i5, Sonore ultraRendu, KEF LS50W active speakers.

Audio devices are under settings/audio do you see anything there?

Settings/setup/configure Roon OS is to do with Rock which you are not using with a sonictransporter.

Thanks Philr. Settings/Audio: I only see my Apple TV. listed When Roon launches, at the bottom of the landing page, it says “No Audio Devices Found” + a ‘Manage Audio Devices’ button.

Are the KEF speakers on? When my DAC is off my microrendu connected to it does not appear on my devices list.

The speakers were on, but doubt the ‘pc’ input was selected. I’m using that usb ‘pc’ input on the KEF’s for the uRendu. Will try your suggestion tonight. I was thinking, the connection between the ultraRendu and speakers would be irrelevant to Roon recognizing the uRendu (network player), but hey…I’m open to anything to get this working!

Hi @James_Duffy ----- Thank you for the report. Touching base to confirm that I saw your PM addressed to me.

Moving forward, have you tired the suggestion made by philr yet? Just curious if this yielded any changes in results. Please confirm. Furthermore, may I very kindly ask you to please provide me with the following:

  1. I saw you mentioned that you have disabled the firewall off on the MacBoo Pro :thumbsup: Any active antivirus applications, by chance? if so, could you please disable as well.

  2. Looks like there was a firmware update for the LS50Ws in May, please verify that the speakers are up to date. Taken from Kef’s website:


That might be it. I’m pretty sure that I have lost the microrendu in my devices list when my DAC has been on but a different input has been selected.

Thanks guys. No anti-virus software running. I will try your suggestions tonight and get back to you.

Update: The firmware was old. Installed update. Powered speaker on, selected ‘pc’ (usb) input on speaker. Restarted the Roon Core and uRendu. Still does not show up in the list of networked devices.

Again, uRendu shows as Active on Roon Ready via

I reached out to smalgreencomputer…and the reply also mentioned the necessity of the uRendu being connected to a DAC. How do I get the uRendu to see the LS50W input as a DAC???

I would have thought that what you have done already should do it. Let’s see if @Jesus_Rodriguez of Sonore has any other ideas.

Go to and enter the ultraRendu to manage it. See if your DAC is listed in Apps / DAC diagnostics? If the DAC is not listed you may have to remove and reconnect the USB cable, then refresh the page. If your DAC is still not listed try power cycling the DAC followed by power cycling the ultraRendu cable and then go to Apps / DAC Diagnostics.

The DAC in this case is the inbuilt DAC on the KEF ls50 active speakers.

That doesn’t matter. If the KEF is connected to our unit via USB then “it” should show up Apps / DAC diagnostics?

Looking through the comments under this DAR review there is reference to a power off function and possibly to the speakers changing power status according to the presence of a signal.

@James_Duffy, in the KEF software app is there any facility to defeat power management ? If so, could you see if that makes a difference to USB detection by the ultraRendu and consequent detection of the ultraRendu by Roon ?

He reported off line that he might have broken the USB connector…so that might explain things;)

1 Like

Jesus…just so you know…Before posting here, I mentioned the issue with the usb connector in my first email to Small Green Computer’s Andrew Willis. It didn’t “raise a red flag” at the time with Andrew, and I followed Andrew’s suggestions…thus my seeking other solutions as well. I’m returning the uRendu to Small Green Computer to repair the usb connector via Andrew’s instructions. Nothing will make me happier than if the problem is due to my stupidity in damaging the connector. :wink:

1 Like


Just an update…customer service from Small Green Computer has been STELLAR. (due to me breaking the USB connector) … Received replacement ultraRendu, set up with Roon was completed in 5 minutes and the sound is outstanding. Huge thanks to Andrew and Jesus at Small Green Computer.