SonicTransporter Stuck Adding Content


(GaryM) #1

Hi @Eric – I’m sure you’re busy with the 1.3 roll out. But following up on this issue. 1.3 hasn’t resolved. I thought it had initially because the number of tracks reported as being imported was exactly correct, 95,094. That is, in the importing process, it shows:
Adding Music to Library: of 95094, xxxx added, xxxxx identified

But when complete, the number is much less.

Correct Number: 95,094
Reported in 1.3 running on Windows Core (win8.1(64) machine, 95,094
Reported in linux (SonicTransporter i5), 91,587
Missing (95,094 - 91,587) = 3507

The view skipped files in 1.3 on the ST shows the following:

Corrupt files, 942
I/O error files, 7
Total files reported as skipped, 949. Thus 2558 files unaccounted for (3507-949)
Spot checking a few hundred of the corrupt files, they all checkout as good files with two different integrity checking programs (foobar2000 and dbpa). Same with the files reported as I/O error.

Again, all the files import correctly into the Windows Core running 1.3 (pointed at the exact same USB drive connected directly to the SonicTransporter as USB, and connected to Windows roon by reference to network share pointing at the USB drive attached to ST). It’s only in the SonicTransporter i5 (linux) version that I don’t see all the files. Suggestions?


Sonic Transporter - No library or Auralic Aries [resolved by SGC support]
SonicTransporter Storage Issues [solved]
(GaryM) #2

As of this morning, after roon wanted to update to Ver 1.3 (194), instead of just having a few thousand missing files, I instead have zero files. In my settings > storage section, it shows that “DriveNotReady” next to the SonicTransporter USB drive listing. (Note that I can access that ST USB drive over my network, see files, open files, etc. So the USB drive is awake and useable). I assume this is part of the same problem others are reporting here.


(GaryM) #3

Thanks JSE. Following these steps caused my drive to be recognized again. It currently seems to be slowly removing tracks (counter going down), but also reporting that it is importing files and identifying. So I’ll have to wait for it to finish before I know whether I’m still missing files (my original problem). But at least drive connection is back!


(JSE) #4

Great to hear, give it some time, as these analysis are pretty heavy on the cpu.
You can read more about it here:


(GaryM) #5

After reconnecting and adding back files, I now have even stranger behavior than I had before (where I only had a few thousand files missing). Now it initally finds all 95,094 of my files and starts “Adding Music to Library”. The 95,094 starts going down (which is unusual) and it eventually adds 3996 files. But the “adding” revolving circle on the upper right never stops. End result (which is still trying is):

Adding Music to Library: of 3996 tracks, 3996 added, 3966 identified

Again, pointing the 1.3 Roon core on my Windows 8.1 machine at the exact same attached USB drive on the SonicTransporter (over a network connection), I get all 95,094 files added properly to my Roon library.

@eric and @support The title to this thread is marked as solved and my original thread post that was moved to here (SonicTransporter not picking up all my files) that was marked as solved in 1.3 is not solved. I’m in even worse case at this point. Thanks for any assistance.

EDIT: Running 1.3 (build 194) on SonicTransporter i5 (the ST firmware is latest). Files are all on USB drive connected to SonicTransporter (and all are readable if I connect Win8.1 1.3 Roon to that disk).


Sonic Transporter - No library or Auralic Aries [resolved by SGC support]
(Eric Stewart) #6

Hi @garym ----- I have split your posts out to a new thread so we can troubleshoot this issue on a thread not marked as “solved” in order to avoid any misunderstanding of the issue being reported.

Here is what I would like to do. Could you please power cycle the ST i5 device and try once more to add the content in Roon. If you end up in the same state (i.e Adding Music to Library: of 3996 tracks, 3996 added, 3966 identified), please dump me a set of logs and we will take a closer look.

Thanks!
-Eric


(GaryM) #7

OK. Please advise as to how to access logs in the ST. In other linux computers I’ve had, I could access with something like filezilla after logging in, but for the life of me I can’t do this in ST. Andrew at small green computer says users don’t have command line access. But it seems people still access logs somehow. Would doing a backup (from 1.3 setting) help access logs?


(Eric Stewart) #8

@garym ---- Everything on the SonicTransporter can be reached from the web interface (sonicorbiter.com)

Click manage next to the IP address of the unit you want to access and it will redirect you to the IP address of that unit.

Roon diagnostics

click on Apps -> Roon Server

This will give you the option to print the Roon Server logs to the screen.

-Eric


(GaryM) #9

logs provided in PM to you. thanks.


(GaryM) #10

Quick question. How do I get my logs from my sonictransporter. I can’t “login” to the ST on my network and see any of the program or log files (I can only access the music files, etc. that are on the attached USB drive).


(GaryM) #11

Got the answer on how to access logs above.


(Eric Stewart) #12

Hi @garym ----- Just touching base here. Confirming that the logs have been received. Thank you very much for the follow up! We appreciate your patience while we look into this issue for you.

-Eric


(GaryM) #13

@eric, I just sent you an updated PM with link to new logs. As noted in the PM detail, I seem to be back to only the “missed files” problem that I’ve had since 1.2. I have 948 files showing as skipped in ST (but not in Windows Roon 1.3 accessing same drive). And there are several thousand files missing that are not in the skipped list.


(GaryM) #14

@Eric @agillis

I’ve made some progress on issues with adding all my files in my SonicTransporter i5 (with USB 3.0 attached drive). With Roon ver 1.3 (200), I continued having odd problems. Very random. The number of files added could be 12,000 or so or as much as 93,000. Sometimes inbetween (40,000~).

As of now, I’ve actually managed to get the ST to add all the files I should have (other than skipped corrupt files which I think is a different problem and I’ll post on another thread I have for that issue). I’m not convinced the problem is solved, as removing and adding the music directory seems to add a different number of files everytime I do it.

Here’s some details on steps I’ve taken to diagnose:

  1. Remove Roon Ready app from ST, reboot, then re-add Roon Ready app.

  2. Re-mount the USB 3.0 external drive to the ST.

  3. Remove then re-add the music directory from the ST to the music source location within the Roon control program. Let run overnight (or even two days). At this point I was getting very different numbers of tracks over the course of doing this over a week or so. Again, just yesterday I managed to do this step and get the correct number.

  4. I’ve used a completely different USB 2.0 external drive (with a backup copy of the same files, formatted the same way) and connected this to the ST. Same problems occur (with random incorrect number of tracks being added).

  5. If I run Roon Server on my windows laptop and point the music file location (i.e, mapped over the network) to the USB drive that is connected to the ST), everything always works perfectly every time. That is, track count is correct.

EDIT. In both cases, the USB drive is self powered via the USB port…no separate power supply.

Thoughts?


(Andrew Gillis) #15

A few things to try.

  1. upgrade your sonicTransporter to the latest code and reboot.

  2. format your drive in exFAT. We have found this more reliable then other formats.


(GaryM) #16

Aha! Makes sense. Now that I’ve actually read the information you provide for setting up the ST (duh, who reads the manual! :grin: ), this makes perfect sense. The exFAT format may be more compatible with a linux machine. This could explain why the drive works perfectly with the Windows Roon server but has some issues with the ST.

I’ll have time to do all this late next week and I’ll report back here on the outcome.


Audio files corrupt in Linux (SonicTransporter) but not in Win Roon Server [Ticket open]
(GaryM) #17

@Eric @agillis
Thanks to both of you for your help. formatted external USB drive to exFAT and re-added files to ST. Now get correct number of files (except for the missing 942, shown as skipped in Roon on ST, but not on Roon Windows). This seems unrelated to the ST and more related to file type. See other thread here:


(Eric Stewart) closed #18