SonoreUPnP Bridge (beta)


#413

Hello @Jesus_Rodriguez,

I am using Sonore UPnP Bridge on an Audiostore Mite and have discovered a problem which I can reproduce. I know this is not Sonore hardware, but the software is the same I believe?

Anyway, first, play some music with Roon to the Bridge. Next go into DSP settings in Roon. Then enable Parametric EQ and start very quickly changing settings. I turn bands on and off. You need to do it quicker than Roon can catch up with so that you make multiple changes before the music starts again.

Eventually Roon will just continuously skip tracks and the music will never start again. If you look at the endpoints in Roon the Bridge will have disappeared.

To fix, the Bridge must be restarted. No need to restart Roon Core as it will recover.


(Jesus Rodriguez) #414

Try stopping playback before you enter these DSP settings.


#415

@Jesus_Rodriguez thanks for the response, I appreciate your help.

I have found that quickly hitting any buttons can cause the skipping issue. For instance if I click on Next Track and Previous Track too quickly then it goes into the skipping loop.

Also I found to fix it I can just restart the Bridge app rather than the Mite itself.

However you are correct in what you say: the problem only occurs if music is playing. If I pause playback then it seems to be OK.

Is there a way to fix this? The problem is if I give my iPad to a friend and ask them to play some music, “but don’t press buttons too quickly or it will break”.


(Jesus Rodriguez) #416

That is a good way to reset things. Understand that the application needs to translate commands across the various protocols and you can not overload it by fast clicking. Also, we are not able to trouble shot specific issues for every case because we don’t have the gear to test with. This is the reason the app is in perpetual Beta status.


Synchronised playback with Sonore Bridge & Naim Musos
#417

I wish I had know that before I spashed money on hardware to support it.

For what its worth, I’ve compiled a list of issues with the Bridge + Roon + Naim 272

  • Naim volume set to 100% after Bridge restart or significant system setting change in Roon (I think this to be a problem only for people who have a combined Pre-Amp and Streamer/DAC like me)
  • Perpetual skipping of tracks if too many buttons are pressed too quickly in the Roon app
  • When playing a CD, it will often stop before the end of the track quite suddenly. Sometimes Roon Radio kicks in, sometimes not.
  • I can’t use the Stop button. Instead of stopping it just goes to the next track! I can use Pause, but…
  • If I press Pause and try to switch my Naim to another input (e.g. TV / vinyl) then it will often switch back to Roon/Sonore and keep playing from the next track! My other half has become quite annoyed at inability to be able to stop the music - understandably.

If this will never be fixed because, as you say, you don’t have the resources nor will it ever leave beta status then I have to wonder if I have made the right decision.


(Jesus Rodriguez) #418

I have been testing in my system here today and I’m not able to reproduce your systems.

  1. The volume is 100% as set.by Roon with my unit because it’s a streamer and does not need a volume control. Are you able to set some max volume you feel comfortable with.
  2. No skipping here with playback after several hours.
  3. I don’t have a way to test a CD.
  4. I don’t see a stop button in Roon. What are you using as a controller?
  5. I don’t have your unit here so I can’t test its input select switch. This seems like a firmware issue with your DAC/AMP because we do not control that feature.

All the marketing on this feature is listed as bata. If Vortexbox UK has misrepresented that you should contact them.


(robert dixon) #419

Having just added a Sonore UPnP Bridge to add Roon functionality to my ND5XS. Does anyone know if it possible to see song info on the screen and on Naim app? I can see the sample rate, the song / track info just shows streaming# where the artist / song are usually displayed.


#420

No it won’t. You only get this with officially supported Roon devices.


#421

Hi @Jesus_Rodriguez

You’re right about the volume control aspect, with my unit being a combined pre-amp and streamer/DAC. I had set the maximum volume on the unit to 45% so as not to damage my equipment.

When I said CD, I meant a ripped CD album, sorry for not being clear. The stop button is on the Naim unit/remote control.

Anway, it is what it is, I’m going to use an alternative Rpi based approach and return the Audiostore product. Its just not for me. Thanks for your help.


(Jesus Rodriguez) #422

You should be using Roon on a computer or Roon on a mobile device to control it! You can’t mix it with a UPnP controller…


#423

I am using the Roon app, not the Naim app. I mean the physical remote control handset. Are you saying I can’t use the remote control handset?


(Jesus Rodriguez) #424

Correct…the point is to use Roon for streaming and control.


(simon_pepper) #425

Yes, you use Roon Remote to control the stream to the Network player.
With Roon the stream is pushed to the Endpoint rather with a UPnP Render will pulls the file from the server.
So my Naim remote has been in the draw and not used. I also don’t use any other input on the NDS, I haven’t played a CD in ages, on the Merdian 200 CDT.
So the Bridge is exclusive to the Ethernet input, and no volume control.


(Andrew Gillis) #426

Yes you would use Roon. Not the hard remote that came with it.


(David McRoberts) #427

Just to say I have recently installed a Sonore UPnP bridge on my Naim (NDS) system and has worked flawlessly. Simple to set up and works as advertised.

Using the Roon App and enjoying more of my music which has been buried away until Roon pops up and suggests a listen :slight_smile:


(Andrew Gillis) #428

Nice! it works really work for “upgrading” old Naim equiptment to Roon compatibility.