Sonos AirPLay on Roon Tested

New to Roon.
I have set up core on my imac and Roon has identified endpoints.

With my Sonos products, three have been identified as Roon Tested, the other appear in other network devices.

For those in other devices the Sonos speakers have come up as Sonos Streaming and AirPlay, thus allowing to stream either by AirPlay or Sonos.

For the Roon Tested devices they only appear as Sonos Streaming.

If I use AirPLay zoning it works fine for any device in Other Network Devices, but selecting the Play 5 Sonos for AirPLay it connects AirPlay playback on the Roon Tested Sonos’s.

Is there anyway I can separate the Roon Tested Sonos to allow individual AirPlay as well as Sonos.

David you can only connect to the Sonos Airplay devices that support it (newer devices). Whereas all the Sonos direct endpoints will show up.

From memory (I do not use Airplay) you have to group older devices with newer ones to get Airplay to work with them as a grouped zone in Sonos.

Not sure if that helps or not



Mike thanks for the reply.
All my newer Sonos speakers appear in the other network section, the ones in Roon Tested are still Sonos 2 but are older.

They all work with AirPlay but effectively when I connect AirPlay to Kitchen Sonos it brings on all Sonos Tested speakers via AirPlay.

The reason I want to separate them is my main system is the B&O Beovision so it would be better to zone with that, as opposed to Sonos streaming.

Hi David all the Sonos devices should show up as Roon tested (via Sonos streaming) old or new.

I currently have Airplay disabled on my Sonos Amp and that is the only device I have that supports Airplay as all my other devices are older.

On the Sonos App I’d the option the group non Airplay devices (but they have to be played with the Airplay compatible devices)



Thanks again, see screenshot for my Sonos, my new devices are not showing up in Roon tested only non Sonos AirPlay speakers.!
Yet Sonos is linking them to Kitchen AirPlay and playing via AirPlay.
Screenshot 2020-12-24 at 12.02.39 pm|244x500

David send a screenshot of Settings->Audio so we can see if they are enabled for Airplay.

Can you also check if they are grouped together on Sonos app. If they are they will automatically play



Whereabouts can you see that?

David they are there under Other Network devices and enabled which is a good start.

To find out if they are grouped go to the Sonos App and choose the middle button at the bottom. It will show you a list of all your Sonos device’s and whether they are grouped together.



I believe the Snug Sonos, Garden Room Sonos and Lounge as shown on Roon tested are not AirPlay enabled.

On the Sonos app, yes they were grouped if I ungroup them then only the selected "Other network device"play by AirPLay from Roon, you can then link them on the Sonos room app so I believe that is then linking by Sonos network.

I think I understand what is happening now.
I much appreciate your help.


David no prob, I am rusty on Airplay as I never use it.

I would have thought that if each device has Airplay (they are enabled in Roon or they would have a Enable button next to them) so I would expect them to appear in Roon as endpoints.
Sorry I can’t be more helpful than that.