Sonos and Roon stability

I’ve been doing inventory on my network this weekend and my Roon setup is becoming more stable with each tweak I make. First I had problems with Android apps not connecting and discovered that eliminating my Wifi extender fixed that issue. The extender was put in place when I had an older router and was no longer needed with my newer router.

The other issue I’ve been having is playback from Roon to multiple Sonos zones concurrently. I wasn’t able to playback to more than four zones without dropouts. Three usually worked without issue, but once I added the fourth zone it becomes unusable. Then, I realized I had an older Sonos bridge connected to my router. I remembered Sonos released an update a while ago so the bridge could be eliminated. Using the Sonos app I connected my Sonos system to my Wifi network and then removed the hardwired bridge. I played 44khz/16 bit flacs for hours and hours today without a single hiccup. And… are you ready for this? I was playing to SEVEN zones!!! Later in the evening after playing reliably all day I did have a couple hiccups, but nothing like before. I’m still unable to play any source file that requires down sampling (DSD for example) unless I reduce the number of zones to 3. However, overall I’m super happy I have found a happy compromise.

I’m posting this in hopes that it might help others who might be struggling with dropouts during playback to Sonos through Roon.

Happy Roon-ing with Sonos


One more tip I found that really helps with Sonos stability when playing from Roon is changing any surrounds to “Ambient” vs “Full” in the advanced room settings of the Sonos app.