Sonos audio endpoints no longer visible after 710 update [Solved - Synology Open vSwitch]

Core Machine (Operating system/System info/Roon build number)

Synology NAS/Linux, Roon 710

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Roon Core on ethernet, several Sonos devices on ethernet and wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

SMSL Dac over USB, Sonos over ethernet and USB

Description Of Issue

Hi all, I’ve been really enjoying Roon running on my Synology NAS (DS1819) on the previous build (667?) and all was working just fine.
After applying the 710 update automatically, only the USB connected DAC, and the default output (my PC) are visible as an audio device.

No other network devices (only Sonos devices) are visible as audio end points.

Nothing else in the network changed, and I was happily streaming to my Sonos Play:3 right before the upgrade started.

Any ideas?


Sorry for the trouble here, @Steve_Smalley! Can you try rebooting the Core and Sonos devices? Is there any change after doing so?

FWIW, our two Sonos endpoints are working fine after the update.

I read this subject just after I had pressed the update button in Roon.
Thankfully all working well after the update.


Thanks Neil and Dylan… Good to hear Neil and Michael are working. Unfortunately I’m still not.

I’ve rebooted the core and all of the Sonos devices in the house. Still I can see only the locally attached DAC (even tried unplugging that)…

It’s too bad there is no way to specify an endpoint by IP address.

Any other ideas?

One other data point… No other network devices are visible either. I have numerous Chromecasts and even my Sony TV etc. that were appearing in the ‘audio’ tab under settings. I never enabled them because I didn’t use them, but now they are not visible either

Ok then… I have noticed that something had enabled the Synology vswitch on the LAN port.
I learn from the forums that this is an issue for Roon. I disabled that because I don’t need it right now, and now all is back to normal.
Thanks so much to the Roon community forums for helping find this problem… I hope Roon (or Synology) can fix this at some point so I can use the vswitch… But I’m all good now.


1 Like

Hi @Steve_Smalley,

Yes, open vSwitch has caused similar behavior to what you describe, so thanks for letting us know you were able to sort this issue out!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.