Sonos Device disappears from Roon [Ticket In]

Odd. Mine only ever dissappear when the wifi has a problem, its a bellwether for that for me.
Proper support may have an idea. Logs may be needed.

1 Like

This is something that’s been affecting a number of Sonos users for some time. I myself never had an issue with my Sonos Arc been rock steady on wireless since I got it in September, it’s on latest Sonos firmware etc. So likely some environmental thing combined with some changes in Roon that’s causing it. Airplay is discovered over mDNS, Sonos streaming doesn’t so this explains why you see it via one and not the other, something is stopping Roon seeing the discovery broadcasts needed.

1 Like

It’s now a long term problem that Roon are investigating and said they working on.
It affects a fair number of us, and it’s not our network’s, it’s something in discovery that is broken as they just disappear and will not come back until a restart of Roon.

If your Sonos One has Airplay I would use that.
I have started pairing my order Sonos devices without Airplay with a Roam or Move and using Airplay to play while grouped in the Sonos app.

It means they can be on all day without dropping off. It’s a workaround and not a fix, but @noris is collecting log files etc while trying to narrow it down.

3 Likes

I just started having this issue after a recent roon release… I have a pair of Sonos SLs, Arc/Sub , roam, and a move… all disappear from roon… I can reboot the roon and they will reappear but then disappear. Rebooting router does not help either.

Hi there, Roon are aware of it and @noris has confirmed that they are working on a fix for it.

Hi All,

We have a ticket currently active regarding this issue and our team is looking into this. I can’t comment on timelines, but we are aware and investigating a path forward. If we need any additional information for our investigation we will let you know. Thank you!

5 Likes

Great… I can use airplay as a backup but will be happy when the issue is fixed and I can go back to using sonos streaming.

1 Like

You and me both Ira, I am currently using a Roam and a Move to anchor my older Sonos devices via Airplay as they do not support Airplay streaming.
The good news is that it has been 100% reliable doing that, even if not ideal

+1 for this PITA issue arising again.
I had escaped it for a few months but today it is back again.

1 Like

FWIW I was having a look in my router settings about 3 weeks ago.
I had IPv6 enabled still after messing around with something during May.
I disabled the IPv6.

Since disabling IPv6, my sonos devices (1 x play 5 and 2 x play 1 - all on wifi) have been stable.
This was prior to latest roon release. Post latest release, the zones are still stable.
This is now 3 weeks of stability.

Might not have anything to do with IPv6 but thought Id post for info as its the only thing I changed in my network.

For info, I also have both IGMP snooping and IGMP Proxy enabled (these have always been enabled) on my router settings
My router is a Synology RT2600ac.

YMMV.

4 Likes

Odd one this as i never lost my Arc at all, it’s always present and doesn’t drop out when I use it , albeit that’s not very often , maybe because I just have the one Sonos speaker?

Same router here but unfortunately your tips didn’t work for me…Thanks anyway !!

Did you reboot everything (network, core and devices) after changing settings?

Back in September 2021 when this Sonos issue first occurred, I managed to get the devices stable by doing this:

  • remove / disable all Sonos devices from Roon
  • remove reserved IP in Synology router for all Sonos devices
  • restart network
  • reassign reserved IP in Synology router for all Sonos devices
  • restart network, ROCK, devices
  • add / enable devices back to Roon.

It was then stable until I had turned IPv6 on.
Stable again since removing IPv6.

All my sonos are on WiFi.

2 Likes

Ogdens I have done the same as you and never had IP v6 enabled. I did have about 6 months of total stability between several releases until it broke again, after another update.

I have tried running just one device and only on WiFi, but nothing makes it work for more than a maximum of 12 hours with an average of about 4-6 hours.

I am more committed to Roon than Sonos, and planning on replacing a couple more rooms as well.

Going to limit myself to garden, kitchen and conservatory in the future, and use them linked via AirPlay (using Move and Roam). That all works perfectly but SonosNet is a disaster for me now.
Pretty much given up on this being fixed

1 Like

Yes, it’s a strange one. I don’t hold much hope of a permanent fix either.

When I came to Roon I had a house full of sonos gear and only started using it due to the S1 S2 debacle. I then quickly started selling the bulk of the sonos geand am just left with 3 units.

My Play 5 is in my kitchen and fine on airplay if the disappearing act rises again. I’ll move the 2 x play 1 on at some point. Or have a sacrificial burning.

1 Like

All my Sonos devices are S2, but not all have Airplay support or I would not worry (as it is more than good enough at 16/44). But like you I now have less Sonos than before and I have 3 Roon Ready streaming devices (plus a few Pi’s that are not currently Active).

Seriously thinking about moving my study from a wall mounted pair of Play 3s to a pair of small Genelec active speakers driven by my MA Mini I pro 3 over XLR. I think that would make a great near field work/play set-up.

Given that we can all play RAAT and AirPlay all day without any interruption in the music, I think that shows that we have good network setups. Still it is frustrating to think about selling gear that actually sounds good and otherwise work’s well.

The same issue here. Three Play:1s not showing in Roon unless I play something from the Sonos app and then restart the ROCK server. They work fine until they disappear again.

1 Like

I can report that this PITA AWOL sonos issue has reappeared in my system again after a couple of months of stability.

Happened last night when my router firmware updated. Strange thing is that no user managed settings have changed.

I was about to pony up on 2 bluesound flex to replace the 2 offending play 1 but they out of stock here until end of September.

So, if I can find the motivation before then I’ll do a rebuild as per first times fix and see if it works again this time. Will report back.

Sorry I can’t :heart: that post, but that is pretty much exactly what happened to me last time.
Both a Sonos firmware update and Roon update and boom gone again.

I have currently given up on Roon fixing this sadly, so I am using 2 Airplay capable devices to run my remaining Sonos devices and I have to say I sometimes forget that Roon to Sonos is FOOBAR in my network.

I have an unused Bluesound PowerNode 2i and I have to say it is a great little device, and I should get myself around to selling it.
The Roon Ready functionality for them is really good so I doubt you will regret buying a Bluesound for the reason of Roon not working.

Good luck with the rebuild once again.

My two Sonos devices went MIA yesterday (or that’s when I noticed). Used apple music to play to them, this worked flawlessly. :man_shrugging: