Sonos Device disappears from Roon [Ticket In]

All my Sonos devices are S2, but not all have Airplay support or I would not worry (as it is more than good enough at 16/44). But like you I now have less Sonos than before and I have 3 Roon Ready streaming devices (plus a few Pi’s that are not currently Active).

Seriously thinking about moving my study from a wall mounted pair of Play 3s to a pair of small Genelec active speakers driven by my MA Mini I pro 3 over XLR. I think that would make a great near field work/play set-up.

Given that we can all play RAAT and AirPlay all day without any interruption in the music, I think that shows that we have good network setups. Still it is frustrating to think about selling gear that actually sounds good and otherwise work’s well.

The same issue here. Three Play:1s not showing in Roon unless I play something from the Sonos app and then restart the ROCK server. They work fine until they disappear again.

1 Like

I can report that this PITA AWOL sonos issue has reappeared in my system again after a couple of months of stability.

Happened last night when my router firmware updated. Strange thing is that no user managed settings have changed.

I was about to pony up on 2 bluesound flex to replace the 2 offending play 1 but they out of stock here until end of September.

So, if I can find the motivation before then I’ll do a rebuild as per first times fix and see if it works again this time. Will report back.

Sorry I can’t :heart: that post, but that is pretty much exactly what happened to me last time.
Both a Sonos firmware update and Roon update and boom gone again.

I have currently given up on Roon fixing this sadly, so I am using 2 Airplay capable devices to run my remaining Sonos devices and I have to say I sometimes forget that Roon to Sonos is FOOBAR in my network.

I have an unused Bluesound PowerNode 2i and I have to say it is a great little device, and I should get myself around to selling it.
The Roon Ready functionality for them is really good so I doubt you will regret buying a Bluesound for the reason of Roon not working.

Good luck with the rebuild once again.

My two Sonos devices went MIA yesterday (or that’s when I noticed). Used apple music to play to them, this worked flawlessly. :man_shrugging:

I agree with @Michael_Harris and have also given up on Roon ever fixing this.
The issue has been ongoing for well over a year now across multiple users and threads. The only semi regular statement I have heard from support is that they “cannot recreate it in the lab”.

In the interim, many users have sent in multiple logs and also posted solutions that sometimes fix the issue and sometimes don’t. It is totally hit and miss both in its occurrence and resolution.

I honestly don’t know if the root cause lays in Sonos, Roon, home network or all of the above. Frustrating as it is I’ve kind of peaked my tolerance on trying to address it just to get 2 play 1s working stable.

1 Like

So I have finally had enough and rebuilt my Sonos setup on SonosNet and moved away from standard WiFi again and so far it has been running for 24 hours without issue.

It may fall off again, but this is the first time in many many months that I have been able to use my Sonos for a hole day. Somebody this may be related to Mesh networks or Sonos creating it’s own network.

It is frustrating that Roon has given no development time to this or gone beyond collecting logs to engage with user’s that have been suffering this issue

1 Like

I sold my two offending play 1’s. Had reached my limit on wasting time with temp fixes.
Just have one play 5 left now from old full house sonos system. Just have t conneced via airplay which is fine for kitchen use.

Be intetesting to see if your latest changes remain stable.

1 Like

Yes I will be slowly doing the same as well.
So far into day 3 and they are all still there.


Hey @Michael_Harris ,

Glad to hear that there’s been an improvement on your end! We are still actively tracking this issue, but there have been higher priority tickets that took precedence. Once there is more team bandwidth, I do want to bring this issue up again with the devs and see what further improvements we can make in this area. Thanks for your patience until that happens!

1 Like

Roon Core Machine

ROCK on NUC Barebone BKNUC8V5PNH Core i5-8365U 16GB

Networking Gear & Setup Details

Netgear R6850
NUC connected via ethernet RJ45
All Sonos Devices WIFI

Connected Audio Devices

1 Sonos Port
1 Sonos Move
1 Pair Sonos One
1 Sonos Play 1 Gen 2
All connected via Wifi

Number of Tracks in Library


Description of Issue

Connection to Sonos devices get very regularly lost. Connection to Airplay Sonos compatible devices is fine. Quality on Sonos is better and I don’t have all my Sonos devices compatible with Airplay.
I opened a case on April 8th, 22.
AceRimmer Community moderator answered at the time “I have moved your post here as it is a known issue that is being worked upon actively”
Any news on this issue.

1 Like

Norris I am away now but it was still working perfectly before I went away.
I am definitely thinking there is something related to Mesh networks. I was not expecting going back to the Boost and SonosNet to improve things as this is what broke things early on.

I will be happy to help debug and supply logs when you are ready to do more work.

1 Like

Roon Core Machine

MAC OS Monterey, Nucleus

Networking Gear & Setup Details

Wifi – Xfinity router plus eero for coverage

Connected Audio Devices

Bluesound & Naim speakers

Roon doesn’t see Sonos SL1 speakers

Number of Tracks in Library

10,000 tracks

Description of Issue

In the audio section of settings, Sonos SL1 speakers on same wifi network don’t show in list of devices – Bluesound and Naim speakers do show (also on same network)

John, glad to see you back. Are your Sonos speakers using SonosNet or attached directly to your WiFi or Ethernet network? Roon and Sonos seem to work best when SonosNet is not used.

1 Like

Hi Robert They’re on my wifi network – they appear on Airplay along with the other speakers

Do they appear again / become available to enable again if you reboot your core?

This sounds like the Sonos issue thst has been around for a year now and appears to affect users in random fashion.

No permanent resolution unfortunately. I sold my last 2 play one couple of weeks back as got tired of it all. Just have one play 5 left now (from what was a whole house Sonos system 3 years ago) which is just connected via airplay.

See these threads, there are some temporary solutions, temporary being the key word:

1 Like

Re-booting has no effect – thanks for the links!

But they are visible as AirPlay endpoints from within Roon? Do the SL1s have the most recent firmware update?

SL 1s have latest firmware – they are visible from Airplay directly, but are not visible as Airplay end points from within Roon – Bluenote & Naim are visible from both Airplay directly and from within Roon

Generally rebooting the Roon server brings it back for several hours. Rebooting the Sonos doesn’t make any difference.

After a year of frustration with Roon and Sonos, I finally gave up yesterday and I put the Sonos Boost back in the network to re-introduce SonosNet. It took several hours ally device’s were back working in Sonos and are still here almost a day later.

If you have modern Sonos I would recommend using Airplay if you continue to have problems.

1 Like