Sonos dropouts (Roon lost control)

5 posts were split to a new topic: No playback through Sonos Zone

I thought the Sonos update was about their privacy policy not a true update?

I have a theory that my Sonos problems are on pre-grouped Sonos, meaning two Play:1 grouped in Stereo, a speaker and a Sub grouped, or a Playbar and speaker grouped. These are groupings that exist in Sonos before using Roon. Does that match your problems?

My recent problem was sliding forward on the playback (skipping ahead 1 minute in a song) and it lost it. Other people have commented on skipping songs too fast.

@tboooe What scenarios cause your problems?

I am facing the very same challenges. My setup is wired network. 2 stereo pair grouped with Sonos App. One Play:5 (gen 1) and one current Play:1. I have yet to understand where the problem is coming from, I simply cannot see any pattern too.

Anything I could do to help here?

1 Like

Since the last update. I have also seen the same issues I have 5 Sonos units in my home. I can start playing to any single one unit and after 1 or 2 tracks I get a message that 'Roon lost control. Until recently this has been rock solid. My only data point is it only started after the last update.

Hi @phakju and @Allan_Rentcome ---- Thank you for chiming in here and sharing your feedback with us. Very appreciated!

Moving forward, may I very kindly ask you to please provide me with the following:

  • A brief but accurate description of your current setup, using this link as a guide.

  • Please outline your network configuration/topology, being sure to provide insight into any networking hardware you are implementing.


Hi there

I have Roon core running on a Mac mini and I am using clients on my iPad. I am running both core and clients at 1.3 build 262.

My Mac mini is connected to a hardwired LAN via an Asus router and switch. My Sonos systems are connected via WiFI to the same network. The Mac mini is a static IP address.

I have five Sonos endpoints as well as other networked airplay devices and a NAD M17 in my main listening area using BluOS.

At some point in the last month any Sonos endpoint will eventually result in the ‘Lost control’ message.




do you need any more data/logs on this issue? Last night the Wife was not happy due to Sonos just stopping playing. Roon remote displayed the 'Lost Control…'message and would not restart the audio. The remote was not even in use at the time as she was in the bath…

I can usually get this message through skipping tracks (clicking Next track several times) but have not tried to determine a repeatable failure mechanism, it just tends to happen. Playback usually starts again under these circumstances though, when the Play icon is pressed.
None of the Sonos Connects are Grouped; all are wired.

24 hours later: Just to update this, got home Thursday after work and Roon was running like it was made of treacle. Really slow response to both Win 10 and Mac OSX Remotes. Slow searches, and pressing play resulted in a 10 second delay before any audio started. Restarted Roon Server via the web interface and all was back to its normal snappy self. I left Roon playing all day Friday whilst at work (through a Sonos Connect) and it was still playing when I got home. Jimi Hendrix is currently doing his best to rip the speaker cones from their surrounds… :slight_smile:

1 Like

Same issues here but with a single speaker…
My Sonos Play:1 is wired so nothing to deal with WiFi.
Roon sees it perfectly, but fails to control it.

I’ve tried resetting the Sonos speaker, connecting again etc…
It worked for few minutes then dropped again.


I’ve just started my Roon subscription and getting the same ‘Lost Control’ messages as other here.

I’m streaming content from Tidal, to a single, wirelessly connected ZP 120, using the latest version of Roon (1.3 (build 276) on a late 2011 MacBook Pro, 2.4 GHz Intel Core i5, with 16 Gb of RAM. Tracks will stop playing randomly and can be difficult to restart. I get the same issues when I try to stream ripped music form my NAS to the same Sonos zone. When I use the Sonos app for the exact same content, to the same sonos endpoint, music plays flawlessly. No drop outs or random playing stops at all.

While this does appear to be a software problem, I’m wondering if it may have something to do with a particular Roon tasks running in background :thinking:

As a new user, I have ‘imported’ a lot of ripped music into Roon and also subscribed to a number of Tidal feeds. I’ve noticed this has resulted in a background task being kicked off in Roon to ‘analyse my music’ and use the results in volume levelling and crossfade. I’ve had Roon running for nearly 3 days, with background analysis speed set to ‘throttled’, however, it’s only managed to analyse 35 or so of 1,750 tracks… I’m wondering if this, or another background task, could have something to do with the player stopping intermittently…?

I’m going to try turning this and any library update background task off, to see if it has any effect of the ‘lost control’ issue. I’m also happy to help with any other testing, as I’m very motivated to move over to using Roon as my media server, verses using my current combo of Squeeze & iPeng for main listening area and Sonos App for my multi-room players.

Ok, so here’s an update and hopefully a fix/workaround for those who are still having an issue with Roon ‘losing control’ of the Sonos player / zone.

I initially thought that some background processing in the Roon server may have been causing the sudden loss of control/playback stops, when streaming to a Sonos player. I can now safely say that turning the background processing off, had absolutely no effect whatsoever, and drop outs continued a pace!:slightly_smiling_face:

However! in the course of trouble shooting, I moved the MacBook, which is running Roon, to the media closet where I have my router and an Ethernet connected Sonos bridge. The Sonos bridge acts as the gateway for my wireless connected zone players.

I then disabled the MacBooks wi Fi and connected it via Ethernet to the router. This provided Internet connectivity for the MacBook to access Tidal and a wired connection into my Sonos network.

I fired up Roon and could select a tidal album and stream to the zoneplayer without any drop outs or Roon ‘losing control’ of the end point zone.

I then opened Roon on an iPad and tried to take control of the play queue, volume etc. That worked ok, but navigation was a bit jittery and play stopped a couple of times. So I returned to the laptop and backed out of the album I was streaming. Then restarted streaming the same album from the iPad control point. Hey presto! Smooth navigation and no drop outs. I’m also able to group and ungrounded zones and transfer music form one zone to another without any interruptions to play :slightly_smiling_face:

So, what might we conclude…:

  1. With the current Roon software build, It looks like you need to have a wired Ethernet connection from the computer/device that’s running Roon, into a point on the Sonos network. Mine is direct into the router, but I will try an Ethernet over mains connection to the router tomorrow to see if that works too.

  2. There still appears to be some ‘conflict’ between control points (in this case Roon on the MacBook and Roon in the iPad) when trying to control media at the track level simultaneously. This can be avoided by making sure you just have one control point accessing a zone at any one time

  3. It seems there may be some software conflicts between Roon and Sonos when trying to process the comms wirelessly, verses interfacing the two via a hardwired Ethernet. This maybe something the Roon developers can take a look at.

Hopefully the above might prove useful for anyone to try who is still having problems with losing control of Sonos Zones and devices.



My current feeling is that Roon falls into a particularly unreliable corner of Sonos networking performance. We work fundamentally the same way the official Sonos app does, except that some of the details tend towards worse network reliability:

  1. We stream very long gapless files, so any interruption anywhere causes a problem. The Sonos app plays a long sequence of small files, so there are many opportunities to “reset” everything.
  2. The data Roon is sending always comes from the machine your core is installed on. Using the Sonos app data can come directly from a streaming service over the internet, or directly from your NAS. This may imply better networking performance, and is probably why your NAS/Sonos app content worked before, because your NAS is probably hardwired.

I would guess that if you went back to the original state, with the MacBook connected wirelessly, and moved a single long (1-2hrs) FLAC file onto the MacBook, and then played that, you would observe similar dropouts to Roon. (or maybe not, because file on NAS -> Roon Core on MacBook -> Sonos Bridge -> Sonos Player actually goes over the MacBook wifi twice).

We will continue to do what we can to improve Roon/Sonos reliability, but both of those problems above are fundamental to how Roon the system works. They are likely never going away, and locating the Roon core in a media closet next to the router where it can be hardwired will always be a good idea.

Many thanks Ben, that makes sense.

I think also that by hardwiring the Roon core into the Sonos Bridge (via the router), you are in effect plugging the Roon core into and taking advantage of the Sonos mesh network, which inherently suffers from less drop out issues than point to point connections. My NAS is also hardwired as an Ethernet connection into a Sonos Connect, so that too probably takes advantage of the Sonos mesh network connectivity in some way.

Of course, it’s not always possible/convenient to co-locate the machine that has the Roon core with the router, so now that I have a configuration that works (fingers crossed) I will also experiment with an ethernet over powerline arrangement from the core machine back to the router where the Sonos Bridge is. I’ll report back here as to the stability of that solution.

Kind regards


This is exactly where I’m at. I have about 7 Sonos speakers in varying sizes.

• If I stream to a single Sonos speaker things work as advertised.

• The minute I begin grouping those Sonos speakers into a Roon zone, music immediately begins to stutter, then a second later the party stops and I get the “Lost control of endpoint” alert.

• However, when I set my Room core to output to system default sound card (a Dell touchscreen that uses a 3.5mm audio cable) and connect that to the line-in on one of my Play:5 speakers (which is grouped to all speakers via Sonos app), then I have no problems at all.

So it appears to definitely be a problem with the manner in which RAAT groups zones vs the way Sonos groups zones in their own controller. I wonder if having the speakers grouped in two different controllers (RAAT and Sonos) at the same time causes some sort of issue. I’ll try ungrouping all speakers within the Sonos controller, and let Room try handling them all via RAAT.


So that failed miserably. It seems Roon just can’t handle grouping multiple Sonos speakers together. Seems the only way I can get it to work is to out Roon (wired) to a single Play:5. Then in the Sonos app I can group the whole house without any drop-outs or lost connections.

My Roon flags: C:\Users\name\AppData\Local\Roon\Application\Roon.exe -scalefactor=1.25 -nosonosflac

Here is the track I tested with:

Adding one Sonos speaker at a time to the grouped zones (from within Roon) caused the Sonos app to throw the following errors, until you see the connection finally just die at the end.
Friday, February 23, 2018 - 9:59 PM Baghdad
Unable to play ‘Roon.flac’ - the song is not encoded correctly.

Friday, February 23, 2018 - 9:59 PM Baghdad
Unable to play 'Roon.flac' - the song is not encoded correctly.

Friday, February 23, 2018 - 9:59 PM Baghdad
Unable to play 'Roon.flac' - the song is not encoded correctly.

Friday, February 23, 2018 - 9:59 PM Baghdad
Unable to play 'Roon.flac' - the song is not encoded correctly.

Friday, February 23, 2018 - 10:00 PM Baghdad
Unable to play 'Roon.flac' - the song is not encoded correctly.

Friday, February 23, 2018 - 10:00 PM Baghdad
Unable to play 'Roon.flac' - the song is not encoded correctly.

Friday, February 23, 2018 - 10:00 PM Baghdad
Unable to play 'Roon.flac' - the song is not encoded correctly.

Friday, February 23, 2018 - 10:01 PM Baghdad
Unable to play 'Roon.flac' - the song is not encoded correctly.

Friday, February 23, 2018 - 10:01 PM Baghdad
Unable to play 'Roon.flac' - the song is not encoded correctly.

Friday, February 23, 2018 - 10:02 PM Baghdad
Unable to play 'Roon.flac' - the song is not encoded correctly.

Friday, February 23, 2018 - 10:04 PM Baghdad
Unable to play 'Roon.flac' - the connection to was lost.

Update 2:
Sonos is obviously struggling to read the file that Roon is sending. But while I’m adding new Sonos speakers to the zone, the first/original Play:5 I started playing to continues to play the song the whole time until the connection dies.

With the Sonos app open (side-by-side with Roon) you can see sonos group the speakers automatically as you group them within Roon, but the Sonos app throws a visible error with each speaker I add to the group (from within Roon). Sometimes the newly added speaker plays sound for a second or two before stopping, other times no sound comes out at all. But the Sonos error log is always the same as you see here, and the original speaker always continues to play until the connection dies.

If I start a song with all Sonos speakers grouped to begin with in Roon (first group all speakers, then stream to the zone), then none of the speakers play any sound and the same events appear in the sonos logs.

Question: it seems like Sonos uses a master speaker to synchronize a zone ( whichever that may be), and then handles syncing the rest internally ( which you can see works well when I output, wired, to a single speaker (default system output in Roon) which is subsequently grouped to all speakers in Sonos).
So does Roon try to stream to each Roon-grouped Sonos speaker individually? That may be causing a brain freeze in Sonos if they are optimized to listen to a single master and just slave off of it, but Roon is telling each speaker to be the master?

You guys seem familiar enough with the Sonos API to be able able to tell Sonos to create zones. So maybe we can revisit that code and check if there is a way to send the group command, but make sure we don’t try to stream to more than one (the original/master) Sonos speaker in the Roon zone.
If it were network related, I would expect to have the same problems using just the Sonos app, or with my current setup of outputting to a single Sonos speaker via audio cable to line-in - but thats not the case. After all my tests, I’m nearly positive that Roon must be trying to output to each Sonos speaker individually, yet Sonos’ internal instructions work off a master/slave protocol. Heh, or I’m dead wrong…

I wish Roon wouldn’t try to manipulate the zones that are configured iside the Sonos app, and instead just play to a designated speaker, honoring whatever Sonos zone configuration is already setup there.

E.g. When I output to my Play:5, Roon isolates that speaker inside the Sonos controller even though I had it grouped. I would prefer that Roon respected the Sonos zones if they exist. But maybe thats just me. For now, there is no way to get music to play on multiple Sonos speakers from within Roon unless you hard wire an audio cable into a Sonos speaker that is then grouped via the sonos app.

*That’s pretty wordy, but hopefully it makes sense.

Ian, sorry to hear about the sonos troubles. I have two sonos (old gen) speakers and have been using then with roon without big issues as long as I avoid hitting ‘next song’ too many times. I also found that fast forwarding a song a few times will result into ‘lost control’. This is with two sonos zones grouped via Roon. You have 7 so maybe that exposes roon’s issues with sonos. Out of curiosity, have you tried grouping 2 or 3 zones via Roon (instead of 7) to try and see if the problem occurs?


Yeah I just finished another test. It seems that if I only group the two Play:5 speakers, it does actually work reliably (that includes a hidden sub in that stereo pair). At exactly 3 speakers and higher things immediately go wrong and sonos begins throwing errors into the logs like you see above.

It’s all in the name of documentation anyway. I have a "wired’ Play:5 approach that works well enough for me. And I don’t have to use that atrocious Sonos app.

aha! so it might be that problems begin with 3 or more grouped sonos speakers. I bet you have tried this already but just in case… are you running your sonos speakers via sonosnet or via normal wifi? If not maybe worth hardwiring one sonos speaker to the router via ethernet to create the sonosnet. I find it is more stable.
You have most likely already tried this but just in case

I have them all on a Boost and some of the more distant speakers mesh. Like I said, its just strange that when I output from Roon to a single play:5 via audio cable (the rest being grouped via sonos app) then theres no issues at all. Its only when i try to group them all via Roon that things fall apart. Strange because it doesn’t seem like there is any difference. But Roon and Sonos obviously do something different in how they group Sonos speakers.

I don’t think it is a clear cut answer by way of the number of Sonos speakers. I think it has a lot to do with the network load overall and the strength of connection for individual speakers. I have a few wired Connects and several wireless speakers (1’s, 3’s, and new 5).

I moved my traditional network to mesh (eeros) and things got a lot better in terms of dropouts, almost going away. Then it seems with the last Roon release things have gotten worse again. I can usually run 4-5 speakers in a group without issue (as mentioned not hitting too many skip songs or fast forwarding).

Not related: the Sonos hard buttons don’t work other than volume. You can’t use them to skip a song. If you stop streaming you can’t restart the Roon stream. That would be nice if they worked.


It looks like your Line In stream is getting Compressed by Sonos. Roon would not do that, so maybe that is a difference?