Sonos IP addresses not updated in Roon Core [Roon Investigating]

Hi @support,

last weekend I tried to transfer audio playback from a Linn device to one of my Sonos speakers. The transfer didn’t work out and resulted in the “Roon … lost control” message.

I investigated a bit deeper and quickly found out that all my Sonos speakers were listed in Roon with IP adresses which were no longer valid (I cannot tell the exact reason why they changed but either the DHCP lease-time ended or my router (which is also DHCP server) rebooted after a software update of the provider). In general, all my Roon endpoints (Sonos and Linn) get dynamic IP adresses out of a DHCP pool.

I rebooted Roon Core (which is 1.5 build 334 running on Ubuntu 16.x) and the IP addresses of the Sonos speakers have been updated right away. The transfer of the audio playback (which I wanted to do initially) could now be performed without any problems.

Now I am wondering how Roon deals with changing IP addresses in general ? Is Roon somehow scanning the network for known devices on regular basis to learn about changed ip addresses ? What could have gone wrong in my case that the old ip addresses were still present in Roon eco-system ?

Any advice is apprechiated.

Regardless of how ROON deals with the network, one golden rule is to assign static IP addresses to your devices. This way you’ll avoid lot of troubles along the way (as is the one you already had)…

Thanks for the comment @anon82498359.
As far as I know wether Sonos nor Linn devices can be configured with static ip addresses on the device itself. They all rely on a DHCP server. The only way to do that is to assign a static ip address to the mac-address of the device.

I’ll check again but I think I cannot do this with the router of my provider. Those features are only available on the command line interface which is not available to customers. I only can use the web-interface of the router.

Hey @papa.jay,

I just wanted to reach out and let you know that I opened a ticket with our technical team to get feedback on the expected behavior here. I’ll be sure to update you as soon as I receive their feedback.



Just checked my router and there is no way to assign static ip addresses via dhcp. The provider locked the command line interface and the web interface doesn’t provide an option for stuff like this :roll_eyes:

Maybe it’s finally time to invest some money in a serious router/firewall…

1 Like

Hello @papa.jay,

We were able to reproduce this behavior using our Sonos test setup. I have passed the details on to the development team for further investigation. We will keep you updated on further progress regarding this issue.



Hi @john,
after some changes in my network this problem showed up again. After restarting the Core the problem was solved and the IP addresses have been updated. Any news when there will be a fix for this issue ?

This happens to me too, any updates?

hi @brian_green1,

I never received any feedback from @support since my last post. I was able to work around the problem by assigning fixed IP addresses to my Sonos gear. The problem never reappeared since then.

Note: My new router is able to assign fixed addresses from a DHCP pool. My old router (the router from my service provider) wasn’t. So this work around is only possible if you have a device which can assign fixed DHCP addresses.

@support Was there ever any fix for this issue? I just factory reset my Sonos (and downgraded from S2 to S1), it got a new IP address and I hit this problem. Restarting my Roon Core fixed it, but it did sound like you guys were aware of/working on this, 2.5 years ago. :flushed:

I have exactly the same problem and I can still see in my Roon device list IP addresses that have changed for one of my devices. Therefore, I have listed both old and new IP addresses for the same device.

How do I “flush” these retained IP addresses from Roon ROCK server?

Andreas I recently went through this after the latest update. I found that rebooting the Roon core fixed this.
I then set all my Sonos devices to have reservations in my DHCP server.
As a test I did one at a time and Roon never found one without a reboot first.

Hope that helps

I have rebooted my ROCK server, rebooted the PC and also the networking equipment, but without success. I have actually raised now a support request, explaining my issue and asking the experts how to fix this.

Good luck Andreas
Roon claim to have not been able to reproduce this at all even though quite a few users have reported it.

Actually they did (see here)

Sorry Pappa I meant after the latest release.
There was a sudden uptick in Sonos dropping off the face of the earth on the day of the release (or the beta if you count my reports and log files).
Though interestingly it looks very much like the same issues three years apart

I see. Thanks for clarifying.