Sonos issues w/ Roon: dropouts, control issues, etc

Roon Core Machine

Windows 10, i5-6300U CPU @ 2.40 GHz, 8 GB RAM

Networking Gear & Setup Details

Mikrotik RB4011iGS+5HacQ2HnD (arm) running RouterOS 6.49.2 (stable)
Configured via CAPsMAN to 3 other satellite access points (2 Mikrotik Audiences - RBD25G-5HPacQD2HPnD, and one cAPac RBcAPGi-5acD2nD).
All APs are ethernet wired.

Connected Audio Devices

  • iMac (13,2) i7 3.2 GHz 24 GB RAM MacOS 10.15.7 output via USB (via CAT5) to Peachtree DAC → power amp
  • Sonos Play 1: wired
  • Sonos Play 1 x 5: wifi connected to SonosNet
  • Sonos Play 5 x 2: wifi connected to SonosNet

Number of Tracks in Library

13,000 tracks

Description of Issue

Am testing ROON in hopes to move to this. But, cannot get technical issues sorted. Peachtree (running RAAT) seems to be fine, although limited time on it as spent time troubleshooting the Sonos.
Sonos speakers are suffering from dropouts continually, especially when grouping together (using Roon), completely stopping, volume settings very delayed, etc. Variety of seemingly network issues. I’ve experimented with using TIDAL stream vs lower resolution sources residing on same machine as core, to same result.

Situation, can be improved by using ROON to send to only to Play 1 that is wired, then using SONOS app to group sonos together. But it still suffers similar issues, just less ‘drastic’ or as often.

I’ve spent most of trial period reading KB, Roon Community support articles and experimenting - but cannot resolve. My network was setup by an IT network specialist and has been rock solid for long time. Sonos work reliably since they’ve been moved to SonosNET vs regular wifi.

It just seems, it is very hard to get SONOS to play nicely with ROON or vice versa.

Hi @Bernhard_Neuhofer ,

Can you please try to temporarily connect one of your Sonos zones via Ethernet instead of SonosNet or WiFi?

Does this mean that they were not stable on WiFi before you switched them to SonosNet? Where did you notice the issues on WiFi, outside of the Roon app?

Do your Sonos zones support Airplay? Are you able to reproduce the issue when using Airplay streaming to the Sonos zones?

Hey @Bernhard_Neuhofer, I’m a relatively new Roon user, but have owned Sonos gear since 2014. I have all first generation devices like you - Play:1 x 3, Play:3 x 4, Playbar, Sub. The 9 devices are grouped into 4 rooms - Bedroom (Play:3 stereo pair), Kitchen (single Play:1), Living Room (Playbar, Sub, Play:3 x 2 as surrounds, in a home theater 5.1 setup), and Sunroom (stereo pair of Play:1s).

All my devices pre-date AirPlay 2 (released in 2018), so the only networking option is to hardwire one device to my router (I use my Playbar), which triggers the creation of Sonos’ private, 2.4 GHz mesh-type network called SonosNet. This appears to be what you are doing as well. Note that you only need to hardwire one of your Sonos devices. Sometimes hardwiring more than one can create issues of its own.

While Sonos advertises that it’s gear is capable of handling hi-res audio up to 48/24, the reality is the older gear can only support 44/16.

When I first started my Roon trial a couple of months ago, I was experiencing the same thing as you. After checking under Device Setup for each of my 4 rooms, I discovered that Roon sets the default “Max bits per sample” to 24, in line with what Sonos advertises. However, after reducing the bit depth from 24 to 16, my issues with dropouts and stuttering magically disappeared.

Here are some screenshots to show you what I’m talking about:

The 2nd screenshot shows the signal path to my Play:1 in the Kitchen. I generally always start with the highest res version of a song (in this case 192/24), and then let Roon work it’s magic by down-converting the bit depth from 24 to 16, as well as by down-sampling the sample rate from 192 kHz to 48. I’ve found that it makes no difference whether the sample rate delivered to the device is 48 or 44.1, but the bit depth being lowered to 16 is essential.

So I’d strongly recommend giving that a try to see if it might clear up your issues. I hope so. If I hadn’t made this discovery, I wouldn’t be here today making these comments.

The only glitch I run into on a fairly regular basis is that ungrouping rooms in Roon doesn’t always work properly, so opening the Sonos app is necessary in order to re-sync the room groupings again between Sonos and Roon. But this doesn’t happen every time. So I can live with that relatively minor inconvenience as long as I don’t experience any significant stuttering and dropouts.

Edit: In case this may be helpful, here’s what appears under my Settings>Audio:

1 Like

100% agreed.

  • set up each zone in Settings/Audio as Sonos streaming and not Airplay
  • also in settings downsample every Sonos zone to 16 instead of 24
  • wire one and exactly one Sonos zone, do not use Wi-Fi but instead ensure Sonos is using its own network vs Wi-Fi (in Sonos / settings / network, you can click on manage networks / [your wireless network name] and hit remove network; if this doesn’t work for you you will have to set up Sonos again, but this is the much more reliable way to get skip-free group playing)

Try 1 & 2, and if you’re not happy, try 3 as well.

Good luck.
John

1 Like

Out of hearts @Johnny_Ooooops. :+1:

1 Like

A Sonos Boost might help. I had connection problems using AirPlay. Some rooms do not have wired Ethernet so wireless is the only option. The Boost is used with Sonos Net and amplifies the signal. It resolved my coverage problems. For $99 it is worth a try.

Well, I must say I hadn’t come across this setting in any of the other reading or searches! But thank you so much, that has made a massive improvement. I’m just starting the testing process, but totally different experience. I only see a slight delay in all speakers when grouped to get the new feed, as well as a delay in changing the volume of a specific speaker.

I will test more, but it is MUCH improved!

To address other questions and points posted - my only speaker that is Airplay compatible is my FIVE, but it does not make things better.

And before using SONOSNet I had delay from the mobile app controlling the speakers, as in delayed connection to change song/volume/etc. But, if anything was playing, there were no dropouts.

I’m also in the very difficult process of running ethernet cable to a number of the Sonos Speakers. It concerns me that someone said having more than one speaker wired could make things worse!? That’s very concerning, hopefully that does not bear out.

I will post back with more testing.

Since making the changes to the device settings ‘Max bits per sample’ output to 16 bit, it has been much improved. However, I still have issue upon song changing, it takes up to 10+ seconds for all speakers to come back with new song.

I have one speaker (called “Island”) connected via Ethernet, the balance via SonosNet. When I use only that speaker, it works better, so that songs advance without interruption and volume changes are close to real time (still slight delay).

Does the “sing changing delay” show up only on Sonos zones but not RAAT zones? That would be wild and I’d have to think about why that might be. Are you sure it’s only with Sonos? Only with grouped Sonos zones? All zones? If you could check and report back that would be much appreciated.

I’ve had that, but it was all zones, and it required changes to my unifi network to address. But let me not leap to conclusions.

Really glad to hear the 16 bit “downsample” was helpful.

No, using RAAT zones it works perfectly or at least the little I’ve tried . . . all my energy and time has gone into trying to sort out the Sonos issues. Sonos is used daily as household general music in many areas of house. My RAAT zones, are more audiophile grade and used for more “special” or purposeful listening (DAC/Tube Amp/Big full range speakers, etc.). And of note, one of my RAAT zones is driven via USB output/ethernet cable from an iMac that is wireless to my network, works without a hitch.

I’ve since ran another ethernet cable to one of the FIVE’s for a lark, to see if I can play those two speakers that were wired without fault. The two wired ones seem to behave - they are grouped. I am in process of wiring in both FIVEs permanently (opening lath and plaster and installing keystone jacks, etc - a BIG job). But, I will never be able to wire ALL my Sonos.

I LOVE the ROON app, for discovering new music and even discovering my OWN music again. It’s excellent. I’d really like to be confident in it and would consider upgraded hardware for the server if stabilized.

I will test more and report back. Specifically will
a) test RAAT zones more and
b) test the grouped zones of two wired SONOS speakers.

If working well enough, I will add just one more sonos to the group which will be wireless and report back on above.

So depending on how deep down the networking rathole you want to go, you can wire more speakers. I did. But I have fairly “prosumer” networking gear (Unifi UDM pro, 2 core switches connected with fiber, 4 L2 switches, 1 L3 switch, 8 wired APs). I had to figure out RSTP, and set all the weights correctly on my switches manually so that I didn’t get “loops” and network storms and separated Sonos networks. It’s not for the faint of heart, but it works. I wouldn’t do it again if I didn’t need to (I have a second home with 8 Sonos zones and similar networking gear also, and though it’s more spread out it’s got less neighbors and so less interference and I don’t have any issues so I leave only one plugged in. You’ve been warned :slight_smile: this can really mess things up but it is possible with some gear.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.