Sonos - Lost control of audio device

whatever happened here? I have a similar problem with sonos and my synology 918+ the sonos bridge is connected to synology and then i have four sonos zones attached via wifi. sonos works perfecty but often roon stops and says roon lost control of audio device. if i disable some of the sonos speakers it works but not with all. i have a very fast connection and have never had trouble till i got roon. (i have the roon database on an ssd attached to my synology.)
i am stumped. i also hae and oppo 203 and maybe i should use that.

Hi Michael.

Version 1.3 (build 269) stable solved all my problems with Sonos as endpoints. I have not managed to force it to hang even though I have really tried. Roon has behaved perfectly on my 5 Sonos endpoints.

I am running Roon on ROCK OS and on their recommended hardware.

Hi @Michael_Specter ---- Thank you for the report and sharing your feedback with us.

Moving forward, I would like to gather the following information from you to help us better understand why you may be experiencing this behavior with your setup. Please see below.

  • An expanded description of your current setup using this link, as a guide.

  • Please describe your network configuration/topology being sure to provide insight into any networking hardware you are currently implementing. I want to have a clear understanding of how your Sonos device are communicating with your network/Roon.

  • I am assuming that the answer to this question will be, “No”, but please verify if you have ever experienced the same behavior while using the Sonos application to stream to your endpoints.


@support Ok. Thanks I will try:
First, As you suspect I have no such problem with my Sonos setup when I use it directly, with with Tidal or lossless music from my library.
This problem seems to happen, particularly if I change from one bit rate music to another, but it seems to be random, too.

My setup: Running the latest version of Roon (just joined)
OS X High Sierra
I use a Synology 918+ My library is on the server (small by Roon standards - a few thousand albums) and I keep my core on a Samsung portable SSD (attached to the USB 3.0 port.)
I have three zones but only use one with Roon, mostly (since they cannot all be played at once as far as I understand.)
I have an 0pp0 203 Blue ray and a Denon AVR also attached to my network (Arris router.) When i use those zones, which is rare, I have no problem playing through the Gallo surround speakers I have in my den.
but in my main listening zone are all Sonos:
Sonos Boost is attached to my Synology via ethernet and I stream from there on the SonosNet to : two Play 5s (first generation) two play 3’s and a play 1.
My networks is very fast and stable and have no trouble with any other high demand activity (4K streaming etc.), casting from my Macbook pro to the TV or from either a Pixel phone or an Iphone.
I have tried to shift the Sonos network between channel 6 and 11. It doesn’t seem to matter.
Anecdotally, it seems as if there is a latency issue or something.)
I hope it is some silly error of mine; seems impossible to believe Roon can’t handle this network configuration. if I needed to get a DSP I would, but not sure why that would solve this problem or improve performance.
(Oh, I have tried reducing the number of Sonos players) and that doesnt matter.
When I get the problem, usually it will eventually go away after ten minutes or soi f I switch to just listening to my Sonos app. A couple of times I have had to reboot the Synology. That always works, until. of course, it happens again.
Any help possible will be greatly appreciated

@support Ooops. One thing: My Sonos Boost is also connected directly to my router via ethernet (ile. I have one port going to the Synology and the other to my router not a switch.)

@support This somewhat scientific observation just in: after playing with a million parameters I move the Sonos boost out of the cabinet where it was right next to my NAS and my router. I just got a longer ethernet cable and put it about five feet away for the moment. So far, all the transport loss problems seem to have stopped. I have for more than half an hour jumped constantly between my Sonos zones and my Denon and moved from very high quality music to AAC and back and then to the radio and then to lossless etc. No problem. I am not sure WHY this would make a difference but it seems to have done so.

Hi @Michael_Specter ----- Thank you for taking the time to answer my questions and following up with me. Very appreciated!

After reading your most recent observation, I wanted to touch base and see how the Sonos endpoints have been holding up after having removing the Boost from the mentioned cabinet.

Furthermore, did you try testing with the same ethernet cable that was being used in the cabinet, outside of the cabinet? I am wondering if something is wrong with that cable, because having the device in a cabinet should have no forbearance on the way traffic is moving across your network.


Same cable. Five feet away. It is working perfectly and I pushed it heavily this morning just to see. I really belive that somehow having the boost RIGHT NEXT to my router was the problem. I looked this morning and Sonos also suggests that the be separated by at least a foot (mine was five inches. Now it is five feet.) I will let you know if things go off the rails but so far so good.

1 Like

This is the relevant section of the Sonos manual. I know this begs the question: why did it work before Roon. But I also added the Synology 918+ and a UPS at the same time in the same small space. Hard to isolate but as long as it works I am not going to worry:

If you have a Sonos product wired into your WiFi router, separate the two devices as far as the Ethernet cable between them allows; 1 ft. (30cm) or more is ideal. Also make sure your Sonos system and router are operating on different wireless channels.
Reducing wireless interference - Get Answers about Sonos