Sonos - lost control while playing through Roon

I am having the same issues with “Roon Losing Control” of a Sonos Play 5. My Roon core and sonos are both wired and I am not using Airplay. I streaming Tidal at cd quality. Running Tidal via the Sonos app is very reliable, but running it via Roon drops out within a minute or two. Running Sonos either wireless or via airplay makes it happen less, but it still happens. My Sonos play 5 is running S1 (details below) and I have not tried S2 as that would not work on my older sonos devices. I am running Roon 1.8 Build 778 64 bit on Windows 10.

Sonos OS: S1
Version: 11.2.6 (build 57587010)
Hardware Version:
Series ID: C100

Hello @Brad_Novak ,

Can you please provide more details regarding your network setup (model/manufacturer of gear) and let us know if the issue impacts only TIDAL or does it impact local content as well?

The issue is on both tidal and local lossless content. I use netgear orbi mesh network with a router (RBR50) and 3 satellites. The network is very reliable and my broadband is 900Mb.

I have split my sonos network so the Play 5 is now in a clean/new Sonos account and its now running S2. That has helped. I think the clean account on sonos with no other devices and no historical setup may be helping ensure that all content goes direct and wired and not somehow across Sonos Net or wireless.


I found that some of my issues were exacerbated by a VPN I had been using. I’m using Mullvad now and haven’t been having the issue.

Hi @Brad_Novak ,

Can you please verify this setting?

Networking Best Practices Guide

Netgear Orbi Routers

If you’re making use of an Orbi router, we recommend unchecking Disable IGMP Proxying in your router’s settings. This setting can interfere with the ability for Roon Remotes to connect to the Roon Core.

I don’t believe I have that setting. My Orbi Router runs in AP Mode not Router Mode. My internet facing router comes from BT and is a BT Smart Hub 2.

Hello @Brad_Novak ,

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

What kind of Roon Core are you using? Can you please reproduce the issue, note the exact local time + date + track with the issue and then use these instructions to send us a log set from your Core for review?

Any questions, just let us know, thanks!

Hi Brad I have a similar setup running in router mode and I used to have this problem quite regularly before.
I did uncheck the Disable IGMP setting on my system but also took out a Sonos Boost and plugged my Amp into the backbone switch and move devices from Sonos net to WiFi.

Took a bit of tweaking but became totally stable and has been perfect for almost two years now.


I have sold my sonos play 5 on ebay. I think its a Sonos networking issue and not roon. I tried various network configs, but the sonos still would occasionally get confused. I could not find IGMP in my Orbi, but I think its because I have a BT router between my Orbi systems and the internet.

Brad you probably want to switch to running the Orbi in Router mode and turning your BT router into a modemi you are going to struggle with Roon otherwise as it wants to use Multicast and that is what that option does.

Been there myself as I don’t only have Sonos, but currently sitting in the garden with a stero pair of Play ones and a Sonos move playing flac files perfectly synced with zero dropouts.

My Orbis are the very first generation RBR50 and an RBS40 in the conservatory. It’s worth the small amount of work to get them running in router mode.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.