Sonos Play 5 Works from Tidal App But Not From Roon

I’ve checked all the Sonos queries here but can’t find a similar query so here goes.

I’m running Roon core on a Microsoft SurfacePro as a standalone core. Majority of my library is via Tidal. I also stream via a Cambridge CNX v2 into a Marantz receiver to my Orpheus floor standers. No issues there.

I have a Sonos Play 5 in the Kitchen / Dining room for casual listening which is supplemented by a Sonos Boost. All connections are wifi except the Cambridge and the Boost which are Ethernet.

Wifi is strong throughout the house so no concerns there with range or strength. My problem is if I use the Tidal app directly to play music to the Play 5 I have no issues. If I use Roon whether via Sonos network or Airplay then It just get the “Roon has lost control of the audio device” message. I’ve tried resetting Roon, disconnecting and reconnecting the Core, signing out and back in of Sonos, as well as Roon but still no joy.

Believe this is unrelated but when I try to configure the Roon core on the mobile app it doesn’t appear to connect or take me to a configuration screen.

Any thoughts?


Hey @Bryce_Stuart,

A belated welcome to the Roon community :wave:

I appreciate you choosing to let us know of the issues you run into when trying to play music via your Sonos device when using it with Roon only. The truth is, streaming music via Roon demands more bandwidth than streaming from TIDAL directly.

Simply for testing purposes, could you please navigate to Settings → Services → Tidal and lower the streaming quality. Please try listening to a track. Is control of the audio device lost then?

Thanks in advance :pray:

P.S. A big thank you for your incredible patience with us. I sure hope we would have had a chance to get back to you sooner :pleading_face:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.