Sonos playback errors - "Roon lost control control of the audio device"

As I understand @AMP’s question/report, it’s not about any one music format. The thing he’s saying provokes the problem is transitions between different music formats on the same playlist. So, for example, playing two 44.1/16 MP3 files and then a 96/24 FLAC file would be more likely to cause a stop at the 44.1/16 -> 96/24 transition.

In addition to his evidence that this is a problem, Roon internally effectively stops and restarts the whole stream to change DSP settings when this occurs. This gives a mechanism as to why this would be more likely to cause breakage in the Sonos streaming mechanism, because there are more moving parts to go wrong.

(Sadly, I’ve tried looping playlists of 5second tracks each with a different format, and can’t trigger this reliably)

for me the issues occur (1) only with Sonos, (2) at seemingly random places during playback - rarely at the beginning of a song

For me it rarely occurs once I get the music playing. 9 out of 10 times the error only occurs within the first 5 seconds of me starting a song. However, today while playing Tidal I got the error during the middle of the playlist at the transition point. No upsampling or conversion.

Build 204 seems to have solved this for me

spoke too soon - still having the same random control loss on Sonos

Dang…Saw your first post this morning and got very excited. I wonder if this only impacts older Sonos devices like mine? The newest one I have is over 6 years old.

FWIW, Many of my Sonos players are more than 10 years old…with all at least 5 years old

And I can play them singly…or in Groups…or all together…and I don’t have any of the issues above

Well there goes my only theory and hope of getting this resolved! :slight_smile:

The Roon core 2.04 update has made things considerably worse for me. After only a couple of these “lost control of the audio device” errors over the past week, a while ago I started getting them constantly while playing Tidal to my Sonos Connect (only a year old). All songs would stop transmitting to Sonos after a few seconds, although on the Roon interface they appeared to still be playing (silently, lol.) Starting the song again resulted in the same problem. Rebooting the core and remote apps did not help. A PM with my log file has been sent to Eric at Roon, as requested above…

1 Like

Just to say, I’ve been seeing the same issues - more apparent recently but that may because I’ve been using the feature more. Sometimes I get a momentary drop, other times I see the message and have to press play again. I’m running Roon v208, and the latest iOS version on my iPhone.

Hi @Karen_Hughes ---- Thank you for chiming in here and sharing your feedback with us. May I kindly ask you to please provide the following information:

  1. A brief but accurate description of your current setup as here.

  2. Please describe your network configuration/topology as well as providing insight into any networking hardware you may be implementing in your setup. I want to understand how your devices are communicating and what tools are being used to make those connections.

-Eric

Hi Eric,

Thanks very much for your response. I’m running:

Roon 1.3 (build 208) on a 2014 iMac Retina 5K - 4Ghz Core i7 with 32Gb of RAM running macOS 10.12.3. The music is stored locally on a RAID 0 drive.

I was queuing the music from Roon Remote on iOS 10.2.1 - the version was 1.3.2003. This is running on an iPhone 7 Plus.

I was playing it through a stereo connected to a Sonos Connect, which is hardwired via ethernet (though with a 100Mb connection). I have a Sonos Play 3 as well which has been flawless - but it is wirelessly connected.

The music was a mix of ripped CDs at 44.1kHz, Apple iTunes Store purchases and 88.2kHz tracks. It seemed that the switching between the 44.1kHz and 88.2kHz was particularly prone to issues, but I did get momentary skips with the 44.1kHz files. One thing I’ve still to try is forcing this onto wireless to see if it is any different.

The network is run through a Netgear R7000 - using 2.4Ghz and 5Ghz networks, but I’m not sure how the Sonos works with that.

Thanks

Hi Karen
Using your Roon Settings —> Audio tab, you should be able to see the IP address of one of your Sonos devices, it doesn’t really matter which one

Substitute that IP address in place of the xxx below…and then copy the entire line into the address line of a Browser on any PC and hit return

http://xxx.xxx.xxx.xxx:1400/support/review

It may take a minute…but you will see a group of text…click on the very last item called “Network Matrix”

Can you take a screenshot of the resulting box matrix and post it here??

Thanks

Hi Ronnie,

I see the following:

“Living Room” was the one having issues (the Connect). The Play 3 (“Karen’s Bedroom”) was working OK.

Thanks,
Karen

Hi Karen
Sounds like a weird suggestion for the moment…but could you disconnect the Ethernet cable from Living Room Connect

Then try playing a similar mixed playlist of tracks as you’ve outlined above [if possible by using the same queue??]…and see if you have the same problems

A little while after you start playing, could you take the same screenshot as above and post it here again…I’d like to see if there’s any major change in the mesh network connectivity as a result of removing the Ethernet cable from the living room Connect

Thanks

Sorry Ronnie - I found out that the Living Room device was actually running wirelessly - my mistake. However, I switched it to wired and tried again. It all played flawlessly. I’ve attached the revised matrix below.

Thanks again,

Karen

Hi Karen
That’s even better…i.e. that the Ethernet connection appears to solve the issue

Comparing the before and after from the cropped screen shots below, you can see how the Living Room in the 2nd picture below [after connecting ethernet cable] now has a “Green” connection to two other Sonos devices in the mesh network…meaning that data should flow much more freely to it than the yellow signal in the 1st diagram

Continue playing [if you can] for another while…and you might report back that the issues are now either gone or they’ve returned

Cheers

1 Like

Hi Ronnie,

Will do - and thanks very much for your help.

Karen

Hey folks – lots of Sonos improvements have gone out with the last two builds.

I’m going to close this thread, but if anyone is still having issues, please start a new thread with all the details of your setup, and @support will take a look.

Thanks!