Sonos playback errors - “Roon lost control control of the audio device”

I am starting a thread because the previous thread of the same title was closed.

I am having playback issues on Sonos similar to what was described in the previous thread. Songs will play for a few minutes, then suddenly stop. Pressing play on the Roon remote consistently resumes playback from the same point, but the same issue occurs again within a few minutes. This typically occurs in the middle of a song, and is unrelated to file type, bit rate, or sampling frequency. It occurs with AAC, 16/44.1 ALAC, and high-res ALAC and DSD that are being downsampled by Roon.

My Roon core is installed on an iMac, and my music library is on a RAID 1 array attached by USB. I have a Sonos Boost attached by ethernet to an AirPort Extreme Time Capsule, and A Sonos Connect:Amp that I am streaming to.

Playback using the Sonos app is flawless, both for AAC and lossless ALAC. I am also able to stream from Roon to an Apple TV, which is connected to the Connect:Amp’s line in, without any problems.

It does look like I have some interference on the Sonos Boost, so the first thing I intend to try is to get a 25-foot ethernet cable and move the Boost further from the router.

Any advice would be appreciated. I am specifically interested in Roon so that I can stream my high-res library to the Sonos, but at this point I consider it unusable.


I have the same issue as Brad_Hood. I have all of my music stored on a MacMini (2016, i5, 500GB), Roon is installed as the core, Tidal HiFi is fully integrated, and I’m going from the MacMini directly into a McIntosh C50. I have a blazing network and have no issue steaming the Tidal App, inside of Sonos, to the (5) Play 1’s in my home. So it’s not a network issue.

What I’m really hoping to accomplish is opening Roon, and using it as the sole UI for my entire home when I have the MacMini on, obviously.

Roon recognizes my (5) Play 1’s, and allows me to group them in a zone, but will only play a Tidal track for about 15 sec before saying: “Roon lost control of the audio device.”

Roon, please help me! I love what you have going on. All me to be your guinea pig!

Hi @Brad_Hood and @Josh_Martin_Family_M ----- Thank you both for the feedback and my apologies for the troubles here.

May I kindly ask you to please perform the procedure listed below and post screenshots of the results your response.

Using your Roon Settings —> Audio tab, you should be able to see the IP address of one of your Sonos devices, it doesn’t really matter which one

Substitute that IP address in place of the xxx below…and then copy the entire line into the address line of any web browser and hit return

It may take a minute…but you will see a group of text…click on the very last item called “Network Matrix”


Here’s what I get:

Yeah… that’s not good. You’re getting a lot of wireless interference.

Try getting your BOOST farther away from your router. That may help quite a bit. Another option is to go into settings in the Sonos app and change the wireless channel. IIRC it defaults to 6 which is what 80% of the other devices out there default to.

Thanks Andrew,

The BOOST does seem a bit happier on Channel 1. The OFDM ANI Level is down to 5.

Do you think that’s likely what’s causing Roon to pause? As I said before, I’m not having playback issues using the Sonos app.

I will try playing through Roon on the new Channel and see if the problem reoccurs.

I have a hunch (I haven’t researched enough to call it anything else) that Sonos tries to be intelligent when dealing with signal issues. Specifically I think it’s trying to downsample higher bitrate streams to something more manageable. Either that or it’s playing with buffers dynamically.

Roon is sending a full resolution 16/44.1 stream and based on the way that I think Sonos works the endpoints have no choice other than to play this stream as-is. When the stream is initiated by the Sonos device I get the impression that the system is trying to make some intelligent choices that favor stability over sound quality.

Part of my reasoning here is that in the past I had a hell of a time getting Sonos wireless zones to work reliably. Fast forward a few years and using the same hardware in the same configuration I had no issues. There’s also some assorted internet grumbling that Sonos is no longer bit perfect all the time.

Thanks again.

After moving the Boost, switching to Channel 1, and rebooting my router (so it hopefully selects a less crowded channel), I’m now getting this:

We will soon see if this solves the problem.

Hi @Brad_Hood ---- Thank you for the follow up and sharing your feedback from the requested procedure with us. Both are appreciated! I wanted to touch base and see how things have been holding up after your adjustments. Looking forward to your feedback!


Playback still stops when there is a lot of traffic on the network, but switching channels seems to help.