Sonos S1 no longer showing up in roon

I’ve been using my Sonos speakers for a few years, but last week they stopped working and now they don’t show up at all in the roon interface.

See those threads.
It’s a known issue for some since lstest release of 1.8

My devices are also affected.
Essentially the latest Roon can no longer maintain connection of non airplay enabled Sonos devices.
Restarting your core will bring them back. But they will disappear again at some random moment. And that random moment will be within hours.

I’ve tried everything I can think of including full hard reset of the Sonos system. Nothing helps Roon maintain connection. As you say, there was no problem until last week’s release. When the Sonos are missing in Roon they are still available in Sonos app and can be pinged on the home network.

This is a Roon issue, pure and simple. No excuses.
Sonos connected via ethernet or WiFi disappear from Roon.
Only airplay connected Sonos devices stay connected.

Tagging @support


Would it be a reasonable option to downgrade to the previous release? If so, does anyone know where I could find it?

Just testet my 3 S1 sones and they seems to play OK. 2x play1 and an old zp100.

New user here. My Sonos S1 is not recognized by Roon. My two older s5s work fine. Any progress on a fix?

Ok, I solved this. For some reason the S1 wasn’t enable in Roon Settings - audio. All good now.