Sonos stopped working with Roon

Roon Server Machine

PC (64 Bit, 64GB Ram, Ryzen 9 5900X 12 Core Processor 3.7Ghz, Windows 11 Pro.

Networking Gear & Setup Details

Using a BT router connected to a Google Mesh - via their Nest Wifi

Connected Audio Devices

Sonos Play 3, Play 5

Number of Tracks in Library

None - I almost exclusively stream from Qobuz

Description of Issue

Hi,

I used to be able to play the audio in the Roon PC app, through Sonos to my Sonos speakers. Now when I choose the Sonos speaker, select the music and press play, nothing happens. The equalizer starts on the track name, however the music does not play and the timer stays at 0:00. After a few seconds it says that Roon has lost control of the audio device.

My Sonos speakers are fully updated.

If anyone knows how to resolve this I would be most grateful.

Best wishes all.

2 Likes

P.S. I should add that when I use the Sonos App from the same PC it all streams to the same speakers on the same network perfectly. It is just when I stream through Roon that it is not working.

1 Like

A post was split to a new topic: Sonos Won’t Initiate Qobuz Playback via Roon

As a Sonos user and a Roon user I can give you some hints and tips.

I have swapped back over to my Google WiFi network (troubleshooting elsewhere). All my nodes (3 of for now) are all connected back to a switch for backhaul. My Roon server is connected to a secondary switch connected to my primary switch (not ideal, but needed due to layout).

Having your Google WiFi mesh nodes l, or any for what’ it’s worth connected via ethernet for backhaul may improve things greatly with Roon.

Another thing to try is to connect at least on Sonos speaker to your network with ethernet. This’ll then connect other devices, in range to Sonosnet (Sonos’s own network).

2 Likes

Hi @sicilian_kan,

Thank you for your post and for your patience.

Does this occur when you have the Sonos devices grouped together? If they are separate Zones, does it occur more frequently with one speaker than another? Mesh networks struggle to forward certain types of network traffic between nodes, so it will be helpful to know the location of each speaker relative to the networking topology.

We’ll need to know the exact network configuration of your Sonos Play 3 and Play 5. Are they both wired via ethernet, both connected via WiFi, or one of each?

Re-reading your post above, I get the impression they’re both on WiFi. Are you in a position to hardwire one to a router or mesh node? This will activate SonosNET, allowing the two speakers to form a dedicated subnetwork that might offer better performance. Hardwiring both would be even better, as you’d eliminate radio interference with the WiFi signal between the router or mesh node and the speaker.

Where is your PC wired in this configuration? Is it on the main BT router, or another node in the mesh network?

While frustrating, this is because Roon’s lossless protocols are often far more sensitive to any packet loss in the Wifi connection than Sonos’. This does help us eliminate broader underlying network problems that might be harder to diagnose and resolve. I’m curious if using Airplay to connect to the Sonos speakers is reliable, as well.

In your router web administration, I would additionally verify that UPnP is on in your router(s) web GUI. Try setting the UPnP timer to a different interval, if that option is available. I would also verify that RoonServer.exe, Roon.exe, and RoonAppliance.exe are all added as exceptions in your Windows firewall and any router firewalls.

2 Likes

With the Google WiFi devices, the Google Home app gives you access to the settings.

By default I think UPnP is on.

Found here



Also try enabling WPA3 security, found above the UPnP setting. This helped with a few devices having connectivity issues for me when I first set them up.

2 Likes

Thanks connor - much appreciated. When you mentioned the firewall, I thought of course that might be it, because the speakers were streaming directly through the Sonos App but could not do so through the Roon App. Not all the files you mentioned were added as exceptions. Switching this made it work. Many thanks!

2 Likes

P.S. Thanks Menzies for your help too and Robert, I hope the above helps you.

2 Likes

Glad it’s fixed for you :+1::grin:

Completely forgot to think about the Windows firewall exceptions. After a recent update (Windows or Roon) some had to re-allow these exceptions - RoonServer.exe, Roon.exe, and RoonAppliance.exe

Doh! :person_facepalming:

2 Likes

Yes, thank you to @AMT for the suggestions here - very helpful with Sonos as always.

@Robert_Comley, we’ll move your post into a dedicated thread to troubleshoot in case you’re still encountering issues. This thread will autoclose shortly.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.