Sonos -- why listed twice in System?

Core Machine (Operating system/System info/Roon build number)

Windows 10 laptop running roon, music is local

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Hi quality, 5ghz, dlink ncovr

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Brand new Sonos One

Description Of Issue

The Sonos works, but why is it listed TWICE in devices?

Once via airplay, once via sonos streaming?

And should I disable one? Which?

It’s listed twice as there are two routes to play to it and two routes to group devices together for multi room.
Normally best to use the Sonos streaming.


Hi @ra_ki,

It shows twice because you can stream to it using multiple methods. You could use AirPlay or Sonos streaming.

1 Like

@dylan : I’ve been wondering this as well, because I just set up my system again with a fresh instal, and when setting up you only get the Airplay option, but later when going into settings you can choose the Sonos Streaming option as well. If Sonos Streaming is the best option, why not add that to the setup procedure?

The solve is to simply go into Settings in Roon and disable the airplay option, and then it is listed once.

I consider this one (of many) small presentation flaws in the roon software. The roon stuff should do that automatically.

The new user experience is kludgy due to issues like this.

(When I installed roon on a 13" laptop, it complained that it couldn’t be used at all because my 3200x1800 display wasn’t big enough… not a great out of box experience!)

I would not disable anything. You might want to use one of the other options sometime for some unknown reason. Roon identifies each and every possible connection if finds. Just enable and use the ones you want.

That screen resolution might be too much for a small screen. Use a lower resolution. I’m using 3840 X 2160 (250 percent) on my Dell XPS 15.

I can always re enable… but I do not need two options for Kitchen speakers!

Screen res is fine. The screen res isn’t the problem. The problem is the roon app on fresh install saying “this display isn’t big enough to run roon” I mean, what kind of out of box experience is that?

It was great for me. Roon works with so many possible combinations of hardware, I guess some people might need to lift a finger to click on something, IDK.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.