Sorting by date added does not work

I am using the current version of Roon 1.8 on Nucleus +, up to date.

When I add tracks, I don’t find them at the top of tracks sorted by date added.

It seems Roon does not set the import date, based on the attached snapshots.

Import date used to work for me.

Thank you!

If you go to Settings>Library>Import settings you can adjust how Roon decides on a track’s import date. For instance, depending on how your tracks were added, they might have a pretty old file creation time because some ways of moving files preserve an original file creation date. My setting is “Roon import timestamp” to avoid messing up “date added” when I rearrange the files in my library.

Awesome - this did the trick - many thanks!