Sound cuts out after 28 seconds

Roon Core Machine

NUC Roon ROCK connected via Cat5e
Roon OS 1.0 (227), stable
Roon Server Software v1.8 (943), stable
Roon app on M1 iMac Device version 1.8 (880), stable
Roon app on iPhone Device version 1.8 (943), stable
iPhone 12 Pro, iOS 15.4.1

Networking Gear & Setup Details

Predominantly Unifi LAN

Connected Audio Devices

Several, including Sonos, Naim Uniti Star, KEF LSX, and M1 iMac

Number of Tracks in Library

Local library = 5,459 tracks, stored on a Synology NAS

Description of Issue

All has been fine for many months, but recently if I start any music via my M1 iMac to play on the KEF LSX the music stops after ~28 seconds. If I press Play again the same things happens after a further 28 seconds. If I use the Roon app on my iPhone to control the music it works fine.

The same happens whether I try to play music via Qobuz or a locally stored file.

Playback on the Naim Unity Star is fine.

Any ideas how to resolve this? Many thanks!

If after careful reading all the advice of the team and the community is followed, only improved program code will help. Roon is very demanding in terms of network solution and there are individual problems in the per mil range, which then can be solved only with protocol exchange to the team.

I think this is already done:

Disconnect all devices from the network and power. Waited a few minutes, slowly restarted everything from the router. IPv6 switched off, DNS adjusted, everything wired…

If the lsx are wireless they are very sensitive to drop outs seemingly, going by the number of posts here.

28 sec reproduction sounds odd. A license cut out maybe

Your iMac is not at current release state, maybe upgrade to see if that causes hiccups…


Many thanks, All.

I just logged out and logged back in to Roon on the iMac, and it tried to download an update … but never completed the task; after many minutes it said “There was an error checking for an update”.

The app remains on 1.8 (880) Stable.

I started to play a new track and after 29 seconds it stopped and showed the error “Roon lost control of the Audio Device”.

How might I “force” an update on the iMac?

FWIW, everything is connected via Cat5e - even the KEF LSX speakers - and I have a good internet feed (via Starlink).


Download it from and install.


It’s great to see you again @Julian_Berry!

Thank you for reaching out to us with your question. My apologies for the delayed response and for your wait. We’ve made some recent changes to the support team structure and some reports have experienced a longer response time than usual.

Since some time has passed I wanted to touch base to get your current status. If you’re still experiencing this problem on the newest Roon build (970) and need assistance please let us know. We’ll be watching for your reply and get back in touch as quickly as we can. Thanks! :+1:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.