Sound dropping out intermittently

Core Machine (Operating system/System info/Roon build number)

NAS Synology DS416 Play. Internet providers modem feeding via Ethernet a Netgear GS308E switch, then via Sonore optical converters

TEXT GOES HERETotaldac D1-7 device via USB

This has only been happening within the last week or so and does not happen each time, but there are occasional stoppages of music, sometimes for less than a second and the track then continues. Sometimes the drop out is longer and it then goes into pause mode, in the worst case it stops completely and restarts on the next track, skipping the remainder of the track that was playing. Is this likely to be a problem with the NAS or could it be Roon?

Description Of Issue


Hi @Derek_Suggate,

Does this only happen with the Totaldac or have you seen this with other devices as well? Can you share a screenshot of the Signal Path when playing to this device?

Hi, the TotalDac is the only device I use and it hasn’t ever been a problem before. I will try a screenshot and post that afterwards

How do you bring up the signal path?

By the way, if info is needed the Roon is 1.7 (build 511)

On the queue screen, click on the light.

Thanks, got that but can’t take a screenshot on iPad. Any idea how to do that?

Ok, got it. Does this help?

I have seen plenty of these dropouts, sometimes stopping music playback, sometimes skipping to the next track. Since the 1.7 upgrade, I hear it happen far less often than before. Your setup could not be much simpler and is similar to mine.

In the past, people here have mostly blamed network traffic or hardware, so I am curious to see if there are any new ideas…

deleted 10/char

Thanks for the screenshot, @Derek_Suggate!

As a test, it would be good to know if this same behavior occurs when playing to System Output of a remote device. Do the dropouts still occur?

Hi Dylan, just back from some time away. Problem remains the same, sometimes playing fine other times stopping several times on the same track!
What exactly do you mean by a remote device? IPad or suchlike? I don’t have any other things to try to playRoon through. Is it possible to go back to the earlier version of Roon? Didn’t have any problems then

1 Like

Your Core might just no longer be sufficient to run Roon besides all the other software usually running on such NAS devices.

Nothing has been added, but maybe the latest version of Roon is just asking too much? I don’t know how much more memory, speed etc is required for the 1.7 version compared to the 1.6. Anyone have any ideas?

Hi @Derek_Suggate,

Yes, whichever device you use as a remote — iOS, Android, Windows, or Mac — If you play to the speakers of that device does the same behavior occur?

Hi Dylan
I have now tried using Roon on my iPad and the same thing happens.

Any ideas how I can go forward from here ?

1 Like

Thanks for confirming, @Derek_Suggate.

There are a couple places this could be stemming from, but the thing that stands out to me the most is that the Core machine doesn’t quite meet our requirements. Since this is happening for all zones, it’s likely that the issue is stemming from the Core machine. I know this Core worked for you previously, but as your database grows, it definitely puts more strain on the underpowered Core.

I’d like to propose a test which should help determine if this is the case. Do you have another machine that does meet our requirements that you can use temporarily as the Core? Does the same behavior occur when using that Core machine?


I do have a PC that may be suitable (or not!). How would I go about installing Roon and the music library onto it to try? Before I do anything though is it not strange that this should only start to have happened after the update to Roon 1.7 though? Is this more build version more demanding of the NAS?

Hi @Derek_Suggate,

You can follow our migration instructions from our KB — That will walk through moving everything to the new Core.

I understand that this Core worked for you previously, but as your Roon database grows it will put more and more strain on the Core. The type of behavior you’re seeing typically stems from one of two places: the Core or the network.

The Core seems to be the obvious weak point currently, and understanding how Roon works on a Core that does meet our requirements will be a great data point for understanding where the behavior is stemming from.

It’s looking like it may well be a NAS problem. Do you know which of the Synology range is recommended as a machine that meets the Roon requirements?