Soundcards under wasapi cause jumping to next track without playing

Core Machine (Operating system/System info/Roon build number)
Windows 10 64bit pro - latest builds - 32GB DRAM - X99CPU - SSD 500G - Roon = 1.7 build 710

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
model? something pro metal case 16 ports. Roon works flawlessly on ASIO drivers - All on 1Gb ethernet and through GB switch Netgear I believe (it is way down under my desk so to lazy for now)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
USB 2.0 DAC - works fine, latest XMOS drivers installed 5.0

Description Of Issue
Roon works flawlessly with ASIO drivers - point is that I cannot go back to non exclusive sound card usage. Somehow this worked in the past I believe… otherwise I would have noticed the flaw I have now (see below)

Meaning if I have a Web Call or want to view a short video on my web browser - I have no sound.
I need to close Roon and than it works of course. But “booting” Roon back takes 1,5 minute (100k tracks 7800 albums) - it is just not convenient…

I can use my USB DAC also with WASAPI, but than it does not play the tracks - it just keep jumping to the next track

I also tried the Nvidea Quadro P400 sound output, but that is also WASAPI. Same issue with jumping

now the issue is, that if I select that Audio output (Bridge?) than when I play, Roon kind of starts with the track, and 1/10th of a second later jumps to the next track and so on without playing anything.

any ideas what to look at? I hope it is something known and simple to fix (I run out of ideas, hence my post for help)

Best Regards,

Is the Roon support team supposed to answer this? Does this have a ticket? It goes very quickly under in the long list…

Hi @Doede_Douma,

Thanks for reaching out! Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

OK, station one: all good. Private network, Raat and Roon are in the firewall exceptions…

next step?

ps: out of interest, what would make a difference in terms of firewall between ASIO and WASAPI drivers?
the first works, the latter not…

1 Like

Hi @Doede_Douma,

Thanks for checking the firewall! The next step here is to take a look at logs to see if we can gather some more clues.

Can I please ask that you reproduce the issue(s), note the exact local time + date + track they occur at and then use these instructions to send me a log set for review?

Any questions, just let me know, thanks!

Hi Noris,

January 18th 2021… 22:36:00 local time CET (germany)
playing all 100 tracks of Top 100 - favourite classical Melodies.

all 100 tracks got skipped. I will zip the log files and get you a dropbox link

here is the link Noris:

let me know when you have it, so I can remove the content from my dropbox

1 Like

Hi @Doede_Douma,

Thanks for sending those logs over, I believe I see the issue here.

According to your logs, the WaveIO only supports the following formats:


When the issues were occurring, it appears you were trying to play 44/16 content, which your DAC does not support.

I suggest that you enable Roon’s DSP Engine to convert the source to one of these formats:

You can also click where it says “Max PCM Rate” and specify “Custom” and re-sample tracks to one of the above sample rates.

Let me know if this helps!

Hoi Noris,

Strange log To be honest, as the WaveIO works perfectly Fine under 44.1 16 Bit. I tried That with Windows direct and also Foobar with direct sound driver of windows So non-issue with the Hardware.

Then I tried WASAPI in foobar…
First I got a detailed error message in Foobar with WASAPI and why it was not working at first try and that lead me to experiment with windows settings and I also rolled back the drivers for the WaveIO and when I set windows to allow exclusive control, I could use the WaveIO under wasabi.

Funny thing is, that now it works with Roon and I can also uncheck the box for the exclusive mode in Roon. If I start a video in my browser I (as I wanted) can hear both Roon and the video sound. I need this to quickly switch around with video chats…

Not sure on all this interaction of settings and drivers, but now WASAPI works the way I wanted

May be this is good feedback for you guys as well. Why was Roon not just telling me what the problem was with the windows settings in stead of just skipping the tracks. Old junk like Foobar actually helped me into the right direction.

Thanks for your help anyway, without the 44.1 thing I’d I probably would not have started to play around with Foobar

1 Like

Hi @Doede_Douma,

Thanks for letting us know that you’ve been able to resolve the issue with the driver change!
If you have any further difficulties, please just let us know.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.