Specific files playing back incorrectly

I’m having an issue where an album I just purchased from Bandcamp (https://tettixashellinthepit.bandcamp.com/album/rogue-legacy-reborn) isn’t playing back properly. What I’m hearing is that it will sometimes have a few pops per second, sometimes a few gaps per second in the playback, or sometimes play random noise instead of the audio. Once in a while, Roon will drop the zone and say that there aren’t any configured before finding it again. This is the FLAC version they have, specifically.

I’m running build 274 on Linux for my Roon server, and also build 274 on my Mac for the client (a 15-inch, late 2013 Macbook Pro). Audio is being played back through CoreAudio to the built-in speakers without exclusive mode, any max sample rate or max bits per sample, and downmixing as needed, with 0s resync delay and 0ms sync adjustment. Clock master priority is default. I’ve been using auto volume leveling, but turning that off makes no difference. VLC plays back these files just fine, so if they’re corrupt, they’re at least not totally corrupt.

This sounds a lot like Issues with files appearing to be corrupt, hearing pops except Roon isn’t mentioning corrupt files in the log for me.

Is there anything you need from me in order to look into this?


Hi Chris,

Did you select System Output or Built-In for the MacBook? Others have had this issue and it’s usually because they select System Output, which doesn’t allow you Exclusive Mode. Using Built-In Audio with Exclusive Mode selected usually fixes this issue.

Maybe post a screenshot of your Signal Path.

Cheers, Greg

1 Like

It was set to built-in, though I had exclusive mode turned off. Turning exclusive mode on does indeed fix the issue, though I haven’t had this problem with any other album I’ve tried to play. However, what I’m finding strange here is that turning exclusive mode back off doesn’t result in the issues I was having before. I wasn’t having them with anything else I was trying to play, either. I’d even tried rebooting my laptop before posting, and that didn’t help, so I’m really perplexed about what was going on.

It seems to be fine now, but . . . this is odd.

I’m fine now, I think, but in case anybody else runs into whatever this was, here’s my signal path.

Hi Chris,

Unless you need to hear other sounds from your computer while listening to music, Exclusive Mode will give you the best sound results.

Here’s more info about Exclusive Mode.

Also, check out OS Mixer info in the Signal Path.

Cheers, Greg

1 Like

This topic was automatically closed after 44 hours. New replies are no longer allowed.