Specific iPad cannot make remote connection to core [Resolved]

Basic issue: I have a iPad Air 2 (128GB, 2014 model) that will not connect to the Roon core. It used to connect, but overt the last 4 days it will not. My iPad Pro (9.7", 256BG) and iPhone 6S connect fine.

System setup:

Roon 1.3, build 242, 64 bit
Operating system: OSX 10.12.5
Device: Mac Mini 4 core I7 @ 2.4 GHz, 16GB ram
Firewall off
Music stored: Drobo 5n

tracks: about 38,000 tracks

Network: cat6 cable, switch at core and NAS endpoints
Router: AT&T UVERSE Model 5268AC Firmware updated within the last 6 mos.
All endpoints wired except BlueSound Pulse Mini in 1 bedroom

Things I have tried to fix the iPad connection issue:

Checked general and network setting to make sure set the same as other IOS devices that connect
Entered Roon core ip address
Entered Roon core name
Rebooted IOS
Reset network communications
Deleted and re-downloaded Roon remote app
Plenty of storage space left on the iPad Air 2

Nothing that I can point a finger to happened to the iPad to change its connection abilities. Any ideas would be helpful at this point.

Have you checked ipad IP address is same subnet as the Core?
Have you tried using a simple app utility (like fing) to see if you can see the Core, and also ping it, from the ipad?

Yes, it is on the same subnet.
Fing shows the Roon Core device. However, when I ping it there is 100% packet loss.
Doing the same from the 2 other iOS devices shows the core and can ping as well.

That’s a weird one. I can’t think other than it being something wrong in the network settings on the iPad.

Can you ping the core from the working iPad? (just to rule out ping being disabled)

Only thing I can think is to screenshot both iPads network settings just incase there’s something you can’t see.

Ping works from the other iPad

Ok, I have a 3rd iPad. It is a iPad 4th Gen, earlier then the iPad Air that I reported first. It appears to have the same problems. Like the iPad Air, it connects to all other wireless network apps, sees the Roon Core, but cannot ping it. Based on these 4 IPS devices, I wonder whether the last Roon Remote update did something that affects the communication with Roon on older iPads, iPad Air 2 and before?

But you should be able to ping regardless - Roon has no control over that. Can you definitely ping from the iPad that works?

Yes, I can ping to the Roon Core from both the iPad Pro and the iPhone 6S, but not from either the iPad Air 2 and the iPad 4th Gen

Ok hopefully someone cleverer than me will step in. Can’t think of anything else in that scenario that would cause it - if all devices are on the same wifi and correctly addressed you should be good. Sorry. Will give you a @support bump.

I am not cleverer than anybody, but have you tried assigning the same IP address that works on the one iPad to the one that doesn’t? (Turn off the working one first, I guess …)

1 Like

Not clear I have control of the iPad’s IP address. The one that works in turned off, but it still claims the previous ip address on the network table.

Set them to manual (rather than dhcp) but put all the same details in.

Yup. My logic was that something in your router (firewall??) is not treating all ip addresses the same, so by selecting one which definitely works . . .

Ok, perhaps I will turn all the devices off, reboot the router, and see who gets assigned which ip addresses. Then I might try a manual ip set up

Problem solved. Turning all devices completely off, rebooting the router, and then powering everything allowed the offending IOS devices to find the Roon Core again. Note, the DNS table remained exactly the same. Thanks for the troubleshooting suggestions! Remember, when in doubt, reboot (everything!).