Spinning endlessly

(Marcelo Bulgueroni) #1

Hello!

After a long time using other apps, I started testing Roon on a Macbook - my plans are to transfer the library to a mac mini in the next month if the tests go okay. The quality of the software is beyond impressive, both on visual appearance as well as sound quality! Congratulations!

Currently I am running Roon on the following Setup:

  • MacBook Pro (Retina, 13-inch, Early 2015) - 2,7 GHz Intel Core i5 - 8gb RAM with SSD 256GB - have been using this with Roon both wired through ethernet and through wi-fi N
  • Mac OS X Mojave 10.14.3 (18D109)
  • Roon Version 1.6 (build 390) stable (64bit)
  • Music Files are stored on a NAS Synology DS416j connected through gigabit ethernet
  • Collection Size of about 39407 tracks (using local songs and Tidal integration on roon).

The problem is that after initial setup all files were added (with exception of some 300 which were included in exceptions due to fragmentation / corruption etc) and the spinner showing the library updating stopped.

However, after a reboot two days ago the spinner will never cease to spin, and the screens show that supposedly all tasks were over as per the screenshots below.

I saw in the forum that it can be originated by different issues. Tried the basics I saw around here (rebooting Roon Core, rebooting the Mac, cleaning the library) however the behaviour did not change. Can you help me with this, please?

@support

(Mr Fix It ) #2

Is your library still being audio analyzed? This can take many hours to several days or more depending on your hardware and library size.

https://kb.roonlabs.com/Audio_Analysis

(Marcelo Bulgueroni) #3

Thanks @wizardofoz - I forgot to mention that. From what I can gather it is finished (let it run with 4 cores the whole weekend for that). Not showing any song being scanned for audio levels now:

(Noris) #4

Hello @Marcelo_Bulgueroni,

Thanks for contacting us regarding this issue and for the kind words about Roon!
Let’s take a look at this issue a bit closer:

  • Does anything show up under “Skipped Files”? I wonder if Roon might be hanging on a track with special characters, special characters that can cause this are listed at the end of our Skipped Files Guide
  • You mentioned that you have two Macs here, does this same spinner appear on both of them or just one and not the other?

Please let me know this information when possible.

Thanks,
Noris

(Marcelo Bulgueroni) #6

Thanks @noris for your reply!

Concerning your questions:

Yes, there are some skipped files, but reason given is “audio stream format not supported” or “file corrupt”

Here is a link to the exported xls:

I have two Macs, but only the Macbook Pro with Roon Core installed. In the near future I will switch one for another, the Mac Mini is at my business office now and not part of the same network, so I am afraid we will not be able to consider it for troubleshooting :neutral_face:

Let me know what additional information I can provide.

Best,

Marcelo

(Noris) #7

Hi @Marcelo_Bulgueroni,

Thanks for providing that information, I have gone ahead and activated diagnostics mode for your account and what this action does is automatically upload a set of logs to our servers for analysis and I see that the diagnostics report has just arrived.

It appears that Roon might be stuck on a track from your library, I am seeing a few tracks from this folder that might be causing issues:

/Users/mbulgueroni/Library/RoonMounts/RoonStorage_c75c09c0385b11bee90d66bb2542dba80cddfa0b/Music/Metric/Pagans In Vegas/

Can you please try to move (but do not delete) this folder out of your storage location, reboot the Core and let me know if that helps? If we narrow down this issue to a specific file I would like to get the file over to QA to take a look, so please do not delete any files just yet, simply move them for now.

Thanks,
Noris

1 Like
(Marcelo Bulgueroni) #8

Thanks @noris ! Did that before leaving my home. It will be a while today but as soon as I am back home I will report back!

1 Like
(Marcelo Bulgueroni) #9

Reporting back from home, @noris : problem persists :smirk:
Something different I noticed: some skipped songs now present an I/O error.

(Noris) #10

Hi @Marcelo_Bulgueroni,

Thanks for letting me know, it appears that the search continues :male_detective:

I have identified a few other folder/files which may be causing issues here:

Music/South/From Here On In/
Music/Gin Blossoms/Outside Looking in_ the Best of the Gin Blossoms
Music/Céu
Music/David Bowie/Christiane F._ Wir Kinder vom Bahnhof Zoo
Music/Dead Can Dance/1981-1998 (disc 1)
Music/Hole/Ask for It
Music/Pink Floyd/Dark Side of the Moon
Music/The Guess Who/Share the Land
Music/Various Artists/The X-Files_ the Album

Please try rebooting after moving them out and let me know if that helps.

Thanks,
Noris

1 Like
(Marcelo Bulgueroni) #11

Hello again @noris !

Done that and will report after the initial scan.

Meanwhile, I found an interesting pattern in almost all folders in your last post. Except for the South album all others were in duplicated folders where some files of the album (say songs 1-8) where on one folder and the other files (songs 9-12) where on the other folder. The names are the same, with only case letters differentiating them. Probably due to the terrible iTunes naming and “organizing” structure which I use in the folder in order to keep my content synced to the cloud. See here how the folders are presented:

(Marcelo Bulgueroni) #12

Well, it seems we still have work to do. It started different after moving those folders, almost re-processing the whole library, but now it seems to be stuck spinning again…

(Noris) #13

Hi @Marcelo_Bulgueroni,

Sorry to hear that the spinning is still occurring after moving those files. Is the state of spinning still the same as before (Adding Music To Library: Complete) or has that message changed to something else? I have not seen a new diagnostics package arrive to our servers, is the Core still online and connected to the network?

Thanks,
Noris

(Marcelo Bulgueroni) #14

Hello @noris ! I started investigating my Music folder and found a lot of duplicate folders with the same “case” problem, as well as many apple music files (.m4p) which should not be there.

In order to clean up a little I took Roon core offline and am trying to correct all these inconsistencies before running it again. Do you think it will be better to rebuild the whole database after that, starting as new?

Thanks!

(Daniel Beyer) #15

If you have not made many edits, than I would suggest just starting with a new database to be sure there is no leftover issues. As always, imho.

1 Like
(Noris) #16

Hi @Marcelo_Bulgueroni,

It might be better to start with a fresh database if you have not made many edits as Rugby mentioned. To set your current database aside you can use the following instructions:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location: https://kb.roonlabs.com/Database_Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart the Roon App to generate a new Roon folder

Please let me know how it goes.

Thanks,
Noris

1 Like
(Marcelo Bulgueroni) #17

Hello!

After carefully removing all duplicated files and folders due to case difference, removing all apple protected files and starting a new database from scratch the spinner seems to be gone for good! :smiley:

I even re-added the removed albums, one by one, and it seems they presented no problems.

Thank you so much for your kind support through this process. I believe I can now focus on enjoying the music and tinkering with my setup only :wink:

Best,

Marcelo

1 Like
(Noris) #18

Hello @Marcelo_Bulgeroni,

Glad to hear that the issue is fixed!
Thanks again for contacting support, I wish you a pleasant day and an enjoyable Roon experience :headphones:!

– Noris

1 Like
(system) closed #19

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.