Spinning icon in top right corner - "Metadata Improver - paused"

I have the same ‘phenomenon’…

No changes to settings other than switching the 4 hour reindex interval to ‘Only at Startup’ this morning. Core reboot did not help.



The Roon @support team prefer one topic per customer’s issue… so they are able to track it and focus on each individual problem. hence I split out your topic.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup and the nature of the issue using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

As a fellow user, I would recommend the following troubleshooting steps …

Try rebooting the machine that the Roon Core is running on, that can often help.

Metadata improver: paused

Suggests that a Roon is unable to connect Roon cloud services, so this might also be related to a firewall or networking issue.

So again it’s worth rebooting any network equipment, and also try temporarily switching of any firewalls.

Thanks Carl, I was merely interested in following the topic, not (yet) reporting my own problem. But I understand and appreciate the reason for splitting the topic.

Like I said, the only thing I changed was the automatic rescan interval (from ‘4 hours’ to to ‘Only on startup’). No network changes, no firewall changes, no new hardware of software.

I performed another restart of my Roon Core machine and I also restarted my NAS, and that appears to have fixed the problem.

1 Like

Thanks for update @Max_Delissen,
I’ll mark this one as solved, but should it come back after the topic auto-closes in a couple days … message me and I’ll reopen the topic for you.

1 Like

Will do, thanks!

1 Like


Unfortunately, this phenomenon has reappeared.

I upgraded to Roon 1.8 (build 790) this morning, added an album, hit ‘Force Rescan’ and there it was again.

I have never had that problem before, could it have something to do with the fact that I recently installed the full version of Roon on the Mac mini in my home office, because I thought it would be nice to have it as a ‘remote’ instead of my phone?

Roon Core is still running on my other Mac mini that is set up in the fuse box closet, as a dedicated Roon Core machine (only running Docker in the background for my Squeezebox Radio that I use as an alarm clock - the LMS software is much easier to set different alarms than via Roon Plugin, sorry :wink: )

These are the only things that I have changed recently.

I am performing a core machine restart right now and see if that solves the problem (like it did yesterday), but it is obvious that this is not a comfortable way to add music to my library :wink:

Hardware Setup:

Core Machine (Operating system/System info/Roon build number)

Mac mini (Late 2012) with 2.5MHz i5 processor, 500GB Apple HD and 16GB ram, dedicated for Roon core (no other apps running, non-necessary functions like IR and Bluetooth shut off) with MacOS Catalina 10.15.7 and Roon 1.8 (build 790).

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Synology DS412+ NAS, AudioQuest Forest, Carbon and Vodka wired ethernet, with AVM/FRITZ!Box 7490 router and Netgear GC510PP and English Electric 8SWITCH switch.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

AURALiC Altair G1 via network as Roon endpoint, Mac mini (as Core machine but with 250GB Samsung 860 EVO SSD and 10GB RAM).

Hey @Max_Delissen,

Thanks so much for the very detailed account of the issue you’ve ran into. I am sorry about the trouble… :slightly_frowning_face:

So our technical team can help, I’ve moved this thread into their queue. You should hear back from one of them here.

Thanks in advance for your patience :pray:

Hey Rebeka,

Thanks for the help, and you will find that I am quite patient :wink:

For now, the problem has not occurred again after a full front-end restart, but it may take some days of unencumbered use to be sure that it was - like Carl told me in a private message - a local network issue.

These things happen, and they are always unexpected and unwelcome, but they always get solved sooner or later. This time it may be ‘sooner’, which is nice :wink:

This afternoon, after resetting my Roon Core Mac mini, my Netgear GC510PP switch and my FRITZ!Box router, I uploaded 4 albums, did a Forced Rescan after each upload, and failed ro reproduce the Metadata Improver warning. Yay!

I suggest we monitor things for a day or two, and if the Tech Team wants to look at my log files to find out what actually happened they are welcome to them. If a simple reset was all it took this time, we will at least have learned that some problems are easy to solve and not worth foaming at the mouth for :stuck_out_tongue_winking_eye:

Hey @Max_Delissen,

If I appreciate something (other than your efforts to get to a resolution) is your very kind attitude - thank you! We’re happy with the collaboration.

Sounds like a great plan. We’ll stay connected :slight_smile:

I run into this issue regularly, and for me the reason is that changes to the library happens to an unlicensed server.

And how does a server loose it’s license then? Well, for me the reason is mostly that i have activated another of my Roon Cores, and hence “given” my one and only authorization to that Core at a given time.
Sooner or later, the first Core will contact/be contacted by the Roon authorization function and dicover that it’s license lease has expired and cannot be renewed (as there are no available authorizations to distribute).

If i, at this time, sync my library on these two cores, thus add content. this first Core will develop this Metadata Improver error. The second Core, which holds my one authorization, will not experience any issues.

Hope this makes sense?

This happens often, you see support threads quite commonly. A full network restart and / or core restart is a fix .

Not sure if there is a more fundamental reason lurking , but this is a quick fix, I restart my whole system in the summer due to thunderstorm potential, so it’s a winter problem I VERY occasionally see

Hi @Max_Delissen

Thanks for following up, and sorry to hear that you’re running into this issue again.

Typically this error occurs when there are networking issues preventing the Core from connecting to our servers. A lot of times a reboot will help to get the device in a better state so that the connection can be made properly.

Just to confirm — Was the docker running LMS a recent change? Did this start happening around the time that this was set up?

Yes, Docker running LMS, because the latest update from Disk Station Manager killed the ‘official’ LMS package after Logitech stopped making updates, and my Squeezebox Radio (that I use as an easy to set up and flexible ‘multi-alarm’ clock) lost contact with LMS. The best workaround was Docker, because I didn’t want to revert to earlier DSM/Perl/LMS versions for safety reasons.

And Yes (2.0) that is when the Matadata Improver message appeared for the first time.

However, I also installed Roon on the Mac mini in my office only last week, could that have something to do with it as well, like Mikael_Ollars suggests? It was supposed to work only as a very luxurious remote, but it did insist on a full library index.


Well @dylan, the warning has returned, but this time it’s completely out of the blue. I have not added music to my library or performed a Forced Rescan. It just appeared. But with a red warning icon in the top right corner, instead of a spinning blue wheel.

I strongly suspect that the cause is an authorisation conflict that occurs irregularly after I setup the full Roon on my office Mac mini, like @Mikael_Ollars suggested. I think somehow it didn’t install like a remote as I intended, because it performed a full library index.

My gut feeling tells me it has nothing to do with installing Docker and the new community version of LMS on my NAS.

So I will uninstall Roon from my office Mac mini, restart my Roon Core machine and see what happens after that. I hope my ‘gut’ is right, because I can do without the extra full Roon install, as log as it gets rid of these warnings :wink:


Uninstalled the Roon app, and deleted Roon and RoonServer folders from my library. RoonBridge is still on my office Mac mini, didn’t change anything there. Core machine restart now, see what happens…

There is no problem running a “full Roon” as a control only. These things only happen when you have clicked “I want to use this computer as a Core” and then authorized it with your license.

Nevertheless, hope uninstalling solve your issue. But i would like to recommend you to perform the “Log out” manouvre on your main Core afterwards, and then log in again to make sure you authorize the correct core.

1 Like

thx Mikael, I did not authorise a new core, so that should be okay.

Hope it doesn’t turn out to be Docker/LMS after all, because that would mean saying goodbye to my trusted old Squeezebox Radio alarm clock. after all, Roon is way more important😜

1 Like

As per a friend’s advice, I have now reset the DNS Server of my Roon Core Mac mini to Cloudflare’s server address (with as the backup server). My Mac mini was using the standaard OpenDNS Home servers.

Apparently, this solution was suggested elsewhere on this form, so let’s wait and see what happens. So far so good…

Setting the DNS address to on both my ‘Roon core’ Mac mini and my FRITZ!Box router seems to have done the trick. The spinning blue wheel indicating the Metadata Optimizer shutdown has not reappeared, so I feel safe to call this issue SOLVED.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.