Spinning icon in top right corner - says "Metadata Improver - paused"

Core Machine (Operating system/System info/Roon build number)

Roon 1.8 (783) on QNAP TVS-871 with 16GB and i3 CPU.

Network Devices

All networked in over cable to my Draytek router.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Roon bridge on DietPi with USD NAD DAC attached into a Meridian pre-pro. 1.7 build (571).

Description Of Issue

In my GUI for Roon, I see a spinning circle icon in the top right hand corner, next to the bookmark icon. If I click it, it says “Metadata Improver: Paused”. Also, says “Roon is having trouble verifying your connection with our servers, so metadata improvement has been paused. Check your internet connection and make sure that you’re running the latest version of Roon.”

Internet radio works fine and I can also play music from Qobuz through Roon, so this would suggest internet access from my Core is ok?

Thanks

A post was split to a new topic: Spinning icon in top right corner - “Metadata Improver - paused”

Hi,

First thing to try is rebooting the machine that the Roon Core is running on, that can often help.

Metadata improver halted

Suggests that a Roon is unable to connect Roon cloud services, so this might also be related to a firewall or networking issue.

So again it’s worth rebooting any network equipment, and also try temporarily switching off any firewalls.

If that does not help then I’ll hand over to Roon’s @support team.

Hi Carl - I’ve restarted my NAS and router but still no luck.

However, the icon has been reporting the following for a couple of hours:

1 Like

The Storage section under Settings thinks its all scanned and watching for new music.

Hey @Dan_Mason,

Sorry to hear about the trouble and thanks for reaching out about it. Not only that, but for also restarting your Core and router.

I was wondering if you could change the default DNS servers to Cloudflare DNS, Quad9 or Google DNS.

Thanks in advance :pray:

set dns to 1.1.1.1, seems to do the trick
thanks

1 Like

I’ve made some progress, but not by changing my DNS.

I have a VPN client configured on my NAS which connects out to NordVPN. This means my NAS was a public IP in a different country to where I live.

If I disconnect the VPN and therefore the NAS was my home’s public IP, the issue goes away.

Once I re-connect the VPN, after a day or so, the icon and error comes back?

Thanks
Dan

A post was split to a new topic: Metadata Improver Paused

Hi Rebeka / Support, any update on this issue?

Thanks

Hi @Dan_Mason

This error typically means that your Core is having trouble connecting to our servers, so it sounds like something about the VPN you’re using is causing an issue here. I’d look into what options are available with this VPN and maybe set exceptions to allow traffic from Roon to not be blocked or altered in any way.

Thanks. Can you help me trouble shoot further? Maybe see if it’s a DNS issue or a blocked port?

My VPN just routes 100% of all traffic, no firewall so nothing should be being blocked.

Are there logs we can look in to get more information?

Thanks

Is there any way to bind Roon to a particular interface maybe?

My QNAP has 2 default gateways, the first with metric 80 is the VPN and the second is my home Draytek with metric 100.

What hostname or IP is my room core trying to connect too?

I could just add a static route from the room ‘cloud’ servers over my Draytek.

Thanks

Hi Carl - Can I get an update from support on this issue, everyone seems to have stopped responding.

Thanks

Hi @Dan_Mason,
I know Roon’s support backlog is high but it does look like this has been missed.
Let me tag @dylan and @rebeka for you.

1 Like

I’m still waiting on support for this issue.

I had a direct message from @dylan 7 days ago asking if it’s still a problem, I said yes and still nothing?

A post was split to a new topic: Roon 1.8 says “Metadata Improver - paused”