Sporadic crashes, cannot display some albums, and problems adding new albums

Core Machine (Operating system/System info/Roon build number)

Mac mini (Late 2012) on macOS 10.15.6, 2,5 GHz, 8 GB, Roon Core 1.7 build 610
Music is stored on internal SSD

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

FirtzBox 6490 Cable, Zyxel GS2210-8, AirPort Time Capsule 6G

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Devialet Expert 800 over Devialet Air (via Ethernet on Zyxel GS2210-8)

Description Of Issue

Since roon 1.7 (not only the latest build 610) discover sporadic crashes of the core, restart of the core sometimes fails and I need to restart the Mac mini. Moreover, I have problems adding new albums to the database, which are mostly not automatically added, even after forced rescan of the directories.
In addition about every fifth to tenth of my albums cannot be displayed, i.e. cannot be loaded despite it is in the database and shown as a search result. Roon only shows “Loading album” and nothing happens. This concerns not only albums recently added, but also albums, which are in the database for some time.

Hi @Christian_Tegeler,

Thanks for reaching out! Can you please use these instructions to send me a set of your Roon logs? If you have any issues accessing or don’t have a file transfer service, just let me know.

Hi @noris,
thank you for your quick response.
Please find the logs here:

Best regards

1 Like

Hi @Christian_Tegeler,

According to the log, there is no more free space on the drive, which is why these issues are occurring:

IO error: /Users/christiantegeler/Library/Roon/Database/Core/a9b7ef96ca174c5881504e67de316ad3/broker_2.db/002878.ldb: No space left on device

I suggest freeing up some space and see if that helps.

I also don’t know how stable the current database is because if Roon was trying to write files to the drive and didn’t have the space, there could be database write errors.

Do you have any backups of your database before the space issue started? To be safe, I would restore the database from a backup at least a week before you started running into these issues.

Hi @noris,
there is more than 300 GB free on the local drive, on which the Roon database is stored.
Please see the enclosed screenshot.

Hi @noris,
I copied a few Gigabyte of data in the Roon database folder and it worked.
So disk space cannot be the problem here and there is no quota on the library folder.
What else can cause the problems?
Best regards

Hi @noris,
since the problem persists and disk space is definitely NOT the problem (see above):
What ist the next step?
Do I need to open a new case to get a response?

Hi @Christian_Tegeler,

Apologies for the delay here, I wanted to check with our QA team to confirm my findings.

They agree that according to the log traces it looks like the Roon database location is running out of space.

I know you sent the screenshot above that shows the free space, but there are a few considerations to keep in mind, please see below:

  1. Are there any partitions set up for the location of Roon? While it is possible the physical drive has the free space, if you have set up logical partitions and just that partition is running out of space, it could explain the discrepency.

  2. When the app is in the unstable state and crashing, how much free space is left on the drive? I would check near the crash time, as it is possible that the space is being used as cache space (an application creates a temporary file).

  3. Can you please perform a search using Spotlight for “Terminal” and enter this command in terminal and paste the output here?
    df -h

This command shows the disk info and partitions set up.

Hi @noris,
there were no limitations due to other partitions on the physical drive and more than 300 GB free space.
I used the MacOS Disk Utility several times to check, if the drive is okay, and there were no errors. All the Time Machine Backups were fine, too.
Before I received your reply, I tried to make a manual backup of the drive, on which roon and the whole music library were located, by copying the files to an external HD. Suddenly read errors occurred on random files (“IO error -36”). When copying these files individually, there was no problem, but then the IO error -36 occurred on other files. So I suspected, that there was something wrong with the drive (a fusion drive btw.).
I decided to replace the drive by a new SSD, reinstalled MacOS and roon, set up a new roon database, and copied my music from my backups.
Since then everything works flawlessly, so I guess, there was some kind of not very obvious problem with my drive.
Thank you for your assistance!

1 Like

Hi @Christian_Tegeler,

That’s fantastic news, happy to hear you tracked down the cause of the issue to the faulty drive and that the replacement is working out nicely!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.