Spotify Connect issue with RoPieeeXL


I’ve been taking a look at RoPieee over the last couple of days and have it running on a RPi 4b. I’ve upgraded to the XL version to try out the Spotify Connect feature, but I’m not having much luck. I’ve looked through the topics here and see a few people have had issues with playback but my particular problem doesn’t seem to feature.

What’s happening is that I see the RPi listed in the device list in Spotify, but if I try to connect to it, it either thinks for a while and bombs out, or it shows as connected, but bombs out as soon as I try to play anything. I don’t see any errors within Spotify. I’ve tried this on two devices, a Pixel 3 and an old samsung tablet, both cases with identical results.

I read on here about roon locking the audio, so I’ve powered down my roon core, and rebooted the RPi, but this hasn’t changed anything.

I’m using a usb Dac with the Pi, a Muse Mini Usb Dac, which is working perfectly with roon.

Has anyone else experienced this?


Open the RoipeeeXL interface and on the RoipeeeXL tab try setting the Spotify Connect Audio Output drop down to USB and not Auto.

I found this worked for me.

1 Like

Hi Wayne and thanks for the response. I changed both of those settings to USB during initial configuration. I guess I could try the opposite and change them to Auto…

1 Like

if you have a USB DAC then setting this to ‘auto’ doesn’t bring anything.

Can you send me feedback? After you tried to play something with Spotify?



How do I send this feedback. Logs presumably. Where to I find them?


It’s in the advanced tab.

But have you upgraded? I released a patch yesterday that fixes your issue.

Just upgraded thanks, and it’s working great now. Thanks for the help.

HI there, I am running the same software, but having the same problem. Roon is working through USB on a rpi3b. Spotify connect sees the rpi3b but no would output (yes I am on usb output).

When I performed the install it did throw an error. But roon worked so - i forgot about it.

Any suggestions?



That’s not a very detailed report :wink:

If there was an error I would suggest you start with a reflash.

done a re-flash already. and created feedack. running the raspberrypi3 with usb output at this stage, not hat. Roon has been running stable on a lan.

When Spotify is activated the raspberrypi shows up as a device that can be played too. when selected Spotify appears to play to the raspberrypi but there is no audio coming out of the stereo. There is no crashing or unusual issues. just no sound. connections work on roon.



Can you try the beta channel?

ok… on the beta channel…

there was a green download pop up. but the problem still exists. Not sure if that was supposed to fix it or whether it was part of changing to the beta channel?

Did you follow the instructions? As in: saved the change, rebooted etc.
After the reboot you should have a message saying that an update is available.

I believe I did (green colour?). But nothing changed, so I have now tried a new image. No luck! never mind. Thanks your your help. Great service you are providing, don’t stress about it.

Ok. If you have it reflashed… can you send me feedback?
You can find it on the ‘advanced’ tab of the webpage.

I’ve been listening to Spotify all weekend, so it should work :wink:


I did just send a feedback. thanks

What’s the ID?

do you mean the board serial ID? 00000000c54fe6b6

No, the udid which is shown when you send the feedback.