Squeezebox Classic (SB3) unable to connect to Roon server [Resolved]

Motherboard: Intel Corporation - D2700MUD
CPU: Intel® Atom™ CPU D2700 @ 2.13GHz
Cache: 512 kB
Memory: 4 GB (max. installable capacity 4 GB)

Roon 1.3 Build 218 stable 64bit
Running as a Docker application on an unRAID server (version 6.3.2).

I have a Squeezebox Classic 3 which has been used for a number of years connected to LMS via ethernet – WIFI is NOT an option with the SqueezeBox.

I have enabled Squeezebox Support from within the settings of the Roon application.

All instances of LMS are disabled/turned off within my network so there should be no interference with LMS in the environment.

A factory reset has been done on the Squeezebox Classic which has been configured with a static IP address.

The Squeezebox is unable to connect to a server within the environment and the Settings/Audio page of the Roon application shows no entry for the Squeezebox – no networked devices are shown at all.

Looking through the RoonServer_logxx.txt files there are numerous entries as follows:

04/20 12:24:46 Trace: [squeezebox/discovery] GOT from device_id=4 firmware_rev=137 mac_addr=00:04:20:12:93:92 RESPONDING hostname=Roon
04/20 12:24:47 Trace: [squeezebox/discovery] GOT from device_id=4 firmware_rev=137 mac_addr=00:04:20:12:93:92 RESPONDING hostname=Roon
04/20 12:24:50 Trace: [squeezebox/discovery] GOT from device_id=4 firmware_rev=137 mac_addr=00:04:20:12:93:92 RESPONDING hostname=Roon

The above entries seem to suggest that the Roon Core server can see the Squeezebox Classic but there is no further communication between the two after the discovery has been done.

I have tried setting the IP address of the host server (i.e. the unRAID server hosting the Roon Docker application) on the Squeezebox Classic but it is still unable to connect to the Roon server.

I have tried installing Roon Core on a Windows 10 laptop but this shows the same problem – Core can see the Squeezebox but no further communication happens.

Well it looks like I’ve answered/solved the problem:slight_smile:

It appears that the network cable I was using to connect the SqueezeBox to the network was faulty/too long (approx. 20 feet) to enable consistent communication. After testing with a shorter cable the SqueezeBox could see the Roon server and all communication was good.

Only problem now was that the Squeezebox was in another room unable to connect physically to the hifi.

So a quick google/internet search shows that I can set up a Raspberry Pi as a bridged network connection such that a device (Squeezebox Server) can communicate via the Pi’s LAN over WiFi to the network. After configuring the SqueezeBox Classic with a static IP address and providing the IP address of the Roon server everything communicates.

So I now have a Squeezebox classic connected to a Roon Core server via a Raspberry Pi with a combination of Wifi/Lan - happy bunny.