Squeezebox doesn't turn off when connected to roon server

Core Machine (Operating system/System info/Roon build number)

Windows 10, latest build of Roon (don’t know where to find the build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Asus router, LAN connected

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Squeezebox classic

Description Of Issue

When the squeezebox is connected to the roon server, I can’t turn off the squeezebox with the original remote control and it keeps connected to the server. Result: squeezebox and power supply run hot and the server doesn’t go to sleep (so the server computer keeps running 24/7 which is not okay). In the display the roon logo is shown when nothing is being played. I never see the normal screen saver (date / time) that I normally saw when the squeezebox was turned off with the orginal remote control. When I push the play button on the squeezebox remote control, it immediately start playing the playlist. If I make the server go to sleep manually and I push the play button on the squeezebox, it wakes the server (I have never installed wake on lan for the squeezebox classic, so very strange!). When I connect the squeezebox to the normal Logitech Media Server, the squeezebox functions normally. The strange behavior of the squeezebox when connected to Roon just popped up (few weeks ago, everything worked fine, squeezebox could be turned off, to wake the server, I used an app on my mobile phone, server went to sleep when I shut down the squeezebox with the remote control etc.)

Can you please help me? Now I have to plug / unplug the power supply of the squeezebox.

Hi @Sander_vg,

Thanks for your inquiry here. As far as I know, Roon does not perform any WOL by itself. You mentioned that this issue recently started and it was working properly a few weeks ago. Do you recall if anything changed in this setup that would be around the time this behavior started? Also a few other things:

  • How is the squeezebox connected, is it via Ethernet or WiFi?
  • Are you using the newest firmware on the squeezebox?
  • Have you recently installed any Roon/Squeezebox Extensions?

– Noris


Thanks for reaching out to me!

  • You are right: Roon doesn’t perform the WOL. Since approx one week, the Squeezebox wakes the ROON Server computer (HP Notebook) which was a week ago not the case (and I didn’t change anything in the settings)
  • Squeezebox and server are connected via 1GB Ethernet
  • Yes, newest firmware is installed (I cannot confirm as I cannot enter the settings menu anymore while the squeezebox is connected to roon… see below)
  • I have not installed any extensions that I am aware off
  • only two changes: (1) a new power supply for the Squeezebox (old one broke down, but of course, this can’t have any impact on this behavior) and (2) update Roon was installed. Not sure whether the newest update had changes with regard to dealing with Squeezebox clients?

Also, now I can change the volume, pause the music, start playing the music with the remote from the Squeezebox. I’m not 100% sure, but I cannot recall this was possible one week back. And I cannot enter the settings menu in the Squeezebox when connected to roon (eg. to disconnect or change another music server, select a different network etc.).

I have also a Squeezebox touch, but nothing changed with regard to the touch (stil working like breeze :-))

As far as I can tell, Roons idea is to leave everything running 24/7/365.

Hi @Sander_vg,

Thanks for providing that info. I just want to clarify one aspect here:

By “normally” here you mean to say that the Squeezebox allows the server to sleep after being inactive for a set period of time and that pressing play while the server is asleep does not wake it up?

Also, just in case you haven’t tried this yet, can you perform a full reboot (power off, wait 30 seconds, power back on) on your Core, Endpoint & Network to see if that changes anything?


Yes, when ‘disconnecting’ the classic, the server goes to sleep when only the Touch is connected.

I have tried to reboot several times, but didn’t change anything.

To clarify: biggest issue is dat the core doesn’t go to sleep anymore. I listen maybe 1 hour a day on average so a waste of energy to keep the server running 24/7

Hi @Sander_vg,

Thanks for that confirmation. I would next like to see what happens in the Roon diagnostics when this issue occurs.

Can I please ask you to reproduce the behavior you mentioned and note the exact local time + date in your country of when it occurs? E.g… 4:11PM on 5/22/19?

After receiving this info, I can go ahead and enable diagnostics mode for your account and see if there is perhaps any other indication as to what is going on in the logs.


Hi Noris,

I did as you requested. Starting position:

  • Squeezebox turned off (no power supply)
  • Set server to hibernate after 5 minutes of inactivity (to see quick results, normally I let it hibernate after 2 hours of inactivity). The test was performed 24 may 2019. Time is local Amsterdam time.

19:29hr: turned on Roon server by sending magic packet from android phone
<Waiting to see whether the server goes to hibernate after 5 minutes>
19:36hr: server is sleeping, so hibernate functions correctly
19:37hr: Plug in the power supply of the squeezebox. The server keeps sleeping.
19:39hr: Press on/off button Squeezebox. The Roon Server awakens (strange! in the past the Roon Server ONLY responded to the magic packet)
19:40hr: start playing music on Squeezebox
19:42hr: stop playing music and do nothing. Wait to sill whether Roon Servers hibernates after 5 minutes.
21:00hr: Roon server still awake. Doesn’t work correctly anymore! Push the on/off button of the squeezebox, so the screen saver image is displayed (but the squeeze doesn’t really turn off, because when I push ‘play’ it directly continues playing the last song… in the past, it didn’t do anything while pushing play. I had to turn on the squeezebox with the remote first)
21:10hr: Roon server still awake. So doesn’t work correctly.
21:21hr: Roon server still awake. Now unplug the power supply from the squeezebox.
21:36hr: Roon server still awake. So still doesn’t work correctly. Let the Roon Server hibernate manually.
21:45hr: Wake roon with magic packet from android phone
22:02: Roon server still awake. So still doesn’t work correctly. Restarting PC.
22:22: Roon Server sleeps. Turned on Roon Server by sending magic packet from android phone

22:27: Roon Server sleeps. So works correctly again after the restart.


  • Hibernate after 5 minutes works correctly when Squeezebox is not connected. Wakening the server with the android phone by sending the magic packets functions correctly
  • When the squeezebox is connected (connect the power supply) and when music is played the Roon Server doesn’t hibernate anymore. Even when disconnecting the Squeezebox, the Roon Server still doesn’t hibernate. A forced restart is necessary to make the Roon Server wake / hibernate correctly again. But when the Squeezebox is reconnected and used, it doesn’t hibernate anymore.

This used to work okay, but stopped working (my hypothesis) after the most recent update from Roon.
In that period the Roon Server received a few updates, so the IP adress was changed and the Wake on Lan settings were changed. I have corrected this and when no squeezebox is connected, the hibernate / wake functions correctly, so it doesn’t seem to be a problem with the server itself. The Server is a HP Elitebook laptop.

Hope this gives some information to solve this issue.

Hi @Sander_vg,

Thank you for providing that information.

Now that I have these timestamps, I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

Once this is received I will ask QA to take a look and see if perhaps there is any additional information contained in the logs. There may not be, but we can check.

– Noris

Hi Noris, can you report any progress on this? Should I take certain actions with the Roon Server for you to collect the required data?

Hi @Sander_vg,

Great timing. I just heard back from QA regarding analysis and they have not been able to reproduce this behavior on their end. When the squeezebox device we have in the lab is paused the server goes to sleep as expected and trying to wake up the server via Squeezebox does not trigger the WOL command.

Next, we should confirm which process exactly is triggering the PC’s wake. For this, can I ask you to reproduce the issue once more (have the squeezebox wake up the server) and:

  1. Open Command Prompt as Administrator
  2. Run the following command: powercfg -requests
  3. Send us the output from that command


Hi Noris, here the requested output of the powercfg command (I changed my name with xxx for privacy reasons. If you need the name of that folder, please let me know and I can send it to you by email):

PS C:\Windows\system32> powercfg -requests

[PROCESS] \Device\HarddiskVolume2\Users\xxxxx\AppData\Local\Roon\Application\Roon.exe


[SERVICE] \Device\HarddiskVolume2\Windows\System32\SearchIndexer.exe (WSearch)
Indexeren in Windows Search



Hi @Sander_vg,

Thank you for sharing that output, yes it contains the necessary information and I have attached the output to your case notes to QA. While we wait to hear back can you please let me know if perhaps you have another Windows PC around the house that you can use to temporarily host the Roon Core on? It would be interesting to know if this behavior only occurs for that one specific PC or if this behavior carries across multiple Roon installs.

– Noris

Hi Noris, nope, I don’t have another windows PC to test it. Only a synology NAS. I have tested the behavior with another Squeezebox (the Touch) and has the same behavior. So I think it’s safe to asume it must have to do with the interaction with the PC and Roon and probably not all PC’s will show this behavior (otherwise you should have been able to reproduce the same behavior. Let’s hope that QA can find a solution!

HI @Sander_vg,

Thanks for the additional update, I have added this to your case notes as well. I will be sure to let you know once I have an update regarding next steps.

– Noris

Hi @Sander_vg,

I spoke to the technical team regarding your case today and I have some feedback for you here.

For the squeezebox to have the Clock face, you would need to have this configured in the squeezebox device setup tab, please see here for more info in this regard.

Roon does not perform any WOL functions, so what you are seeing is likely an interaction between your PC and the Squeezebox.

I can’t say for sure what exactly is triggering the WOL or preventing the Core from sleeping, but if this issue does not occur on other PCs nor on our end, it is possible that you have something installed that is keeping the connection to the squeezebox active.

As a follow-up step, I would check to see if this behavior still occurs if Roon is re-installed or if it occurs from another PC.

– Noris


I have already tried reinstalling roon before sumitting this support request. Didn’t solve the issue.

What do you mean with: “you have something installed that is keeping the connection to the squeezebox active”. Something on the PC or something on the Squeezebox? I have nothing intentionally installed on the squeezebox and the PC has hardly any other software because it is a PC dedicated to serve as a roon server. What kind of software or packages is the technical team referring to?

What was the conclusion from the powercfg data I shared with your technical team?

Suppose it doesn’t occur with another PC (I agree with the technical team that it is probably something with the interaction between PC - Roon - Squeezebox). What would be the next step in that case?

In the meanwhile, I will test whether the PC will go to sleep when Roon is not running on the PC. I will let you know the result.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.