Squeezebox Radio playback issues

Hi I am having issues with using Roon on my squeezebox radio unit. I have searched the forum for help but can’t find anything I have not already tried and.csnt seem to find answer.

First off it keeps dropping playback after about 10 mins for no reason and it never seems to activate the now playing screen.

I am connected using wireless as unit is in Kitchen, I have the squeezebox support switched on and the flac compression is on in the device settings. The unit is very near the wireless ap which is a Unifi Uniti and signal strength is not a problem. I know the Radio is only wireless g but it should manage 44.1 streams as they are not that big. It worked fine when I used LMS and my old SB touch was fine until it died.

Anything you can suggest other than run ethernet as this is just not feasible.

Hey @CrystalGipsy — Thank you for sharing your report with us, I appreciate it!

To start, can you please provide a brief description of your current setup using this link as a guide. Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

While I know that running an ethernet is not idea, would it be possible to move the Squeezebox temporarily and connect via ethernet just to confirm what the experience is like that way? Doing so will definitely help us narrow down possible causes of the behavior you’re experiencing.

Are you only having difficulties with this one endpoint? If you play to a wireless remote device do you experience the same thing?


My network setup is Netgear r8000 acts as wired router only that feeds Unify Uniti AC Pro AP and cisco switch that connects NAS and Roon core.
All other endpoints use wireless and are fine, it’s just the Squeezebox radio. We use this for mainly streaming Tidal to rather than my library. It played fine this morning with no pauses at all but just did it again whilst listening, wonder if it could be internet related and the lack of buffer on the Radio is causing issue as Tidal can struggle with high latency. It’s odd as it can just stop mid track. If you press play again straight away it resumes again but it may stop again later.

Hi @CrystalGipsy — Thanks for the additional info, it definitely helps!

Just to rule out possible networking issues, have you tried using a wired connection on the Squeezebox radio? Knowing the results of that test will definitely help narrow down the possible root cause of the behavior you’re seeing.

We use this for mainly streaming Tidal to rather than my library

Have you tried streaming your library here instead of TIDAL? Do you experience the same behavior when doing so or is this only with TIDAL streaming?


Sorry @dylan not been able to test until today. The radio still pauses/stops tracks when playing local flac streams to. So its not just Tidal. I looked at the logs bit can’t find anything that looks to be the issue. I have no way of using it with ethernet as I don’t have a cable long enough without it being hazardous.

Going to try changing my WiFi channels to see if it helps. It was pretty congested on the one I am using when I looked as the radio does run on old wireless g tech it might be borderline for it. As its intermittent I think this might be the issue. If it still carries on then its time to trade up to something with newer wirless tech.

Well changing channel had no effect, but a reboot of Roon and router have. Let’s see how long it lasts. Album finished without further incident and radio has taken over and seems to be working.

Still seems to be working ok for the time being.

1 Like

Damn it’s back again whilst listening to internet radio. Looking at Roon it’s still playing as its still counting
but no sound from the squeezebox. Checked my WiFi all fine no other ap on the same channel.

Hmm I switched back to playing a discovery playlist Roon recommend and all’s been fine since. Really wish I new what was causing this. It’s the only endpoint in the house giving me trouble. Perhaps it’s time to call it a day and upgrade to Bluesound or a Sonos.

Hey @CrystalGipsy — Sorry to hear your troubles have returned!

I’d like to make a few suggestions here that should allow us to narrow down a possible cause of this behavior you’re experiencing.

  • If at all possible, moving the Squeezebox device closer to the router and using a wired connection to test would be a great data point. If you do not continue to experience this behavior with that set up, that would be a good indication of possible networking difficulties.
  • If there is any active antivirus or firewall on your Core machine, try disabling it and see if the experence improves.
  • You mentioned above you’re using a Cisco switch. Is there any chance that the switch is a managed switch, or is it unmanaged? What is the exact model here? If you remove the switch from the equation and connect directly to the router, do you still experience this behavior?


Hi @dylan it’s an umanaged switch and is connected directly
to the router and only has the roon core and Nas connected to it. Core machine runs rock so nothing else going on there. I might remove the switch and just patch directly to the router as my next step. If no better then I’ll try a long Lan cable but it’s really not suitable for long-term testing I just can’t have one running along the floor with kids in the house.

2 posts were split to a new topic: Playback issues with Squeezebox Radio