Squeezebox Touch is not turning On / Off

Core Machine (Operating system/System info/Roon build number)

Asrock Q1900-ITX / Windows 10 - 64 bits / Roon latest (installed 03/20/20)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

roon core Ethernet - players under Wi-Fi
router Sercomm H500-s

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Squeezebox Duet - wire to active speakers
Squeexebox Touch - wire to stereo amplifier

Description Of Issue

Despite I know Sq players are “dumb” so I can’t acess to my music and/or step up and down volume by Sq remote, I can’t see the album cover if I am not manually switching on the Touch player to get the “playing” icon and see the cover. If I do not, music will be played without any indication on the player (screensaver is not changing at all). On the other side if I decide to manually turn on to get the cover or VU/Meters and I switch off from Roon the player, the Sq Touch keep on, with the shining screen and the power compsumption on.

If I decide to turn it off while playing, music stops but on the Roon control it still appears as playing.

About Duet, I know it too just by power compsumption and led color.

Thank you for your support

Hi @Jose_Alconchel,

I tried the Squeezbox touch I have on my end, and when I start music playback, the screen automatically switches from the clock screensaver to the album art of the currently playing track, you are saying that this does not occur on your end? Also, when music playback is stopped, I see that it reverts back to the clock screensaver after ~30 seconds.

I would suggest you take a look at the Squeezebox Settings -> Screen -> Screensavers menu to set the (when playing/when stopped/when off) properties of the device to your desired values and see if that helps. On my end I have when playing set to Now Playing, when stopped to Digital Clock and when off to Digital Clock (Black) but you may need to edit these based on your preferences.

Hello Noris

The problem I describe is the same you have understood. If I am not manually turning on the Sq Touch, it looks as OFF position (digital clock in black) but music is being reproduced.

The settings you are explaining about screensavers are my desirable settings to be under Roon, and the default ones from Touch device.

Hope the ticket I have opened come soon with a solution :slight_smile:

Hi @Jose_Alconchel,

I’m not sure I understand your response here. You’re saying that when you start playback the Squeezebox Touch does not automatically go to the Now Playing screen? Is there any change in behavior if you try to factory reset it?


Factory reset done. Now I am listening through Sq Touch and screen is on Screensaver mode Digital Clock (black) as supposed to be in off position.

So, no cover shown while playing :frowning:

Any other idea?

EDIT: when I am turning off the Sq player from Roon (the on/off icon when choosing from zone section) the screen message on Sq is “pause”. To do so I have manually waken up then player from off.

Hi @Jose_Alconchel,

Are there any firmware updates for your SB Touch? If it’s up-to-date on latest firmware, can you please share a short video of this behavior? I just tried once more on my end and when I start playback to my Squeezebox touch, it automatically switches to the Now Playing screen.

Pressing the power button should trigger a “pause” command, this is the correct behavior. It should automatically enter the screensaver mode once it’s been paused for ~30 seconds.

Ok, so as far as I understand as will be always in pause mode from Roon, I must change the screensaver for pause status to clock Digital Clock (Black) to have the screensaver properly (to my own settings)

Am I right?

Hi @Jose_Alconchel,

Yes, I would set the when stopped status to Digital Clock (Black) and that should automatically switch to the clock once music has been paused.

If you’re still having issues after that, you could also try re-installing Roon:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Verify what the behavior is like with a fresh database first
  • Restore the backup and verify if the issue is still fixed

The final setup already working is

  1. turn manually Sq Touch on
  2. set screensaver when pause to Digital Clock (black) remember: this is how I like it as I want to have minimum display and compsumption once playback is not on

If I manually set to “off” position, the music is playing but no cover shown.

If I manually set to “on” position, I can see the cover while playing and the the previously explained setup about pause screensaver saves my day.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.