Squeezebox Touch only displays Live Radio after playing an album first

Description My Setup

Details on your Core machine (OS, Hardware specs, Roon build)

  • Pinkfaun 2.16X Server, running on Audiolinux, AMD 7 3700 processor, 16GB RAM, 1 HD Samsung SSD 250GB for Roon + 2nd HD Samsung 4TB SSD for local music
  • Roon version 1.8 build: 764
  • HQPlayer: HQPlayer Embedded 4.19.1

Details on your Remote(s) (OS, Hardware specs, Roon build)

  • iPad Air 2 – 64GB - running iPadOS 14.4 - Roon build: 764
  • Samsung S10e – running Android version 11 kernel 4.14.113-20607146 – Roon build :764
  • PC running Windows 10 Pro - Intel(R) Core™ i7 CPU 870 @ 2.93GHz Ram 8GB, Roon build: 764

Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)

  • Ethernet & Wifi Mesh network built on 3 * Asus Zenwifi XT8
  • Connected to Service Provider modem
  • Speedtest connection speed ethernet 93Mbps download – 18Mbps upload
  • Roon Core connected via ethernet, Remote PC connected via ethernet
  • Mobile Remotes connected via Wifi

Audio devices in use

  • T+A 8 DSD connected to Roon Core, using HQPlayerEmbedded, connected via USB
  • Endpoints : 2 * Logitech Squeezebox Touch , connected via Wifi

Library details

  • Local library on separate internal SSD 4TB harddisk in Roon Server
  • Qobuz Hi-fi Sublime streaming service
  • 62197 tracks (3875 albums – 2291 local, 1584 Qobuz)

Description Of Issue

I use Squeezebox Touch (SQBT) as endpoint in Roon.
It works well, but there is was small ennoyance.
I have configured the SQBT to keep the display active as long as possible, but in the morning it is always showing the Clock display.
This means I always have to use my smartphone to get music playing again on the SQBT.

I can live with that, but what is ennoying is the following:
As I mainly play Live Radio on that SQBT endpoint, on my smartphone the Live Radio station remains selected automatically. Great so far. Clicking on Play on my smartphone starts the music playing, but nothing else happens. If I select My Audio Streaming source on the SQBT, again not is happening on the screen itself.

If however, I play an album, the album information (cover, band, album and track title appear automatically on the SQBT screen.
If I then switch to the Live Radio station, I get the ‘Radio station Logo’ and the start/stop controls.

It would be extremely convenient if I do not have to take the detour via an album, to view the Live Radio station on SQBT screen.

I also do assume (/hope) this is a small bug that can be solved very rapidly.
Can you please prove me right?

Dirk

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Why is topic closed without support even looking at it?

Hey @anon90297517, sorry that happened. We were trying out a 14-day auto-close, but it was never intended to close topics that hadn’t been addressed yet. We’ve since fixed this setting and reopened affected threads, but it looks like yours got lost in the mix. :frowning: Again, I’m sorry about that!

Now, onto the squeezebox touch. Tomorrow morning when your SQBT is showing the clock, can you try pressing Play on your live radio station, then Stop, then Play again? Let me know if that wakes up the display, rather than navigating to a different album.

1 Like

Hi Kevin

Thanks for re-opening this topic.

I followed your recomendation, but unfortunately, no luck.
Behaviour stays the same

Dirk

If you guys @support have 5 minutes to spare, I would like you to remind this outstanding problem.
Issue still occuring, despite new Roon release in the meantime.
Dirk

Hello @anon90297517,

Time flies :butterfly: . I can’t believe it’s been three months. Thank you for reviving this.

I’ve looped in our technical team. This thread is now in their queue.

Thanks for your incredible patience :pray:

Hi @anon90297517 ,

Apologies for the delay in getting back to you here, it looks like we missed this one, sorry.

Can you clarify if you are using the Roon app to start the station again or the SQBT itself?

Just to make sure I am understanding you correctly here, the steps used are:

  • Play Live Radio
  • End playback via Roon app or SQBT interface
  • Wait for the screensaver to kick in
  • Try playing the same radio station from the Roon app on Android
  • Squeezebox fails to change the display back to Live Radio and it is stuck on the clock until you play a regular album

Is this correct? If I am mistaken on any of the steps, can you please record a short video explaining what you mean? Thanks!

Hi Noris,

If you allow me, I would like to explain the process (and avoid video for now)

Starting point: playing Live Radio on the SQBT with the logo of the station displayed, together with the control buttons.
Screensaver is disbled completely.

My Roonserver is always on, backups are normally taken during the night.

If backups are skipped, I can continue using the SQBT in the morning, as I left it. all fine.

If backups are taken, then music connection to the SQBT is lost.
I therefore have to use a Roon remote control, mostly my Android phone (same behaviour with different remote controls)

If I now start playing an album/track on my remote control, select my music connection on the SQBT, all starts working fine.
If however, I select Live Radio station 1st, than I don’t get anything on mySQBT display when selecting my music connection.

So my current workaround:
Start to play an album/track on my remote control, select music connection on SQBT , then switch to Live Radio on my remote control, start Play, and my SQBT switches nicely to the Live Station logo.

Hope it is more clear now?
Dirk

This. Make it sticky.

Has been my workaround for months/years and also fixes the issue when the SBT doesn’t allow you to switch between the different display modes (Spectrum View, VU meter, album art,…). Not a big deal for me, and probably not an issue related to Roon, but the SBT itself. Playing a local album and then switching to Internet Radio or Tidal brings back all SBT display modes.

Some extra information/correction

Apparently the music connection on the SQBT is NOT broken during the night when backups are running, when in Album/track mode.

This morning I was surprised/happy to see that my SQBT was still active, and the display was still showing the track (in Daily Mixes) where I stopped it manually on the SQBT display yesterday evening.
I checked backups, all of them have succesfully ran during the night.

So the issue is really related to Live Radio mode, as far as I can see.

Dirk

Hi @anon90297517

We are investigating some issues with the display of Live Radio logos on endpoints. We have a ticket in for this. We appreciate the report!

1 Like