Squeezebox Touch Stopped Working [Resolved - Firmware update]

@support Had been running fine with Roon core installed on my QNAP TS-453A controlled by either my iPhone, iPad or PC client (Windows 10 64bit). Windows client updated itself yesterday and since then the core and Squeezebox Touch don’t see each other. I don’t believe anything else has changed.

RoonServer for QNAP (x64) 1.4 (build 306) QPKG-Version 2017-10-3

Enable Squeezebox Support is selected. Roon server has been restarted, QNAP has been restarted.
Squeezebox Touch does not appear in the Networked devices are of Settings

Have you tried power cycling the Squeezebox?

If you mean power cycling and rebooting, then yes. :slight_smile:

Hi @Bruce_Abrams ---- Thank you for the report and sharing your feedback with us, very appreciated!

Moving forward, just to make sure I am understanding your report correctly, the SBT can’t be seen on any of your remote device, correct? Or, is it just on the Win 10 client?

During your troubleshooting of this behavior have you…

  • Confirmed that there are no active firewalls or antivirus applications running on the Win device.
  • Tried rebooting any relevant networking hardware?
  • Tried doing a factory reset of the touch?


Thanks for your reply, Eric. You are correct in that the SBT cannot be seen from any of my remote devices. While I do have Norton antivirus running on the PC (as has been the case for 5 years), there are no firewalls or antivirus apps running on any of the remote ios devices. Everything has been rebooted and the SBT has been reset, although I’ll try a factory reset again just for grins.

Hi @Bruce_Abrams ----- Thank you for the follow up and verifying that information for me, very appreciated!

Continuing forward, I first wanted to check in and see if the additional factory reset yielded any changes in behavior here with the touch. Just to confirm the touch is completely update in regard to the firmware, correct?

Additionally, I am going to be enabling diagnostics on your account so we can see if there any clues as to why you are suddenly experiencing this issue with the SBT. What this action will do is the next time the app is active on your core machine a diagnostics report containing a set of your “Roon” logs will automatically be generated/uploaded directly to our servers. I will confirm when the report is received so you know we have it.


Hi @Bruce_Abrams — Thank you for your patience here and my apologies for the wait. A few things moving forward.

First, I ran some tests today and while I do not have a SBT I set a MicroRendu up as a “Squeezelite” endpoint just to verify what the experience is like. The endpoint was picked up immediately by the application.

Additionally, I have received the mentioned diagnostics report and will be attaching it to your ticket to be reviewed by our tech team. Your continued patience is appreciated while the team conducts their investigation.

Lastly, may I very kindly ask you to please provide me with a brief description of your network configuration/topology being sure to provide insight into any networking hardware you are currently implementing.


[Addition] LMS is not running anywhere in your setup while Roon is, correct?

Correct in that LMS wasn’t running anywhere on my network. Here’s what I believe happened. Another member of my family attempted to use the SBT as they had in LMS days, but using the touch screen to attempt to search the music library. This action caused the SBT to lose connection with Roon. After I performed a hard factory reset of the SBT, requiring an update of the SBT firmware (which required me to fire up the old LMS in order to provide a current firmware that could support the EDO plugin), I then shut down the LMS and rebooted the SBT restoring full functionality. It would be wonderful if the SBT could be re-purposed as a Roon remote in additional to being an endpoint.

Hi @Bruce_Abrams ---- Thank you for the follow up and sharing the results of your troubleshooting. The update is very appreciated, glad to hear that the SBT is now working as expected.

A few things moving forward. I am going to be closing this thread out and marking it as resolved. If for any reason you begin to experience the same issue with the SBT just drop me a PM and I will be glad to re-open for further troubleshooting.

Secondly, I would recommend posting your suggestion in the 'feature request" section of the community site. This is where we encourage our users to share any ideas for the product with us. Mike (our product manager) regularly monitor this thread so this is truly the best place to have an idea be heard.


This topic was automatically closed after 7 hours. New replies are no longer allowed.