Stability Issues [Ticket In]

Roon Core Machine

OS Name Microsoft Windows 11 Pro
Version 10.0.22621 Build 22621
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name MEDIAPC
System Manufacturer Intel(R) Client Systems
System Model NUC12WSHi7
System Type x64-based PC
System SKU NUC12WSHi7000
Processor 12th Gen Intel(R) Core™ i7-1260P, 2100 Mhz, 12 Core(s), 16 Logical Processor(s)
BIOS Version/Date Intel Corp. WSADL357.0087.2023.0306.1931, 06/03/2023
SMBIOS Version 3.5
Embedded Controller Version 255.255
BIOS Mode UEFI
BaseBoard Manufacturer Intel Corporation
BaseBoard Product NUC12WSBi7
BaseBoard Version M46422-304
Platform Role Desktop
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = “10.0.22621.1413”
User Name MEDIAPC\Media
Time Zone GMT Daylight Time
Installed Physical Memory (RAM) 64.0 GB
Total Physical Memory 63.6 GB
Available Physical Memory 57.3 GB
Total Virtual Memory 67.6 GB
Available Virtual Memory 61.0 GB
Page File Space 4.00 GB
Page File C:\pagefile.sys
Kernel DMA Protection On

Networking Gear & Setup Details

Ubiquiti Unifi POE 48 port switch
1Gb physical connection over CAT6A
Draytek Router
1Gb BT Fibre internet

Connected Audio Devices

None

Number of Tracks in Library

58402

Description of Issue

Having major stability issues. Roon crashes anywhere between 12 - 36 hours of running.
Have no audio devices installed
Music on external SSD drive connected over USB-C. 4TB SSD, but have used 1TB and 2TB as well.
Have tried on Mac M1 Mini, Lenovo Mini PC and another 12650H based PC, Surface Pro Laptop etc. All crash.

Hope you can help.

1 Like

Vincent, just another user here, but I thought it might be helpful if you describe what you mean by “crash”. Does the server process stop running, and music stops playing? Does the user interface (the “remote”) go away? Etc.

Thanks, Bill.

If nothing is playing, the UI disappears and I’m unable to connect from any player.

If it’s playing, the UI can still disappear - but it will likely continue playing. Still can’t connect from other players.

Hope that helps.

Have just disconnected the external SSD and left it with no tracks and no audio devices.

I did think it was the SSD, but have tried it with other storage devices and still get the same results.

It was even unstable on a Mac Studio - got the spinning wheel. Great performance on that.

Regards

Vince

That means the server is still running. Is the UI running on the same Windows machine as the Core, or is it on a different device, when this happens? Is it playing a local file, or from Tidal or Qobuz, when it happens?

This all sounds like a networking issue, if you are playing from a local file. You are using somewhat unusual networking gear. Which version of Draytek router is it?

Yes, UI & Core are on the same machine. However, I tend to use Remote or the UI on another machine to select tracks.

Have not tried the ‘headless’ core on its own yet. Likely to make s difference?

What makes you think it’s a network issue? Everything is local to the Roon server. No weird ports need to be opened - not trying to play from outside my network.

And wouldn’t say it’s ‘unusual’ networking kit either! The Unifi stuff is very popular with the Plex community. I run a local Plex server with no issues, along with an ESXI box, Control4 and other devices. Everything seems to play nicely - apart from Roon. But happy to keep an open mind in order to get things resolved. Maybe I have missed something - happy to be guided and corrected. Grateful for the feedback.

Draytek 2962 on latest firmware.

I only meant unusual in that most people have little use for 48-port PoE switch, and that I don’t recall ever hearing of DrayTek before.

I mention networking mainly because the remotes can’t connect, even though the server is still running (the music is still playing, so the server must be sending it out, so the Core is still running). And because the symptoms are apparent on a wide variety of host machines, it’s unlikely to be an OS issue. In addition, the DrayTek Vigor 2962 router is more of a small-business router, and incorporates a number of configuration options, one or more of which may be causing problems.

Although: you say there are no connected audio devices? How is the music being played?

The ‘no connected audio devices’ is a test I’m undertaking right now. I’m not playing anything, and there are no tracks in the database. Just want to see if that trips over.

I have 4 of the PoE switches connected on a 10Gb fibre backbone - at home :slight_smile: Lots of connected devices which all seem to work well together.

Draytek probably more popular in the UK/EU than other regions. Everything that is not required on the router/firewall is disabled. Unlikely that any weird services are running that block things. And not accessing remotely, so only the bare minimum of ports are open.

If there is anything specific I need to open please let me know. My Roon box is on an internal static IP so port forwarding if required is relatively straightforward.

Again, open to ideas. Could even try it on a segregated LAN with a basic 4G router.

Hi @Vincent_Haines

Another fellow user here.

Trying to get my head around this.

If you play music, it plays but your Roon Remote/Client (phone/tablet or other PC (not core)) goes blank.

And the same with no playing music.

I am not sure it’s a core crash issue. It’s suggests a network problem.

I have a full Ubiquiti Unifi network and I keep it very straight forward.

Are you operating VLANs?

As the DrayTek is your router, got it, what are you APs?

Is your ISP box in a modem state?

Sorry for the questions. Just trying to establish in my head a possible line of attack.

Whilst I can appreciate your scepticism, Roon needs a robust simple network. Unmanaged switches ideally (managed can be done as long as near default or a full dedicated VLAN for the audio network).

If you can advise on the above questions it’ll help

:innocent:

Well, when it was playing, and it didn’t stop even though the UI had gone away, what was the connected audio device, and how was it connected?

Cambridge Audio CXN V2 via Airplay.

Since posting the original message a few hours ago, the Roon UI has now disappeared from view. Do not see any obvious Roon-type services in Task Manager either, though not certain what I should be looking for.

Again, not connected to any audio devices, no tracks in the library.

Try rebooting everything :neutral_face:

I suspect Roon will have to look at your log files to get much further with this. You could probably find them yourself, but I can’t help with that, as I don’t run Roon on Windows.

Edit: here’s where to find them: https://help.roonlabs.com/portal/en/kb/articles/logs

First off, thanks to those that replied - appreciate the guidance.

I have now installed just Roon Server on the same machine it it seems stable. Will continue to monitor.

Again, many thanks.

Vince

1 Like

Typical - the law of s&d!

Now have potentially the same issue that is manifesting itself in a slightly different way.

Happily playing music - Core running on one PC, UI on another, output to Cambridge Audio CXN V2.

After a few tracks, music stops. UI on PC goes back to ‘unable to locate core’. After 20 - 30 seconds or so, reconnects, but does not start playing again - though tit remains on the last track that was playing.

Will try a different PC, and the UI from a tablet as well.

It is an improvement - at least CORE is restarting if that is the problem.

Next time this happens, try rebooting just your router. Leave everything as it was when the issues occur.

I’m wondering if your DrayTek is playing silly games with your network.

The DrayTek has multiple LAN ports. I’m not up to speed on the DrayTek, but on a Edgerouter you could bridge the ports. Is this similar to yours or does it act as a mini switch?

Many of us fellow music lovers want everyone to enjoy music with Roon as we do.

:innocent:

I’d guess that if you looked in the logs, you’d see some kind of “something disconnected! Rescanning network…” message. That’s what I found when I was having similar problems.

Turns out my routers had a kind of dynamic network reconfiguration system running, where they’d reassign certain WiFi devices to different channels if they thought it would improve throughput, on the fly. The WiFi devices would disappear momentarily when that happened, and the Roon Core would notice, fly into a panic, stop whatever was playing anywhere, and rescan everything to find out what was going on. But it would not restart what had been playing – I had to fire up a UI and do that manually.

Once I turned the router option off, things became stable.

1 Like

Bill - that sounds very similar to what I’m experiencing. I’ve had the UI on a wired PC today to test and it hasn’t tripped out so far. Will have a look at the Unifi AP controller to see if I can fix the channels. It could also be ‘roaming’ across access points which would have similar results.

Awesome idea - thanks.

Vince

Hey @Vincent_Haines,
We were able to see from your account page that your Roon server has been online recently. Are you still experiencing this issue?

Hi there. Have been travelling so not accessed my music for a while. Just trying again right now.

Thanks